Cisco AM10 no longer switches mode

Bug #1319105 reported by Jody McIntyre on 2014-05-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Undecided
Unassigned

Bug Description

My Cisco AM10 "valet connector" WiFi adaptor

This worked under Saucy but broke when I upgraded to Trusty. I've attached usb_modeswitch.log obtained from turning debugging on.

From before the upgrade, I didn't ever run in debugging mode but syslog entries looked like:

syslog.7.gz:May 7 10:08:34 nyantiger usb_modeswitch: switching device 1307:1169 on 003/025
syslog.7.gz:May 7 10:08:36 nyantiger usb_modeswitch: switched to 13b1:0031 on 003/025

Now there's just:

syslog:May 13 10:37:24 nyantiger usb_modeswitch: switch device 1307:1169 on 003/010

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: usb-modeswitch 2.1.1+repack0-1ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
Date: Tue May 13 12:02:54 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-02-02 (100 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Release amd64 (20131017)
ProcEnviron:
 LANGUAGE=en_CA:en
 TERM=screen
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-modeswitch
UpgradeStatus: Upgraded to trusty on 2014-05-13 (0 days ago)
mtime.conffile..etc.usb.modeswitch.conf: 2014-05-13T11:51:17.900534

Jody McIntyre (scjody) wrote :
Jody McIntyre (scjody) wrote :

As a workaround, I downgraded usb-modeswitch and usb-modeswitch-data to the saucy versions:

usb-modeswitch_1.2.3+repack0-1ubuntu3_amd64.deb
usb-modeswitch-data_20120815-2_all.deb

I've attached the usb_modeswitch log from this, which worked.

Mantas Kriaučiūnas (mantas) wrote :

Please test if your Cisco AM10 "valet connector" works with new upstream versions of usb-modeswitch (2.2.0) and usb-modeswitch-data (20140529) released 2 weeks ago (already packaged in Debian unstable).

You can download new usb-modeswitch and usb-modeswitch-data deb packages from here:
https://packages.debian.org/sid/usb-modeswitch
https://packages.debian.org/sid/all/usb-modeswitch-data/download

Please install these usb-modeswitch version 2.2.0+repack0-1 and usb-modeswitch-data version 20140529-1 packages from Debian unstable (don't forget to do 'apt-get -f install' to have libjim0.74 installed), reboot your Ubuntu system and test if your problem with Cisco AM10 "valet connector" still occurs with new usb-modeswitch

Lots of other switching related issues (like LP bug #1308895, bug #1192297) are fixed in updated usb-modeswitch (2.2.0+repack0-1) and usb-modeswitch-data (20140529-1) packages from Debian unstable.

Here is debian/changelog:

usb-modeswitch (2.2.0+repack0-1) unstable; urgency=medium
  * New 2.2.0 upstream release
    - Introduction of parameter "HuaweiNewMode", wrapping the standard bulk
      message for all newer Huawei devices;
    - Support for generic fallback config files, combined with OS switch (per
      vendor ID);
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Bump usb-modeswitch-data depends to 20140529
  * Update VCS-* fields to canonical form
 -- Didier Raboud <email address hidden> Mon, 09 Jun 2014 11:21:08 +0200

And here is usb-modeswitch-data debian/changelog:
http://metadata.ftp-master.debian.org/changelogs/main/u/usb-modeswitch-data/unstable_changelog

tags: added: regression-release
Jody McIntyre (scjody) wrote :

That version is still broken; same symptoms.

Sorry for the delay in testing - I lent the laptop to someone. I'll be able to re-test more quickly in future.

Lars Melin (larsm17) wrote :

This may be a conflict with the storage driver, does it make any difference if you remove the hashmark in front of the #SetStorageDelay=4

line of /etc/usb_modeswitch.conf ?

Jody McIntyre (scjody) wrote :

I uncommented that line. Still broken; same symptoms.

Josua Dietze (digidietze) wrote :

I have released an updated version of usb_modeswitch (upstream). This version works very reliably with the Cisco AM10, as tested with my own device.

See
http://www.draisberghof.de/usb_modeswitch

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers