usb_modeswitch not run correctly for 3G dongle

Bug #1314842 reported by renatoram on 2014-04-30
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Undecided
Unassigned

Bug Description

I am using a laptop (Asus N56VZ) with Ubuntu 14.04 LTS (recently upgraded from 12.04 LTS) and until recently none of my 3G USB dongles worked (I have a few). Note that the very same problem occurred on 12.04 and I upgraded early hoping for this issue to go away. It didn't.

After investigation, it seems that usb_modeswitch is't doing its magic:

My test dongle is a Huawei Technologies Co., Ltd. ID 12d1:14c1

According to the udev rules and the usb_modeswitch data I could dig up, the product ID should switch to 14c6 to make it work correctly.

A file named "12d1:14c1" IS in the tgz package of usb-modeswitch-data, but nonetheless this is all I see in /var/log/syslog when I plug the dongle in:

===================================================================================
May 1 00:44:49 rramondalap02 kernel: [ 54.336137] usb 3-1: new high-speed USB device number 3 using xhci_hcd
May 1 00:44:49 rramondalap02 kernel: [ 54.354566] usb 3-1: New USB device found, idVendor=12d1, idProduct=14c1
May 1 00:44:49 rramondalap02 kernel: [ 54.354570] usb 3-1: New USB device strings: Mfr=3, Product=2, SerialNumber=0
May 1 00:44:49 rramondalap02 kernel: [ 54.354571] usb 3-1: Product: Vodafone Mobile Broadband (Huawei)
May 1 00:44:49 rramondalap02 kernel: [ 54.354572] usb 3-1: Manufacturer: Vodafone Group (Huawei)
May 1 00:44:49 rramondalap02 kernel: [ 54.355682] usb-storage 3-1:1.0: USB Mass Storage device detected
May 1 00:44:49 rramondalap02 kernel: [ 54.355814] scsi7 : usb-storage 3-1:1.0
May 1 00:44:49 rramondalap02 kernel: [ 54.355879] usb-storage 3-1:1.1: USB Mass Storage device detected
May 1 00:44:49 rramondalap02 kernel: [ 54.355985] scsi8 : usb-storage 3-1:1.1
May 1 00:44:49 rramondalap02 mtp-probe: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1"
May 1 00:44:49 rramondalap02 mtp-probe: bus: 3, device: 3 was not an MTP device
May 1 00:44:50 rramondalap02 kernel: [ 55.354598] scsi 7:0:0:0: CD-ROM Vodafone CD ROM (Huawei) 2.31 PQ: 0 ANSI: 2
May 1 00:44:50 rramondalap02 kernel: [ 55.355275] scsi 8:0:0:0: Direct-Access Vodafone Storage (Huawei) PQ: 0 ANSI: 2
May 1 00:44:50 rramondalap02 kernel: [ 55.356963] sr1: scsi-1 drive
May 1 00:44:50 rramondalap02 kernel: [ 55.357074] sr 7:0:0:0: Attached scsi CD-ROM sr1
May 1 00:44:50 rramondalap02 kernel: [ 55.357135] sr 7:0:0:0: Attached scsi generic sg3 type 5
May 1 00:44:50 rramondalap02 kernel: [ 55.357264] sd 8:0:0:0: Attached scsi generic sg4 type 0
May 1 00:44:50 rramondalap02 kernel: [ 55.359620] sd 8:0:0:0: [sdc] Attached SCSI removable disk
May 1 00:44:50 rramondalap02 usb_modeswitch: switch device 12d1:14c1 on 003/003
===================================================================================

Now I found a way to make it work:

sudo usb_modeswitch -v 12d1 -p 14c1 -M '55534243123456780000000000000011062000000100000000000000000000'

After some seconds pass the dongle is correctly switched to the new ProductID and works as intended.

I thought the issue was with the usb-storage delay (as per /etc/usb_modprobe.conf ) but even after configuring SetStorageDelay=6 I got no change in behavior.

Still, I hope that someone more accustomed to the internals of usb_modeswitch will find a solution, given that a workaround is already available.

Further info on my machine:

uname -a
Linux rramondalap02 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

All USB ports are 3.0 and I suspect this is related to the issue: on my work desktop, 2.0 ports, the same dongle works right away in 12.04 LTS

Mantas Kriaučiūnas (mantas) wrote :

New upstream versions of usb-modeswitch (2.2.0) and usb-modeswitch-data (20140529) released 2 weeks ago and are already packaged in Debian unstable!

Lots of other Huawei related issues (like LP bug #1192297) are fixed in updated usb-modeswitch (2.2.0+repack0-1) and usb-modeswitch-data (20140529-1) packages in Debian unstable.

Please install usb-modeswitch version 2.2.0+repack0-1 and usb-modeswitch-data version 20140529-1 packages from Debian unstable, reboot your Ubuntu system and test if your problem with Huawei 3G dongle still occurs with new usb-modeswitch

You can download new usb-modeswitch and usb-modeswitch-data from here:
https://packages.debian.org/sid/usb-modeswitch
https://packages.debian.org/sid/all/usb-modeswitch-data/download

Here is debian/changelog:

usb-modeswitch (2.2.0+repack0-1) unstable; urgency=medium
  * New 2.2.0 upstream release
    - Introduction of parameter "HuaweiNewMode", wrapping the standard bulk
      message for all newer Huawei devices;
    - Support for generic fallback config files, combined with OS switch (per
      vendor ID);
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Bump usb-modeswitch-data depends to 20140529
  * Update VCS-* fields to canonical form
 -- Didier Raboud <email address hidden> Mon, 09 Jun 2014 11:21:08 +0200

And here is usb-modeswitch-data debian/changelog:

usb-modeswitch-data (20140529-1) unstable; urgency=medium
  * New upstream release
    + New devices
     [0408:f001] SpeedUp SU-8500U
     [04cc:226e] Nexperia TM TD-SCDMA
     [04cc:226f] Nexperia TM TD-SCDMA (Variant)
     [04fc:2140] Sunplus Techn. SU-3200U
     [0b3c:f00c] Olivetti Olicard 500
     [0b3c:f017] Olivetti Olicard 160
     [0bdb:190d] Ericsson F5521gw
     [0bdb:1910] Ericsson F5521gw (Variant)
     [0fce:d0df] Sony Ericsson EC400
     [1410:5055] Novatel MiFi 4082
     [19d2:1232] ZTE MFxxx
     [1c9e:9101] Emobile D21LC (Variant)
     [1c9e:9401] Emobile D21LC
     [1c9e:9d00] Prolink PCM100
     [2020:f00f] SpeedUp SU-8000U
     [23a2:1010] Titan 3.5G
    - Substantial change in handling of Huawei devices
    - Generic udev rule and additional generic configuration files
      (as fallback for unknown models or as OS-specific catch-all)
  * Bump Recommends/Breaks against usb-modeswitch to 2.2.0
  * Update VCS-* fields to canonical forms
 -- Didier Raboud <email address hidden> Mon, 09 Jun 2014 11:19:43 +0200

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-modeswitch (Ubuntu):
status: New → Confirmed
madbiologist (me-again) on 2015-10-13
tags: added: trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers