[FFe] merge usb-modeswitch 2.1.1+repack0-1 from Debian unstable

Bug #1280546 reported by karmen on 2014-02-15
68
This bug affects 18 people
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Wishlist
Mathieu Trudel-Lapierre

Bug Description

The usb-modeswitch package that we have currently in Ubuntu 14.04 is totally outdated - ver 1.2.3 is 2 years ago (not updated since 12.10 !!!).
7 releases have been pushed since then and added new features and bugfixes.
I therefore ask to sync 2.1.0 from Debian testing or sid - there are no bugs reported against usb-modeswitch in Debian and there is lots of bugs in current Ubuntu package :(

I suggest simply sync package from Debian and drop all Ubuntu-specific patches, because usb-modeswitch has build-deps only on jimsh and libjim-dev from jimtcl source in universe.
I think it's easier to include jimtcl package (written in plain C) to main archive instead of maintaining own implementation of usb_modeswitch_dispatcher.
Also new usb-modeswitch 2.x has upstart and systemd integration!

Here is debian/changelog since current Ubuntu release:

usb-modeswitch (2.1.0+repack0-1) unstable; urgency=medium
  * New 2.1.0 upstream release
    - -I flag meaning reversed, default is to skip SCSI inquiry
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Bump usb-modeswitch-data depends to 20140129
  * Bump Standards-Version to 3.9.5 without changes needed
  * Add get-orig-source target to do the automatic repacking
 -- Didier Raboud <email address hidden> Mon, 10 Feb 2014 12:58:03 +0100

usb-modeswitch (2.0.1+repack0-2) unstable; urgency=low
  * Update the systemd patch to change the systemctl path to fit
    Debian's (Closes: #725394) - thanks to Ralf Jung
 -- Didier Raboud <email address hidden> Mon, 30 Sep 2013 10:57:27 +0200

usb-modeswitch (2.0.1+repack0-1) unstable; urgency=low
  * New 2.0.1 upstream release
    - Switched to libusb1.0
    - Major code and debug output cleanup
    - Man page corrections and additions
    - Experimental systemd and upstart integration
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Refresh patches for 2.0.1
  * Update Build-Depends to add libusb-1.0-0-dev and pkg-config
  * Incorporate support for upstart and systemd
    - patch the dispatcher to correctly check if upstart or systemd are running
    - install the upstart init file and the systemd service file
 -- Didier Raboud <email address hidden> Wed, 18 Sep 2013 19:53:11 +0200

usb-modeswitch (1.2.6+repack0-1) unstable; urgency=low
  * New 1.2.6 upstream release
    - Several changes to streamline compiling as part of larger
      projects, mostly in Makefile;
    - fix compiler warnings appearing in certain build environments;
    - new Quanta procedure for Quanta 1K3 LTE;
    - fix for error with cascaded hubs in dispatcher script.
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Replace 04_cope_with_repack patch by one to to use the
    package-provided jimsh and libjim.
  * Bump usb-modeswitch-data depends to 20130607.
 -- Didier Raboud <email address hidden> Sat, 08 Jun 2013 18:07:17 +0200

usb-modeswitch (1.2.5+repack0-2) unstable; urgency=low
  * Upload to unstable.
 -- Didier Raboud <email address hidden> Mon, 06 May 2013 17:36:17 +0200

usb-modeswitch (1.2.5+repack0-1) experimental; urgency=low
  * New 1.2.5 upstream release
    - Initial support for MBIM devices, use with data package >= 20121109;
    - checking for these is the automatic default, new parameter
      NoMBIMCheck prevents the check per device in case of problems; new
      global option to set "delay_use" of usb-storage (as low values may
      prevent mode-switching);
    - fix for handling multi-configuration devices (thanks to Bjørn Mork
      for advice).
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Bump usb-modeswitch-data depends to 20121109.
  * Bump Standards-Version to 3.9.4 and debhelper B-D to 9 without
    changes needed.
 -- Didier Raboud <email address hidden> Tue, 20 Nov 2012 10:45:07 +0100

usb-modeswitch (1.2.4+repack0-1) experimental; urgency=low
  * New 1.2.4 upstream release
    - Additional interface checks to prevent sending UFI commands to
      non-storage interfaces (prompted by more ambiguous device IDs
      popping up);
    - Change in SierraMode for handling newer devices which caused an
      error abort before;
    - Makefile fix for parallelized make runs.
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Drop patch to disable logging as was (temporarily) enabled in 1.2.3.
  * Refresh patches.
 -- Didier Raboud <email address hidden> Tue, 28 Aug 2012 11:13:00 +0200

Jackson Doak (noskcaj) wrote :

This won't be fixed in 13.10, but i'll see if i can fix it in trusty

tags: added: upgrade-software-version
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-modeswitch (Ubuntu):
status: New → Confirmed
Changed in usb-modeswitch (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
Susan Cragin (susancragin) wrote :

usb-modeswitch version
Version 1.2.3 (C) Josua Dietze 2012

usb-modeswitch-data upgraded to 20131113-1 (Which is good) but now incompatible with usb-modeswitch and will not install.

summary: - new upstream version of usb-modeswitch 2.1.0+repack0-1
+ [FFe] sync current version of usb-modeswitch 2.1.0+repack0-1 from Debian
+ testing (Trusty has 2 years old version)
description: updated
tags: added: trusty
description: updated

2.1.1+repack0-1 has landed in debian unstable:

usb-modeswitch (2.1.1+repack0-1) unstable; urgency=medium

  * New 2.1.1 upstream release
    - "Interface" parameter was not working as expected, fixed
      (LP: #1261923)

  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.

  * Bump usb-modeswitch-data depends to 20140327
  * Append CPPFLAGS to CFLAGS

 -- Didier Raboud <email address hidden> Tue, 01 Apr 2014 13:28:36 +0200

No, it should not be blindly synced to the archive; we've ported it to C for a good reason being in the boot sequence; having an impact from loading a Tcl interpreter for just one tcl script...

Changed in usb-modeswitch (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Triaged → In Progress
summary: - [FFe] sync current version of usb-modeswitch 2.1.0+repack0-1 from Debian
- testing (Trusty has 2 years old version)
+ [FFe] merge usb-modeswitch 2.1.1+repack0-1 from Debian unstable
Changed in usb-modeswitch (Ubuntu):
status: In Progress → New

This will still require the FFE (coming up) for a new usb-modeswitch-data to be synced to be accepted.

The FFE for usb-modeswitch-data is bug 1280548

Iain Lane (laney) wrote :

Ok, Mathieu knows most about this and if he thinks this is sensible then let's do it for 14.04 (not sure why it got so late though...)

Please make sure to watch out for bugs - subscribe to the package if you're not already, and follow up with uploads / SRUs as appropriate.

Changed in usb-modeswitch (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-modeswitch - 2.1.1+repack0-1ubuntu1

---------------
usb-modeswitch (2.1.1+repack0-1ubuntu1) trusty; urgency=medium

  * Merge with Debian unstable; remaining changes: (LP: #1280546)
    - patch to rewrite dispatcher to C.
    - debian/patches/redirect_dispatcher_output.patch: redirect all dispatcher
      output when called from udev to /dev/null.
    - Replace libjim depends with libpipeline-dev, libudev-dev.
  * Fixed some bugs in dispatcher rewrite. (LP: #1155975)
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 07 Apr 2014 11:39:41 -0400

Changed in usb-modeswitch (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers