Teracom T-U500 EVDO modem ( 15eb:7153 ) does not get detected

Bug #1210119 reported by Aditya2204 on 2013-08-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Undecided
Unassigned

Bug Description

I recently purchased a Teracom T-U500 EVDO modem for use with BSNL network.

However, on plugging in the modem does not get detected.

I have tried using both the default usb_modeswitch packages and also the latest ones given on the modeswitch site.
I have also tried it on USB 2.0 and 3.0 ports.

I have also tried it on Ubuntu 12.10 x64, i386 and Ubuntu 13.04 x64.

In none of the cases could I get it to detect.

Surprisingly, the modem gets detected when these packages are installed and also show up in the Network Manager.

Here is a file with dmesg and lsusb logs given.

Aditya2204 (aditya2204) wrote :
Aditya2204 (aditya2204) wrote :

One thing though. Lately, I used an official Linux client in .deb format that is present in the storage in the modem accessed via Windows and somehow got it running.

Thereafter, I got successfully connected to the internet.

Also, the method works on both 12.10 and 13.04 with usb_modeswitch removed.
I also, disable the NetworkManager for completely while using it.

Lars Melin (larsm17) wrote :

Not a usb_modeswitch problem, 15eb:7153 has been in the usb_modeswitch data package since Aug 2012.
dmesg shows a disconnect of device 6 (the hub) and device 8 (the 3G dongle connected to that hub).

Arpan (arpan-patwari) wrote :

I got the solution(Only if you have a laptop or neighbor's wi-fi password)

copy the .deb package and try installing by

sudo dpkg -i <package>.deb

it will install but still not run... Go to the /opt/ folder and there you will find the <3GModem>folder

cd /opt/3GModem & ls

Here you will find the ModemClient script file..run it
./ModemClient

It will show some missing dependencies, install them via another internet connection (Go to the nearby cafe or borrow someone's Ethernet)

sudo apt-get install <required dependencies>

It will run but connection might fail due to root privileges so open another terminal and type
"sudo /opt/3GModem/ModemClient"

It worked on my laptop and so should yours by the way i am using 13.10 ubuntu version

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers