Can't use Nokia N8 in Modem mode

Bug #1076016 reported by Muelli on 2012-11-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Undecided
Unassigned

Bug Description

I'm trying to use my Nokia N8 with Linux. I have selected "modem" mode and when I plug it in, dmesg has the following:

[401560.756152] usb 1-2: new high-speed USB device number 87 using ehci_hcd
[401560.895247] scsi109 : usb-storage 1-2:1.0
[401561.893772] scsi 109:0:0:0: CD-ROM Nokia S60 1.0 PQ: 0 ANSI: 2
[401561.900207] sr0: scsi3-mmc drive: 0x/0x xa/form2 tray
[401561.905507] sr 109:0:0:0: Attached scsi CD-ROM sr0
[401561.907448] sr 109:0:0:0: Attached scsi generic sg1 type 5

I tried to eject manually both, /dev/sr0 and /dev/sg1. To no avail.

lsusb is:
Bus 001 Device 050: ID 0421:0396 Nokia Mobile Phones
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 64
  idVendor 0x0421 Nokia Mobile Phones
  idProduct 0x0396
  bcdDevice 1.00
  iManufacturer 1 Nokia
  iProduct 2 N8-00
  bNumConfigurations 1
OTG Descriptor:
  bLength 3
  bDescriptorType 9
  bmAttributes 0x00
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 35
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 4 Bulk transfer method configuration
    bmAttributes 0x80
      (Bus Powered)
    MaxPower 500mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 8 Mass Storage
      bInterfaceSubClass 6 SCSI
      bInterfaceProtocol 80 Bulk-Only
      iInterface 6 USB Mass Storage Interface
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0200 1x 512 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x01 EP 1 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0200 1x 512 bytes
        bInterval 0

Sure, "Nokia suite mode" works well enough, but it's quirky as I need to set up the operator on my laptop. I would like to use it in modem mode.

I expected usb-modeswitch to automatically switch it from the CDROM drive to a network interface (or whatever the phone implements).

FWIW: I tried to send to known Nokia messages, i.e. sudo usb_modeswitch -v 0421 -p 0396 -M 5553424312345678000000000000061b000000020000000000000000000000 but to no avail.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: usb-modeswitch 1.2.3+repack0-1ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic 3.2.30
Uname: Linux 3.2.0-32-generic x86_64
ApportVersion: 2.0.1-0ubuntu14
Architecture: amd64
Date: Wed Nov 7 15:52:01 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110201.2)
SourcePackage: usb-modeswitch
UpgradeStatus: Upgraded to precise on 2012-09-06 (62 days ago)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers