Philips Xenium as a mass storage device lost mounted volume in one second

Bug #1073234 reported by Nikolay Morozov on 2012-10-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Undecided
Unassigned

Bug Description

I have Inserted Philips Xenium Phone as USB Mass Storage after one second it diappears. The /dev/sdg device is also missing. Usiging Ubuntu 12.04 I have no such problems.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: udev 175-0ubuntu13
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu6
Architecture: i386
Date: Tue Oct 30 20:27:12 2012
InstallationDate: Installed on 2011-11-11 (354 days ago)
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111011)
MachineType: Gigabyte Technology Co., Ltd. GA-MA770T-ES3
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=5931ea2f-b02a-4453-9d7b-58f9a68b34ab ro quiet splash
SourcePackage: udev
UpgradeStatus: Upgraded to quantal on 2012-10-27 (3 days ago)
dmi.bios.date: 08/02/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4a
dmi.board.name: GA-MA770T-ES3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4a:bd08/02/2010:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA770T-ES3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA770T-ES3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA770T-ES3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Nikolay Morozov (nmorozov) wrote :
Nikolay Morozov (nmorozov) wrote :
Nikolay Morozov (nmorozov) wrote :
Nikolay Morozov (nmorozov) wrote :
Nikolay Morozov (nmorozov) wrote :

Booting with 3.2.0-32 Kernel that works OK in 12.04 doesn't resolv the problem => problem is elsevere kernel

Martin Pitt (pitti) wrote :

It seems that usb-modeswitch gets in the way:

Oct 30 20:23:38 nmhome usb_modeswitch: switching device 0e8d:0002 on 001/003

Is this one of those devices which initially appear as a CD-ROM to ship Windows drivers? Then usb-modeswitch is right and it needs to unmount the CD-ROM, switch over to hard disk mode, and get that automounted. Or is this being triggered erroneously?

Changed in udev (Ubuntu):
status: New → Incomplete
affects: udev (Ubuntu) → usb-modeswitch (Ubuntu)
Nikolay Morozov (nmorozov) wrote :

no after umounting device disappers from system completly.
in 12.04 works perfect.

Nikolay Morozov (nmorozov) wrote :

No doen't attach like CDROM
look this
Oct 30 20:23:38 nmhome kernel: [ 90.183655] sd 7:0:0:0: >[sdf] Attached SCSI removable disk

Changed in usb-modeswitch (Ubuntu):
status: Incomplete → New
Nikolay Morozov (nmorozov) wrote :

when i attach device it ask me how to show. (Mass Storage, WebCam, COM Port). I have selected Mass Storage

Nikolay Morozov (nmorozov) wrote :

testing with COM Port no problem (GSM Modem) and webcam. Have no problem only "Mass Storage" is buggy...

Nikolay Morozov (nmorozov) wrote :
Nikolay Morozov (nmorozov) wrote :

represented on 12.10 amd64

tags: added: amd64
Nikolay Morozov (nmorozov) wrote :
Nikolay Morozov (nmorozov) wrote :

lsusb see the device

Nikolay Morozov (nmorozov) wrote :
summary: - Philips Xenium X513 as a mass storage device lost mounted volume in one
+ Philips Xenium as a mass storage device lost mounted volume in one
second
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers