Huawei E3131 mobile modem not recognized

Bug #1192297 reported by Taleman on 2013-06-18
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Usb Modeswitch Data
Fix Released
Undecided
Mathieu Trudel-Lapierre
usb-modeswitch-data (Baltix)
Medium
Mantas Kriaučiūnas
usb-modeswitch-data (Ubuntu)
Undecided
Unassigned

Bug Description

Modem does not work in 12.04. I heard it does work in 12.10.

It can be made to work in 12.04 by editing /lib/udev/rules.d/40-usb_modeswitch.rules
adding two lines:

# Huawei E3131
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="151a", RUN+="usb_modeswitch '%b/%k'"

and adding file /etc/usb_modeswitch.d/12d1:151a
with contents:

# HUAWEI E3131 (DNA)

DefaultVendor=0x12d1
DefaultProduct=0x151a
TargetVendor=0x12d1
TargetProduct=0x14ac

MessageContent="55534243123456780000000000000a11062000000000000100000000000000"

I copied those file contents from this forum message: http://forum.ubuntu-fi.org/index.php?topic=44160.0

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: usb-modeswitch-data 20120120-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-48.74-generic 3.2.46
Uname: Linux 3.2.0-48-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.3
Architecture: amd64
Date: Tue Jun 18 22:03:55 2013
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-modeswitch-data
UpgradeStatus: No upgrade log present (probably fresh install)

Taleman (tapio-lehtonen) wrote :

I've another Huawei E3131 Variant - ATTR{idProduct}=="15ca" - added this line to /lib/udev/rules.d/40-usb_modeswitch.rules

ATTR{idVendor}=="12d1", ATTR{idProduct}=="15ca", RUN+="usb_modeswitch '%b/%k'"

Also added attached file to /etc/usb_modeswitch.d/ folder (contains the lines bellow):

# Huawei E3131 (Variant)
TargetVendor= 0x12d1
TargetProductList="1506"
MessageContent="55534243123456780000000000000011062000000100000000000000000000"

I think it would be nice to send this file to upstream (usb-modeswitch) developers :)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-modeswitch-data (Ubuntu):
status: New → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

I've sent Huawei E3131 (12d1:15ca) USB modem data to upstream developers, see

http://draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=2&t=1951

Changed in usb-modeswitch-data (Baltix):
status: New → Confirmed
assignee: nobody → Mantas Kriaučiūnas (mantas)
importance: Undecided → Medium
Mantas Kriaučiūnas (mantas) wrote :

New upstream versions of usb-modeswitch (2.2.0) and usb-modeswitch-data (20140529) released 2 weeks ago and are already packaged in Debian unstable!

This Huawei E3131 issue (and lots of other Huawei related issues, like bug #1308895) is fixed in updated usb-modeswitch (2.2.0+repack0-1) and usb-modeswitch-data (20140529-1) packages in Debian unstable.

Please merge usb-modeswitch 2.2.0+repack0-1 package from Debian unstable to Ubuntu Utopic.
Here is debian/changelog:

usb-modeswitch (2.2.0+repack0-1) unstable; urgency=medium
  * New 2.2.0 upstream release
    - Introduction of parameter "HuaweiNewMode", wrapping the standard bulk
      message for all newer Huawei devices;
    - Support for generic fallback config files, combined with OS switch (per
      vendor ID);
  * Repack the upstream tarball:
    - Drop the code copy of jimtcl.
  * Bump usb-modeswitch-data depends to 20140529
  * Update VCS-* fields to canonical form
 -- Didier Raboud <email address hidden> Mon, 09 Jun 2014 11:21:08 +0200

And here is usb-modeswitch-data debian/changelog:
http://metadata.ftp-master.debian.org/changelogs/main/u/usb-modeswitch-data/unstable_changelog

Changed in usb-modeswitch-data:
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: New → Fix Released
xxvirusxx (condor20-05) wrote :

This bug still exist in 14.04.
This modem E3131 (12d1:15ca) work with Debian sb-modeswitch 2.2.0+repack0-1 package.

Mantas Kriaučiūnas (mantas) wrote :

This bug should be fixed in Ubuntu 14.10 (Utopic, see LP bug #1354823), could you test modem E3131 (12d1:15ca) on Ubuntu 14.10 or install backported to Ubuntu 14.04 usb-modeswitch-2.2.0 from ppa:baltix/ppa (https://launchpad.net/~baltix/+archive/ubuntu/ppa )

xxvirusxx (condor20-05) wrote on 2014-08-10:
> This bug still exist in 14.04.
> This modem E3131 (12d1:15ca) work with Debian usb-modeswitch 2.2.0+repack0-1

xxvirusxx (condor20-05) wrote :

@Mantas Kriaučiūnas

I can`t test E3131 on Ubuntu 14.10. Wasn`t my modem. It was of a guy that I helped on forum.

Also today I helped other guy with E3131H. (12d1:1506) and usb-modeswitch 2.2.0+repack0-1 work again

xxvirusxx (condor20-05) wrote :

I forgot :)

E3131H on Ubuntu 14.04 x64

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers