Ubuntu

USB Startup Disk Creator displays one USB device multiple times

Reported by Hegh on 2012-04-30
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Undecided
Unassigned
Precise
Low
Stéphane Graber
Quantal
Undecided
Unassigned

Bug Description

I have one USB storage device plugged in, and the USB startup disk creator displays the device (/dev/sdc) twice, and the partition (/dev/sdc1) seven times - twice with the current free space, twice with no value for free space, and three times with the full size of the device as the free space. I will try to attach a screenshot.

The USB device is an HP v100w 8G flash thumb drive.

I've only noticed the problem after I hit the 'Erase Disk' button (and I have seen it multiple times), but that may only be because I've only maximized the window after hitting that button; it may happen without hitting Erase Disk.

[rational]
When the UI updates on KDE, duplicate device entries are created.

[test case]
1) Start usb creator using the KDE frontend
2) Wipe a device or do another action triggering a refresh of the list
3) Check for duplicates

[regression potential]
Fix has been in quantal for a while, although I'm not personally familiar with Qt, the change seems sane (one line). Worst case scenario would prevent the list from updating at all, so trivial to spot in verification.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: usb-creator-kde 0.2.38
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Mon Apr 30 12:33:17 2012
ExecutablePath: /usr/bin/usb-creator-kde
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120424)
InterpreterPath: /usr/bin/python2.7
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

Hegh (celloman) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.40

---------------
usb-creator (0.2.40) quantal; urgency=low

  [ Dmitrijs Ledkovs ]
  * Increase the height of both source and target treeviews in the GTK+
    frontend. Thanks to Ross Lagerwall.
  * Search Desktop in addition to Downloads directory for ISOs. Thanks to
    Lucian Adrian Grijincu (LP: #761646)
  * Update debian/copyright to copyright specification 1.0
  * Bump standards version to 3.8.3

  [ Harald Sitter ]
  * KDE: don't duplicate entries by improper removal of entries on update
    (LP: #992061)
  * udisks: on successful format the ended callback must be called
  * KDE: strip() ISO labels as some derivates end up having newlines in
    their label (e.g. netrunner)
  * KDE: auto-populate the ISO list with files found in downloads dir
    (LP: #761745)

  [ Jonathan Riddell ]
  * KDE: do not clear formatting list in backend, fix breakage at
    end of format
 -- Harald Sitter <email address hidden> Fri, 06 Jul 2012 13:22:46 +0200

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Released
Jonathan Riddell (jr) on 2012-07-13
Changed in usb-creator (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
tags: added: kubuntu rls-q-incoming
Changed in usb-creator (Ubuntu Precise):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in usb-creator (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Stéphane Graber (stgraber)
description: updated
Changed in usb-creator (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Low

Hello Hegh, or anyone else affected,

Accepted usb-creator into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/usb-creator/0.2.38.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in usb-creator (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in usb-creator (Ubuntu Precise):
milestone: ubuntu-12.04.1 → ubuntu-12.04.2

The fix for the this bug has been awaiting testing feedback in the -proposed repository for precise for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now the package will be removed from the -proposed repository.

tags: added: verification-done
removed: verification-needed
Colin Watson (cjwatson) on 2013-02-13
Changed in usb-creator (Ubuntu Precise):
milestone: ubuntu-12.04.2 → ubuntu-12.04.3
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers