disk image not automatically selected on addition

Bug #978691 reported by James Hunt on 2012-04-11
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned

Bug Description

usb-creator ignores your selected .iso image, and defaults to auto-selecting the first entry in the 'source disk image' window.

Steps to recreate:

1) run 'usb-creator-gtk'
2) click 'Other...' button to select an alternative 'source disk image (.iso) or CD'
3) navigate to your chosen .iso file in the file browser.
4) click 'Open' in the file browser.
5) observe that
5a) the file browser window closes
5b) your chosen .iso has been added to the list of available 'source disk images'
5c) your chosen .iso file is *not* the selected image.

The problem here is that if you don't notice that the image you explicitly specified has *not* been selected as expected, usb-creator will attempt to copy the wrong disk image to your destination disk.

The workaround is obvious, but only once you notice the problem - click to select your already-selected chosen source disk image before clicking 'Make Startup Disk'.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: usb-creator-gtk 0.2.37
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic-pae 3.2.14
Uname: Linux 3.2.0-22-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu1
Architecture: i386
Date: Wed Apr 11 09:18:36 2012
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=C
 SHELL=/bin/bash
SourcePackage: usb-creator
UpgradeStatus: Upgraded to precise on 2012-01-12 (89 days ago)

Related branches

James Hunt (jamesodhunt) wrote :
description: updated
Changed in usb-creator (Ubuntu):
importance: Undecided → High
Anders Jakobsson (john-doe-mxi) wrote :

Another comment here is that with the default window size, and people don't change the window size of an application like this very often, the list boxes are one line high so it's not obvious that it lists previous images in the first place. They should be enlarged to show at least two lines.

Also there is no apparent way to clear the lists.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed

Same goes for usb-creator-kde btw.

Gleb (gleb-q) wrote :

I have the same trouble in 14.04

usb-creator-gtk --version
0.2.23

ii usb-creator-common 0.2.56.2 amd64 create a startup disk using a CD or disc image (common files)
ii usb-creator-gtk 0.2.56.2 amd64 create a startup disk using a CD or disc image (for GNOME)

Yu Ning (yuningdodo) wrote :

I have the same issue.

So I usually invoke it with below command as a workaround

usb-creator-gtk -i my.iso

Yu Ning (yuningdodo) wrote :

I have created a patch for this bug:
https://code.launchpad.net/~yuningdodo/usb-creator/usb-creator.lp978691-select-readded-source/+merge/238286

When a source is added to the list, scroll to it. When a source is re-added, select it and scroll to it.

Could anyone help to review the patch? Thanks in advance.

Seems like this is already fixed (at least it seems so in vivid). I'll mark it Fix Released and we can see whether it needs to be updated as SRU in the other releases.

As for Yu Ning's patch, it's appears to be for a different issue, so I'd open this up as a separate bug -- re-adding sources still needs to be fixed.

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Released
Yu Ning (yuningdodo) wrote :

Checked on vivid daily image (20150306), usb-creator version is 0.2.65.

usb-creator-gtk: a re-added image won't be automatically selected
usb-creator-kde: a re-added image will be automatically selected, and will auto scroll to it.

So I think we should still keep this bug open for the gtk frontend.

Fair enough; we'll close this bug with the proposed merge proposed. I also tested it did as advertised -- even the scrolling works in a limited fashion.

summary: - usb-creator ignores selected source disk image
+ disk image not automatically selected on addition
Changed in usb-creator (Ubuntu):
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.66

---------------
usb-creator (0.2.66) vivid; urgency=medium

  * usbcreator/install.py: adjust grub configurations, otherwise the
    persistent mode can't be enabled with UEFI BIOS. (LP: #1159016)
  * usbcreator/install.py: detect os version with regex and check for the
    result. (LP: #1208129)
  * GTK: select a source if it's already added. (LP: #978691)
  * GTK: scroll to the selected source.
 -- Yu Ning <email address hidden> Fri, 06 Mar 2015 12:39:57 -0500

Changed in usb-creator (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers