"System policy prevents installing the bootloader" is nonsense

Bug #943235 reported by Matthew Paul Thomas on 2012-02-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Medium
Unassigned

Bug Description

usb-creator-gtk 0.2.34, Ubuntu 11.10
Ubuntu 14.04

Perhaps it does not always appear, but sometimes a PolicyKit alert appears saying "System policy prevents installing the bootloader ... Authentication as the super user is required to perform this action".

This is not about the alert appearing at all (bug 859539), it is about the text. You should never say "System policy prevents" something in an alert that exists solely to let you do that thing. And you should never say "Authentication as the super user is required" on an operating system that doesn't have a super user.

Related branches

Revision history for this message
Matthew Paul Thomas (mpt) wrote :
description: updated
description: updated
tags: added: bitesize
tags: added: string-fix
Changed in usb-creator (Ubuntu):
importance: Undecided → Medium
tags: added: precise
Revision history for this message
Brian Murray (brian-murray) wrote :

Half of this dialog is from usb-creator, I'm not sure about the super user part.

Changed in usb-creator (Ubuntu):
status: New → Triaged
Revision history for this message
Nathan Williams (nathwill-deactivatedaccount-deactivatedaccount) wrote :

debdiff if preferred

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your work, I'm unsuscribing the sponsors from the bug since there is already a merge request in the sponsoring queue

Revision history for this message
Nathan Williams (nathwill-deactivatedaccount-deactivatedaccount) wrote :

ah, thanks Sebastien. seems lp-propose makes the instructions on the HowToFixBugs wiki incorrect.

Revision history for this message
Nathan Williams (nathwill-deactivatedaccount-deactivatedaccount) wrote :

based on the messaging in the user management dialog, i adjusted the messaging for consistency

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.35.2ubuntu1

---------------
usb-creator (0.2.35.2ubuntu1) precise; urgency=low

  * add user-friendly requests for authorization (lp: #943235)
 -- Nathan Williams <email address hidden> Sun, 04 Mar 2012 17:05:59 -0800

Changed in usb-creator (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
caspar_wrede (caspar-wrede) wrote :

This doesn't seem to be fixed at all. The dialog continues to be very user unfriendly and too wordy in 14.04

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

caspar, can you attach a screenshot showing the problem still existing in 14.04?

Revision history for this message
caspar_wrede (caspar-wrede) wrote :

Sure. Screenshot is attached.

Revision history for this message
caspar_wrede (caspar-wrede) wrote :

Another, better one, with the details unfolded

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Thanks caspar, reopening.

description: updated
Changed in usb-creator (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers