ValueError: Invalid version string

Bug #707749 reported by Cody A.W. Somerville on 2011-01-26
66
This bug affects 17 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: usb-creator

install.mangle_syslinux misuses debian_support.Version to compare release versions against each other. This can cause an unexpected exception (ValueError: Invalid version string %s) if the value it retrieves from .disk/info isn't a valid version for a Debian package.

usb-creator either should stop abusing debian_support.Version and/or catch this exception and set target_os_ver to None.

Evan (ev) wrote :

Can you elaborate on why you think this constitutes abuse of debian_support.Version?

Also, can you provide me with a .disk/info that breaks usb-creator in the manner you've mentioned? Thanks!

Changed in usb-creator (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → High
status: New → Incomplete

debian_support.Version is specifically for debian packages and not versioning of Debian, Ubuntu, <Insert other distribution here> releases which are not guaranteed to be valid debian package versions.

Here is an example of a .disk/info that breaks usb-creator:
Ubuntu "Warthog" - Build i386 LIVE/INSTALL Binary 20110127-14:42

FYI: In mangle_syslinux you look to see if .disk/info exploded using space as delimiter produces a list with a length greater than 2 before trying to extract the numerical version. This would work in this case as well if you didn't count everything after and including the dash character, ie. the comment.

Changed in usb-creator (Ubuntu):
status: Incomplete → New
IKT (ikt) on 2011-05-05
Changed in usb-creator (Ubuntu):
status: New → Confirmed
Joakim B (superslickjay) wrote :

I have the same error, using natty 11.04 and trying to extract crunchbang-10-20110207-xfce-i686.iso to a working USB stick.

Risto H. Kurppa (risto.kurppa) wrote :

Same here. usb-creator-kde of Kubuntu 10.10 and trying to write http://cdimage.debian.org/debian-cd/6.0.1a/i386/iso-cd/debian-6.0.1a-i386-netinst.iso

Daryl Hall (ubuntu-daryl) wrote :

Same here - trying to create a standard Debian i386 USB from Natty.

Daryl Hall (ubuntu-daryl) wrote :

Forgot to add that as a workaround for anyone with same issue I used unetbootin:

sudo apt-get install unetbootin
unetbootin

Washington (huoxito) wrote :

Same annoying error here, thanks for the suggestion Daryl

Washington (huoxito) wrote :

I don't understand it, but here is the error message i got. If it can help anyway.

"Could not move syslinux files in "/media/2655-967A": [Errno 2] No such file or directory. Maybe "/tmp/tmp5viFtu" is not an Ubuntu image?"

when trying to create a working usb stick with debian-6.0.2.1-amd64-CD-3.iso

I got this when trying to put Ubuntu 11.04 AMD64 desktop on a usb key.

Johannes R. (ringe-efreun) wrote :

Same here.

Using: 11.04
Trying to put on USB-Stick: 11.04 Server/Alternate x86 32bit

bjv (bjamesv) wrote :

Encountered with usb-creator on 10.10

workaround with unetbootin as alternative did do the trick.

Fabio Marconi (fabiomarconi) wrote :

Start to happens just today, detailed logs at bug 920857
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Evan (ev) on 2012-03-15
Changed in usb-creator (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
Stéphane (stephane-treboux) wrote :

Today I tried to use usb-creator on the following disk images:
kubuntu-13.04-desktop-amd64.iso
debian-live-7.0.0-amd64-kde-desktop.iso

usb-creator worked fine with the Kubuntu image but failed to work with the Debian image.
I used the same USB flash drive twice.
The error message with the Debian image was:
Invalid version string 'GNU/Linux'

This is the OS version displayed by usb-creator for kubuntu-13.04-desktop-amd64.iso:
Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)

And this is the OS version displayed by usb-creator for debian-live-7.0.0-amd64-kde-desktop.iso:
Debian GNU/Linux 7.0.0 "Wheezy" - Official Snapshot amd64 LIVE/INSTALL Binary 20130505-13:41

I have the feeling that usb-creator chokes on slashes in the version string.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments