usb-creator-gtk fails with opaque error when source .iso can't be read

Bug #567246 reported by Steve Langasek on 2010-04-20
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Low
Roderick B. Greening

Bug Description

Binary package hint: usb-creator

I tried to use usb-creator-gtk to write an ISO on an NFS share to my USB stick. usb-creator failed instantly with an opaque, generic "failed" error. Only by luck did I happen to think to check the file permissions on the ISO, which didn't allow root to read the file - once it was marked world-readable, usb-creator-gtk works just fine, but this wasn't discoverable.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: usb-creator-gtk 0.2.22
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
Architecture: amd64
Date: Tue Apr 20 05:48:06 2010
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator

Steve Langasek (vorlon) wrote :
Changed in usb-creator (Ubuntu):
importance: Undecided → Low

Can you provide the details on what the permissions were on the NFS which caused this error? Technically, if you are able to read the file as a normal user, you should be able to access it via usb-creator.

I expect the permissions were such that your normal user could not access the file. If this is the case, and the error you received was not decriptive enough, I will mark as a wishlist to be worked in a future version.

Changed in usb-creator (Ubuntu):
assignee: nobody → Roderick B. Greening (roderick-greening)
status: New → Incomplete
Jens Taprogge (jlt-launchpad) wrote :

I am seing the exact same problem. On Kubuntu 11.10 both with usb-creator-gtk and usb-creator-kde.

The permissions of the file on NFS were 644 with me as the owner. Copying the file to the local harddrive fixed the issue immediately.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers