Fails to enable "Make Startup Disk" button

Bug #533276 reported by Ken Pratt on 2010-03-06
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: usb-creator

I have an 8 Gig thumb drive with one partition. Looks like this:

Disk /dev/sdg: 8009 MB, 8009023488 bytes
247 heads, 62 sectors/track, 1021 cylinders
Units = cylinders of 15314 * 512 = 7840768 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sdg1 * 1 1021 7817766 c W95 FAT32 (LBA)

The drive mounts fine. There are no files on the thumb drive.

USB Creator sees both the raw drive, /dev/sdg, and the first partition, /dev/sdg1. It indicates that /dev/sdg needs to be formatted and that /dev/sdg1 does not have enough room. The image I have selected is:

-rw-r--r-- 1 kpratt kpratt 859865088 2010-03-06 08:02 lucid-netbook-i386.iso

I attempted to use the Format button action on both /dev/sdg and /dev/sdg1. Neither action enables the "Make Startup Disk" button. And neither action results in any kind of error or success indication.

I am unable to create a USB disk from the lucid-netbook-i386.iso image.

ProblemType: Bug
Architecture: amd64
Date: Sat Mar 6 08:38:30 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: usb-creator-gtk 0.2.12
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
SourcePackage: usb-creator
Uname: Linux 2.6.31-20-generic x86_64

Ken Pratt (kenpratt) wrote :
description: updated
Omer Akram (om26er) wrote :

Thanks for taking time to report this bug and help make ubuntu better. Can you please open gpared (if not already installed install it with sudo apt-get install gparted) and then format you thumb drive into fat32 with it, remove you thumb drive and insert it again and try again.

Changed in usb-creator (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Brian Fallik (bfallik) wrote :

I just encountered this problem and confirm that Omer's suggestion in comment #2 works around the problem for me.

HughDaniel (hugh-toad) wrote :

Most of the time I try to use usb-creator-[gtk|kde] it fails in this way, on multiple machines. This bug needs to be upgraded to importance=high. Many times I have hit the "Format" button and 99% of the time it does not accept the partition(s) it has formated as useable. I have tried this on three different Lucid hosts with three different ... now four different USB keys (2G, 4G, 8G) and maybe one time out of 100 it decides that the drive it has formatted is usable. The suggestion above now seems silly, as I checked and this is how the software is currently formatting the drives:

root@rock:~/Downloads# sfdisk -l /dev/sdb

Disk /dev/sdb: 1013 cylinders, 65 heads, 62 sectors/track
Units = cylinders of 2063360 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start End #cyls #blocks Id System
/dev/sdb1 * 0+ 1012 1013- 2041164 c W95 FAT32 (LBA)
/dev/sdb2 0 - 0 0 0 Empty
/dev/sdb3 0 - 0 0 0 Empty
/dev/sdb4 0 - 0 0 0 Empty
root@rock:~/Downloads#

  Yes I have tested in both gtk and kde mode. I guess I have only tested on 32bit machines. Clearly I can test any updates you want me to try.

HughDaniel,

Can you attach a copy of ~/.usbcreator.log when it fails? (please delete this file before running the creator and attach the newly created file). This should give a better indication of what is failing.

Gary M (garym) wrote :

Attaching ~/.usbcreator.log

Steps were:

Selected ISO file.
("Make Startup Disk" button is disabled.)
Clicked "Format" button for /dev/sdb1.
("Make Startup Disk" button is still disabled. /dev/sdb1 is no longer shown.)

Gary M (garym) wrote :

messages extract:

Apr 27 01:54:45 e1 kernel: [114666.928145] sdb: unknown partition table
Apr 27 01:54:46 e1 kernel: [114667.399358] sdb:
Apr 27 01:54:53 e1 kernel: [114674.605977] VFS: Can't find a valid FAT filesystem on dev sdb1.

Changed in usb-creator (Ubuntu):
status: Incomplete → Confirmed
Gary M (garym) wrote :

Trying Omer's work-around in comment #2 resulted in success for me too.

tags: added: karmic
removed: amd64
Gary M (garym) wrote :

Extract from /root/.usbcreator.log:

usb-creator 2010-04-27 01:54:45,048 (DEBUG) usb-creator-helper:39: Unmounting /org/freedesktop/DeviceKit/Disks/devices/sdb1
usb-creator 2010-04-27 01:54:52,853 (DEBUG) misc.py:127: ['dd', 'if=/dev/zero', u'of=/dev/sdb', 'bs=446', 'count=1']

noisymime (josh-noisymime) wrote :

Same problem experienced here on Ubuntu 10.04

Attached is .usbcreator.log file. I deleted the file prior to running usb-creator so this should only be for the relevant session.
The intended device/partition was formated to fat32 using gparted immediately before running usb-creator. It is an 8gb partition.

Gary M (garym) on 2010-09-30
tags: added: lucid
Kristian Thy (thy-42) wrote :

I'm having the same problem on maverick. The gparted workaround doesn't work, and no usbcreator log is created.

Bigfoot (me-eckschi) wrote :

In the last 2+ years this pile of m* never worked. And yeah, keeping this bug report low priority is very intelligent, cause it prevents people from installing ubuntu in the first place. way to go!

Kristian Thy (thy-42) on 2011-01-25
tags: added: maverick
mark mitchell (markummitchell) wrote :

I have the same problem. Although I am new to python, I'll help out.

Here are some oddities that I've noticed in an hour of debugging with ddd/gdb:
1) A bunch of "QCoreApplication::exec: The event loop is already running" warnings, although not an infinite loop. Maybe not a problem.
2) "update_target" function in frontend.py never gets called, and I think that code is the only place where the ui_start_button gets enabled
3) My hard drive is listed in the window as /dev/sdb, but the flash is listed as /dev/sdc1. I would think the flash should be listed as /dev/sdc
4) Log file ended with

  usb-creator 2011-07-14 19:22:14,791 (DEBUG) backend.py:139: id-type: swap
  usb-creator 2011-07-14 19:22:14,791 (DEBUG) backend.py:145: id-label:
  usb-creator 2011-07-14 19:22:14,793 (DEBUG) backend.py:166: mount:
  usb-creator 2011-07-14 19:22:28,220 (DEBUG) backend.py:22: Backend told to add: /home/mark/Downloads/openSUSE-
  11.4-KDE-LiveCD-i686.iso
  usb-creator 2011-07-14 19:22:28,221 (DEBUG) misc.py:130: ['isoinfo', '-J', '-i', u'/home/mark/Downloads/openSU
  SE-11.4-KDE-LiveCD-i686.iso', '-x', '/.disk/info']
  usb-creator 2011-07-14 19:22:37,602 (DEBUG) backend.py:190: cancel_install

If I get any encouragement, I'll keep at it.

Rob Hills (rhills) wrote :

Not sure why this bug seems to have languished. It's biting me today, as it seems to do episodically for no obvious reason.

Jeffrey Stern (jas-61803) wrote :

It is Feb 21, 2013, and I am still experiencing this on my system (Ubuntu 12.04.2 LTS 3.2.0-37-generic #58-Ubuntu SMP kernel x86_64). Like the others, I have tried several USB sticks. I do find the GParted solution works for me. In my case, after formatting, I also used GParted to mark the new partition as 'boot'able, and removed drive and put it back in. I also had to make sure to select an .iso file, AND also to select the /dev/sdc1 partition (which was hidden and had to scroll down.

It was only in googleing for "Ubuntu bugs" AND then knowing to type in "usb-creator-gtk" (which many end-users wouldn't know -- they might search for Startup Disk Creator or something) AND then scrolling down quite a ways before I found this bug listed. I am surprised to see it this low on the list, as the Startup Disk Creator really is NOT ready for prime time -- and has apparently not been for years. When I was trying to use it to "Erase Disk", it would just hang, and the cursor would turn to a round-style hourglass.. I let it go for hours -- no luck. No feedback -- positive or negative. No information about what it is doing. Very little in /var/log/syslog(*). No ~/.usbcreator.log created.

A bump up and revamp of this program (or a replacement) would be highly appreciated. Even at least changing the instructions (using GParted first, for instance) at http://www.ubuntu.com/download/help/create-a-usb-stick-on-ubuntu for now, so as not to waste so many people's time "rediscovering" the same bug over and over and duplicating our efforst -- would be greatly appreciated. Thank you.

(*) in syslog, I only see this when I click on "Erase Disk":

Feb 21 10:25:50 mymachine kernel: [1127251.314224] sd 28:0:0:0: [sdc] No Caching mode page present
Feb 21 10:25:50 mymachine kernel: [1127251.314230] sd 28:0:0:0: [sdc] Assuming drive cache: write through
Feb 21 10:25:50 mymachine kernel: [1127251.318991] sdc:

This also still happens to me on 12.10, seems like years have gone past with this bug around.

Andreas F (aff) wrote :

This problem persists on 12.04 LTS on x86_64. I have tried to download latest version from bzr, but have very limited python knowledge. Reformatting with gparted does *not* work for me. Have tried at least 3 different make and models of USB sticks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers