usb-creator doesn't refresh size error

Bug #521311 reported by Simon Schliesky on 2010-02-13
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: usb-creator

While having a 6.8G DVD in my drive I attached an empty FAT32 4GB USB-Stick.
After starting the usb creator it said something like "partition size [of usb stick] not sufficient" which is correct.
Then I selected a karmic i386 .iso file which has about 700M. Now there comes the problem, the usb creator didnt "refresh" the file size of the installation source (.iso) which is expected to fit onto the usb drive. Instead it still had this error message and a disabled "Make Startup Disc" button.

I worked around it, ejecting the DVD and restarting the usb-creator, so it had no 6.8G image preselected.

I consider this a minor, but nice-to-be-rid-of, bug.

:: using Karmic Koala (9.10)

ProblemType: Bug
Architecture: i386
Date: Sat Feb 13 10:16:46 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: fglrx
Package: usb-creator-gtk 0.2.12
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: usb-creator
Uname: Linux 2.6.31-16-generic i686
XsessionErrors:
 (gnome-settings-daemon:2575): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2772): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2734): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:2716): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -17 and height 24
 (firefox:4477): GLib-WARNING **: g_set_prgname() called multiple times

David Tombs (dgtombs) wrote :

I can reproduce this bug.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
summary: - usb-creator file size issue
+ usb-creator doesn't refresh size error
David Tombs (dgtombs) wrote :

Here's a screenshot from Lucid.

In the future, please include a screenshot yourself if possible. Thanks!

komputes (komputes) on 2010-06-17
Changed in usb-creator (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Daniel Lawrence (dannyla) wrote :

This bug is currently occurring in the latest release ( 12.04 ),

This looks like a problem with usbcreator/backends/base/backend.py not running the /backends/base/backend.py:140:_update_free function if the target has been flagged as either NEED_FORMAT or CANNOT_USE.

By running the /backends/base/backend.py:140:_update_free function it forces the recalculation of size requirements of the sources vs the size of the target and then updates the GUI to show that the target is acceptable.

The attachment "Patch to force the call of _update_free in /backends/base/backend.py:140" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in usb-creator (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.56

---------------
usb-creator (0.2.56) trusty; urgency=medium

  [ Ivan Larionov ]
  * Loop-mount iso in read-only mode, can't modify it anyway. (LP: #1289314)

  [ Daniel Lawrence ]
  * usb-creator doesn't refresh size error (LP: #521311)

  [ Jeremy Bicha ]
  * Always select the most recent image found (LP: #1087117)

  [ Yu Ning ]
  * GTK: Handle the backend.format_ended_cb callback otherwise the erasing
    operation will never ended. (LP: #1289269) (LP: #1273925)

  [ Dimitri John Ledkov ]
  * At the end of successful UDisks2 format, trigger device change to
    remount and recalculate the now formatted free space.
 -- Dimitri John Ledkov <email address hidden> Tue, 01 Apr 2014 15:04:39 +0100

Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers