Ubuntu

usb-creator-gtk does not start (GtkFrontend instance has no attribute 'cancelbutton')

Reported by Vicente Ruiz on 2010-01-06
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Undecided
Evan Dandrea

Bug Description

Binary package hint: usb-creator

When I try launch usb creator, error window appears. This windows shows:

"An unhandled exception occurred:
GtkFrontend instance has no attribute 'cancelbutton'"

More info:

$ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: a5c56fe715514eea6999aa6e34156545
CheckboxSystem: e704f33cc0866ff0f0256a33de39ea1c
Date: Wed Jan 6 15:09:15 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: wl
Package: usb-creator-gtk 0.2.13
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
SourcePackage: usb-creator
Tags: lucid
Uname: Linux 2.6.32-9-generic x86_64

Vicente Ruiz (uve) wrote :
Steve Magoun (smagoun) wrote :

Updating to usb-creator 0.2.18 fixes this for me

Changed in usb-creator (Ubuntu):
status: New → Confirmed

Thanks. I don't know enough about python to get it to install. Nothing
crucial, I'll wait for Lucid
Chris

On 03/12/2010 12:47 PM, Steve Magoun wrote:
> usb-creator 0.2.18

Martin Pitt (pitti) wrote :

uve, can you still reproduce this on current lucid?

Evan, wouldn't it make more sense to not intercept all crashes like this and let apport handle it? Then we'd get proper stack traces and runtime information?

Changed in usb-creator (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

Closing as per comment 2

Changed in usb-creator (Ubuntu):
status: Incomplete → Fix Released

It works fine! Thank!

2010/3/23 Martin Pitt <email address hidden>

> Closing as per comment 2
>
> ** Changed in: usb-creator (Ubuntu)
> Status: Incomplete => Fix Released
>
> --
> usb-creator-gtk does not start (GtkFrontend instance has no attribute
> 'cancelbutton')
> https://bugs.launchpad.net/bugs/503808
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Rumpeltux (rumpeltux) wrote :

I still get the error message with the current lucid version:
ii usb-creator 0.2.20
although the program itself reports to be $ usb-creator-gtk --version
0.2.8

Rumpeltux (rumpeltux) wrote :

Ok it works apparently, but you need to update usb-creator-gtk to the new version, which is not done automatically by installing the current usb-creator version since it does not depend on a specific revision of usb-creator-gtk.

Added explicit depend for latest version to usb-creator meta package to fix your issue Rumpeltux. Should not happen in version 0.2.21 onward.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers