Installation failed when path to the ISO contains non-ascii characters

Bug #460298 reported by Stanislav Hanzhin on 2009-10-25
160
This bug affects 31 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Nobuto Murata

Bug Description

Binary package hint: usb-creator

usb-creator-gtk version: 0.2.12
Ubuntu 9.10

When the path to ISO-file contains non-ascii Unicode characters, usb-creator-gtk fails with "installation failed".

[SRU request]
Impact:
users cannot create usb startup disk unless moving ISO.
ISO files are downloaded to xdg-downloads directory, and translated xdg-downloads directory's name usually contains non-ASCII characters.
users who want to make Lucid startup disk on Karmic machine may face this error.

fixed in version 0.2.21
and exact change is the following:
http://bazaar.launchpad.net/~usb-creator-hackers/usb-creator/trunk/revision/292

TEST CASE:
1. Move ISO to "/home/user/DIRECTORY_NAME/ubuntu-9.10-desktop-i386.iso" (DIRECTORY_NAME contains non-ascii character)
2. Launch usb-creator-gtk and select the ISO
3. Press "Make Startup Disk"
4. Get "Installation failed" message

Expected result:
Press "Make Startup Disk",
then start writing to USB stick
and done.

Nobuto Murata (nobuto) on 2009-11-02
Changed in usb-creator (Ubuntu):
status: New → Confirmed
summary: - Tells "failure" or "aborted" when path to the ISO contains non-latin
- characters
+ Installation failed when path to the ISO contains non-ascii characters
Nobuto Murata (nobuto) wrote :

I faced the same problem.
I added my .usbcreator.log.

Log file ends with the line,
"TypeError: execv() arg 2 must contain only strings"

"Downloads" folder is translated to each languages.
And ISO images are downloaded to "Downloads" directory.
So, many users may face this problem.

Nobuto Murata (nobuto) on 2009-11-02
description: updated
®om (rom1v) wrote :

Same problem, which is a bit annoying because in French, the default download directory is "Téléchargements", so if I download a .iso (using bittorrent), and try to put the .iso on the key, it doesn't work (and no information is given about the cause).

Vincent Lönngren (bice77) wrote :

In Swedish the default download directory is "Hämtningar".

Nick Bagios (nickbagi) wrote :

I am confirm this bug in Greek system language too. The folder name of download is "Λήψεις" in KDE 4.3.2
Kubuntu 9.10
usb-creator-kde

reg (rgaudin) wrote :

Also affected.

This bug is not likely to be fixed in karmic since it's a consequence of a python 2.x bug.

http://bugs.python.org/issue6135
http://bugs.python.org/issue1759845

Fixing it would require one of the following:

. patch python
. patch usb-creator to warn user (lame and easy)
. rename the file on-the-fly (ugly)
. patch usb-creator not to use Subprocess.Popen (would create other issues)
. wait for python3

Cedric Veilleux (cveilleux) wrote :

Just lost a few hours because of this bug. My system is in French and the process would fail with "Installation failed" message and nothing else..

Took me a while to find the error in the log.

I understand this is a python bug and that is fine, but the process should at least fail with a more useful error message or a pointer to the log file!

Manolis Kapernaros (kapcom01) wrote :

Unbelieavable! :D
I never thought it will be the name of the directory!
Mine is in Greek...

I agree with Cedric Veilleux. If i knew where the log is, i would have save much time..

Jesper Sandström (inthevidual) wrote :

I second the opinions of Veilleux and Kapernaros, a simple description of where to find the log will save many hours until a fix is possible.

Evan (ev) on 2010-04-01
Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.21

---------------
usb-creator (0.2.21) lucid; urgency=low

  [ Evan Dandrea ]
  * Encode ISO path with UTF-8 when mounting (LP: #460298).

  [ Roderick B. Greening ]
  * Update KDE Frontend to work with newer PyQt bindings (LP: #553243).
  * Bump version to 0.2.21 in setup.py, kde_about.py, usb-creator-gtk,
    and man pages.
  * Add explicit version requirement to depend on latest usb-creator-gtk
    for usb-creator.
 -- Evan Dandrea <email address hidden> Thu, 01 Apr 2010 17:42:12 +0100

Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
Nobuto Murata (nobuto) wrote :

SRU: minimal patch for Karmic is attached

Nominating for SRU, fulfills: (1) have an obviously safe patch and (2) affect an application rather than critical infrastructure packages

description: updated
Nobuto Murata (nobuto) on 2010-04-02
description: updated
Apteryx (maxco) wrote :

It seems this bug reappeared on Ubuntu 13.10. Using usb-creator-gtk 0.2.23, I can reproduce the problem when trying to use an iso image located in the downloads folder (LANG=fr_CA.UTF-8): ~/Téléchargements/. If I move the iso to ~/, which contains no special character, then the error is resolved. I also tried with other directory names containing special characters and it failed in the same way. Could someone reopen this bug?

David Tombs (dgtombs) wrote :

Hi, please open a new bug report by hitting Alt+F2 and running "ubuntu-bug usb-creator".

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.