Lack of verbose feedback: USB Startup Disk Creator does nothing when trying to format a disk

Bug #457737 reported by Pablo Antonio on 2009-10-21
162
This bug affects 30 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned
Nominated for Karmic by GTP-Hank

Bug Description

Binary package hint: usb-creator

I wanted to create a USB Startup Disk. So I clicked "USB Startup Disk Creator" on the System -> Administration menu. I chose the ISO. My USB disk was plugged. The second list showed my disk, with a warning icon, and beneath the list it said "The device needs to be formatted for use.".

However, when I clicked "Format", nothing happened. I thought the problem was I didn't have gparted installed (and was about to submit this bug as a "papercut", asking if you could make it clearer that gparted had to be installed in order to format the disk). Then I installed gparted, and tried that button again, but nothing happened, so I think the bug is more important than I thought.

Let me know if you need any other detail. Thank you.

ProblemType: Bug
Architecture: amd64
Date: Wed Oct 21 20:37:43 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: usb-creator 0.2.11
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: usb-creator
Uname: Linux 2.6.31-14-generic x86_64

Pablo Antonio (crazy2k) wrote :
Keith B (kcbnac) wrote :

I also have similar issues while booted off the 9.10 Beta Desktop CD (x86, on a Dell Inspiron E1505N) - 'Format' button does nothing, and the 'Make Startup Disk' button is greyed out/unclickable.

Installed Karmic RC with full updates and attempted to make a USB boot disk for my netbook. I tried both aUSB key and SD card. Both failed to format. The on e that did format had a warning sign next to the partion it created that said I needed to format again. I tried using the new disk utility to erase the partion made and make a new one, but the startup disk creator still saw the old partion it had made, even when I used Gparted to create a new disk label. I tried reformating the disk and even used Shred and DD Zero on both disk, but startup disk creator still saw them both as having bad partions that needed to be formated. Eventually I used my netbook with Jaunty on it to reformat both disk and make Fat32 partions. The Startup disk creator still mounted the drive itself with a format warning, but allowed the UNR iso to be written to the disk and the thubdrive booted with only onlyt one non-fatal error that is likely unrelated.

I then used startup disk creator again to format one of the cards and mounted it on my net book to see what was wrong. Fdisk said the cylinder count and sectors were bad and did match the disk count. I tried using expert mode in Fdisk to correct both errors and was able to fix them so it looks like startup creator is corrupting the disk when formating. Error seems related to how disk utility mounts the drives as it shows similar issues in disk utility. Sorry this is so long, but I spent four hours tryinfg different stuff to see if I could find a hack fix, because I did not want to install Karmic to my netbook if I can't format disk as I often use it for this purpose.

Shofi Islam (shofi-islam) wrote :

Confirm bug on a fresh install of Karmic, final relase. Program does nothing and outputs no log or additional information. How did this pass testing?

UCAP (ucap) on 2009-10-30
Changed in usb-creator (Ubuntu):
status: New → Confirmed
Bryan Ford (baford) wrote :

Same here - this time running on a fresh install of Ubuntu 9.10 final release, 32-bit version, in Sun VirtualBox 3.0.10 on Mac OS X Leopard (using USB passthru to allow Ubuntu direct access to the USB flash drive I'm trying to install an Ubuntu Netbook Remix ISO image onto). The USB flash drive is "only" 1GB, but that presumably should be plenty to hold the 700MB ISO. The flash drive was apparently formatted in the standard Windows fashion for flash drives, with no partition table, just one big VFAT partition.

Ah, just figured out what the problem was. The USB drive was one of those that came formatted with no partition table - just one big "raw" VFAT32 file system, so it got mounted under Linux as (in my case) /dev/sdb instead /dev/sdb1. usb-creator apparently didn't know how to deal with that, so it just showed a line for /dev/sdb complaining that the volume needs to be formatted, with a "Format" button does nothing, and no "/dev/sdb1" line since there was indeed no /dev/sdb1.

I confirmed that this was indeed the problem by manually reformatting the USB drive with a partition table, and used Linux fdisk to create a /dev/sdb1 partition, then used Windows to format that partition (I know Linux can do it, but don't trust it to get it right :) ), then usb-creator was happy with the resulting disk. It still says "volume needs to be formatted" when the /dev/sdb line is selected, but there's no a /dev/sdb1 line and it's happy when that line is selected.

Just in case it's not obvious to other users how to reformat a USB drive with a partition table... First I did a 'dd if=/dev/zero of=/dev/sdb bs=1024 count=1024' to zero out the beginning of the disk where the partition table should be - probably not necessary but just for good measure. Then I used fdisk under Linux to set up the partition table with one primary partition covering the whole disk with a type tag of Win95 FAT32 (LBA). Then I formatted that partition under Windows - Linux mtools should probably be able to do it too, but I don't entirely trust it to get it right.

Cheers,
Bryan

Shofi Islam (shofi-islam) wrote :

Confirm the above fault as the program not handling raw /dev/sdb partition. Workaround is similar, but I used gparted to create a new /dev/sdb1 FAT32 partition.

This is still confusing. Either the program should cope with raw vfat partitions or ask for a partition as part of the format process.

Steven (stebalien) wrote :

This should be marked critical.

Alex Rudnick (alex-rudnick) wrote :

I agree that this should be marked critical; this is seriously frustrating!

I tried the workaround suggested by Bryan (above), except that I just used mkfs.vfat to make a new vfat filesystem on /dev/sdb1. And I haven't been able to make usb-creator-gtk go yet. Pretty upsetting; regular humans would have just given up and gone away by now!

Tim Tilberg (ttilberg) wrote :

I've come across this error a lot of times lately, the first time it drove me to assuming my usb disk was corrupt or some such. This time I thought it was because lots of other things were broken in the system (bad upgrade problems from jaunty, using pre-release updates... things are starting to go wonky - That's why I was going to make the usb disk lol).

I went to one of my other Ubuntu machines to do the deed, and came across this problem there too. I just formatted the partition using gparted.
It lists both /dev/sdg with a warning icon, and also /dev/sdg1, which is currently allowing me to create the partition.
It is quite confusing though, especially when the default item selected is the warning icon @ /dev/sdg

Tim Tilberg (ttilberg) wrote :

I figured I'd add this in, based on what Alex said on comment #8.

To get a functional stick, I first deleted all partition tables using fdisk
$ sudo fdisk /dev/sdg
and then created a fat32 partition, using full space in gparted.

Doing this, allowed me to select the /dev/sdg1 partition in usb startup disk, and succesfully create the boot stick.

I hope this helps.
-Tim

My stick had no partition table. It was preformatted and all used in FAT32 (4Gb). Had to create a partition table and a primary partition in order to use it. I see it is confirmed, but because this broken app is published on all blogs and even on the Ubuntu documentation pages THIS should be marked as critical.

Caio Ariede (caio-ariede) wrote :

Same problem here, but I got it working formating the Pendrive with FAT16, using Disk Utility (in System / Administration), before opening USB creator.

Lawrence H (lhassall) wrote :

Surprised this hasn't even been looked at! Tried twice to format a USB stick (already containing a Ubuntu startup image) resulting in a disk that doesn't mount in Ubuntu or Windows.

Luckily finally found command line instructions to reformat but shouldn't have to. Should be marked critical and fixed ASAP.

komputes (komputes) wrote :

@Pablo - You mentioned that you see a message saying "The device needs to be formatted for use." - I do not see this on my machine, can you explain where you see this message or possibly upload a screen shot of this. If someone else sees this message please send in a screenshot or describe the location. Thank you.

komputes (komputes) on 2010-01-12
summary: - USB Startup Disk Creator does nothing when trying to format a disk
+ Lack of verbose feedback: USB Startup Disk Creator does nothing when
+ trying to format a disk
Anton Gladky (gladky-anton) wrote :

Have the same issue on one of USB-flash drives. Answer #10 helped.

Seems the problem is in some flash-drives.

Chrescht (sekateur) wrote :

I wanted to create a startup disk on the first partition of an external USB hard drive../dev/sdb1.
Unfortunately by selecting /dev/sdb1 and clicking format, the whole drive sdb was formatted and not only the first partition.

I find this to be a serious bug since whole partitions of data are wiped (!).
Fortunately there exist magic tools like testdisk..

Karmic
2.6.31-17-generic
i686 GNU/Linux

cheers.

komputes (komputes) wrote :

@ Chrescht - The fact that there is no feedback during the process is this bug The fact that it does not warn/confirm what will be destroyed, causing data loss is Bug #443330. Please subscribe to that bug and mark it as affecting you.

Jon Yates (jon-jonathanyates) wrote :

I am afraid that I dont get the command line workaround pls could someone spell it out for me please

Jonathan

Scott Ritchie (scottritchie) wrote :
Changed in usb-creator (Ubuntu):
importance: Undecided → High

I have the same issue.

Flash drive (/dev/sdb): Corsair, Flash Voyager, 4GB
Mother board: Hewlett-Packard 0A00h
OS: Karmic, 2.6.31-20-generic, x86_64

Pako (elektrobank01) wrote :

I think the problem is very banal, developers should just change the order of already made USB's, if you go down the menu you will notice that the second in a series of USB is the right one, and the first that shows the error has been previously made and should be deleted from the list

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.19

---------------
usb-creator (0.2.19) lucid; urgency=low

  [ Mario Limonciello ]
  * Don't force select a source unless the list is empty.
  * Reverse the order of the populating ISOs and command line option --iso
    again so that --iso always trumps others.
  * Hide the source_vbox again when --iso is used.

  [ Evan Dandrea ]
  * Get rid of the needs-format warning for now. It was always shown
    for parent block devices and the confusing resulting from that was
    quite bad.
  * Rework partition mounting so that it doesn't fail if the partition
    was mounted between dbus calls.
  * Somewhat fix progress reporting.
  * Don't write usb-creator-helper's log to /root (LP: #461064).
  * Provide a format confirmation dialog (LP: #443330).
  * Error out of formatting if we're unable to unmount all of the
    partitions (LP: #507420).
  * Provide feedback via a spinning cursor and disabled format button
    while formatting (LP: #457737).
  * Only call gtk.main_quit if we're in a mainloop.
  * Don't try to unmount a partition in usb-creator-helper unless it
    actually is mounted.
  * Unmount the partition at the end of install using
    usb-creator-helper rather than umount as a regular user.
  * Handle device changes by synthesizing a remove and add.
  * Pulse the progress bar while flushing changes to disk.
  * Pulse when installing the bootloader.
 -- Evan Dandrea <email address hidden> Wed, 24 Mar 2010 18:34:35 +0000

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Released
Jeremy Davis (jedmeister) wrote :

Whilst it seems to be fixed in Lucid, it still exists in Karmic and IMO should be fixed.

I used a USB that already had an image on it. I created the original image using the similar Dell utility (it was on a Dell netbook with 8.10 preinstalled) under Intrepid if my memory services me correctly. I ended up having to install GParted and reformat it (FAT32) with that, then it worked fine. Formatting with the preinstalled "Disk Utility" (Palimpest) didn't do it. Well it formatted it and Nautilus sees the USB fine - but USB Creator still wouldn't work with the USB until formatted with GParted.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers