python2.6 crashed with OSError in fs_size()

Bug #439001 reported by LinuxCanuck on 2009-09-29
130
This bug affects 19 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python2.6

Using USB Startup Disk Creator
9.10 64-bit Alpha 6
I was formatting the usb stick and it happens each time, failing to complete the task

ProblemType: Crash
Architecture: amd64
Date: Tue Sep 29 17:22:15 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/python2.6
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: python2.6-minimal 2.6.2-3ubuntu1
ProcCmdline: /usr/bin/python /usr/bin/usb-creator-kde
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
PythonArgs: []
SourcePackage: python2.6
Title: python2.6 crashed with OSError in fs_size()
Uname: Linux 2.6.31-11-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

LinuxCanuck (linuxcanuck) wrote :
tags: removed: need-duplicate-check
Matthias Klose (doko) on 2009-10-03
affects: python2.6 (Ubuntu) → usb-creator (Ubuntu)
visibility: private → public
elihh (elihh) wrote :

I Have this bug after the click to format usbpen

c_ellesley (archelegraph) wrote :

it says

Data Storage to Use: one item which is already selected:

/!\ Format needed : /dev/sdb

so I clicked format and the installer and crashed repeatedly, even after the usb-stick had been formatted by hand.

..after a while I noticed that there is a second entry in the list (which is not visible except for the scrollbar on the right)
which is /dev/sdb1 (which I formatted by hand after the first crash)

..well this works!

..maybe the layout of the installer could show at least two lines of choice, so that people are able to find the right entry ?

c_ellesley (archelegraph) wrote :

I presume it is not a bug, but merely the right choice to be made is obscured by the gui-layout
(see comment)

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Evan (ev) on 2009-10-13
Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.10

---------------
usb-creator (0.2.10) karmic; urgency=low

  [ Cody A.W. Somerville ]
  * usbcreator/install.py:
    - Do not copy /syslinux/syslinux.cfg to root of disk, no longer needed.
    - Look at all files ending in .cfg under the syslinux directory when
      updating configuration files based on the options selected in usb-creator.
    - Strip tabs when parsing iso/syslinx config files to correctly identify
      commands in a syslinux config file that indents lines.

  [ Evan Dandrea ]
  * Small fixes to Cody's changes to the mangle_syslinux function:
    - Don't assume / is the path separator.
    - Add command line entries to the front, to avoid them being carried over
      to the installed system.
    - Write all lines, not just modified ones.
  * Properly set the icons in the source treeview. Thanks John S.
    Gruber (LP: #436469).
  * Handle the device no longer existing in fs_size (LP: #439001).
  * Update translations from Launchpad.

  [ Roderick B. Greening ]
  * Fix issues with UTF.8 (unicode) strings being cast to str
    (LP: #440719).
    - Updated KDE Front-end

 -- Evan Dandrea <email address hidden> Tue, 13 Oct 2009 11:08:16 +0100

Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers