[Karmic] usb-creator-gtk crashed with NameError in pixbuf_data_func()

Bug #436469 reported by Andrew Cowie on 2009-09-25
192
This bug affects 39 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: usb-creator

Trying to navigate to a .iso, and boom.

AfC

ProblemType: Crash
Architecture: amd64
Date: Fri Sep 25 19:01:54 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/usb-creator-gtk
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: usb-creator-gtk 0.2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/usb-creator-gtk
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
PythonArgs: ['/usr/bin/usb-creator-gtk']
SourcePackage: usb-creator
Title: usb-creator-gtk crashed with NameError in pixbuf_data_func()
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.6/dist-packages/usbcreator/frontends/gtk/frontend.py", line 315, in pixbuf_data_func
     cell.set_property('icon-name', icon)
 NameError: global name 'icon' is not defined
Uname: Linux 2.6.31-10-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fuse lpadmin netdev plugdev sambashare users video

Andrew Cowie (afcowie) wrote :
tags: removed: need-duplicate-check
Andrew Cowie (afcowie) on 2009-09-25
visibility: private → public
summary: - usb-creator-gtk crashed with NameError in pixbuf_data_func()
+ [Karmic] usb-creator-gtk crashed with NameError in pixbuf_data_func()
John S. Gruber (jsjgruber) wrote :

In my case occurred just after telling usb-creator to format a newly created partition.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
John S. Gruber (jsjgruber) wrote :

Occurs trying to display an icon for a potential CD source. The bug is a hassle because it happens every few seconds.

Amelioration: insert the CD at the last moment before using usb-creator (or maybe use an image or .iso file?)

Looks like line 315 in /usr/share/pyshared/frontends.py is intended to match line 487.

A patch is attached to do this but it maybe easier for a dev to just copy line 487 to 315.

David Horváth (chronos-hun) wrote :

I just opened the program, did not do anything, popped up that the app has crashed.

Evan (ev) on 2009-10-13
Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.10

---------------
usb-creator (0.2.10) karmic; urgency=low

  [ Cody A.W. Somerville ]
  * usbcreator/install.py:
    - Do not copy /syslinux/syslinux.cfg to root of disk, no longer needed.
    - Look at all files ending in .cfg under the syslinux directory when
      updating configuration files based on the options selected in usb-creator.
    - Strip tabs when parsing iso/syslinx config files to correctly identify
      commands in a syslinux config file that indents lines.

  [ Evan Dandrea ]
  * Small fixes to Cody's changes to the mangle_syslinux function:
    - Don't assume / is the path separator.
    - Add command line entries to the front, to avoid them being carried over
      to the installed system.
    - Write all lines, not just modified ones.
  * Properly set the icons in the source treeview. Thanks John S.
    Gruber (LP: #436469).
  * Handle the device no longer existing in fs_size (LP: #439001).
  * Update translations from Launchpad.

  [ Roderick B. Greening ]
  * Fix issues with UTF.8 (unicode) strings being cast to str
    (LP: #440719).
    - Updated KDE Front-end

 -- Evan Dandrea <email address hidden> Tue, 13 Oct 2009 11:08:16 +0100

Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers