package usb-creator 0.1.16 failed to install/upgrade: Package is in a very bad inconsistent state - you should

Bug #366462 reported by John Vivirito on 2009-04-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: usb-creator

While updating usb-creator it fails to configure. I had to install --reinstall for it to work. here is the output i got with commnads:

<snip>
Setting up openoffice.org-common (1:3.0.1-9ubuntu3) ...

Setting up indicator-messages (0.1.6-0ubuntu1) ...
Setting up indicator-applet (0.1.6-0ubuntu1) ...

Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.28-11-generic
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Processing triggers for python-support ...
Errors were encountered while processing:
 usb-creator
gnomefreak@Development:~$ sudo dpkg --configure -a
dpkg: error processing usb-creator (--configure):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting configuration.
Errors were encountered while processing:
 usb-creator
gnomefreak@Development:~$ sudo apt-get remove usb-creator
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  usb-creator
0 upgraded, 0 newly installed, 1 to remove and 6 not upgraded.
1 not fully installed or removed.
After this operation, 569kB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: error processing usb-creator (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 usb-creator
E: Sub-process /usr/bin/dpkg returned an error code (1)
gnomefreak@Development:~$ sudo apt-get install --reinstall usb-creator
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  usb-creator
1 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
1 not fully installed or removed.
Need to get 0B/27.6kB of archives.
After this operation, 0B of additional disk space will be used.
Selecting previously deselected package usb-creator.
(Reading database ... 119246 files and directories currently installed.)
Preparing to replace usb-creator 0.1.15 (using .../usb-creator_0.1.16_all.deb) ...
Unpacking replacement usb-creator ...
Processing triggers for man-db ...
Setting up usb-creator (0.1.16) ...

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 9.04
ErrorMessage: Package is in a very bad inconsistent state - you should
NonfreeKernelModules: nvidia
Package: usb-creator 0.1.16
PackageArchitecture: all
SourcePackage: usb-creator
Title: package usb-creator 0.1.16 failed to install/upgrade: Package is in a very bad inconsistent state - you should
Uname: Linux 2.6.28-11-generic i686

John Vivirito (gnomefreak) wrote :
John Vivirito (gnomefreak) wrote :

No longer an issue. When i ran into it i ran --force-all with dpkg and it worked. Since them i have tried it by installing on another system and worked fine so i guess its fixed

Changed in usb-creator (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers