USB Startup Disk Creator no longer works in Ubuntu 9.04

Bug #366087 reported by tdaxp on 2009-04-24
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
usb-creator
Invalid
Undecided
Unassigned
usb-creator (Ubuntu)
Medium
Unassigned
Nominated for Lucid by WubiNeophyte

Bug Description

Binary package hint: usb-creator

I have been running Ubuntu 8.10 with a startup USB disk (1GB) made with unetbootin. After booting in, I used the USB creator to install Ubuntu to a writable USB disk (4 GB). Things worked well.

Now that Ubuntu 9.04 came out, I wanted to try the same package with the new version. I successfully created a non-writable USB disk for 9.04 with unetbootin. I am currently in Ubuntu 9.04 (on the 1 GB disk). However, when I use USB Creator to install 9.04 on the 4 GB disk, it consistently fails. The error message points me to the log file. These are the most recent lines in the log file:

<i>-- Starting up at 13:27:17 --
[13:27:17] /var/lib/python-support/python2.6/dbus/connection.py:242: DeprecationWarning: object.__init__() takes no parameters
  super(Connection, self).__init__(*args, **kwargs)
[13:27:17] adding: /dev/sdc
[13:27:17] new device:
{'udi': '/org/freedesktop/Hal/devices/volume_uuid_49EA_155E', 'capacity': dbus.UInt64(1031756288L), 'uuid': '49EA-155E', 'device': '/dev/sdb1', 'mountpoint': '/cdrom', 'fstype': 'vfat', 'free': 272629760L, 'label': '5099A0'}
[13:27:17] adding: /dev/sdb1
[13:27:28] mounting /media/disk/Downloads/ubuntu-9.04-desktop-i386.iso
[13:27:28] ['mount', '-t', 'iso9660', '-o', 'loop,ro', '/media/disk/Downloads/ubuntu-9.04-desktop-i386.iso', '/tmp/tmp3E1nW0']
[13:27:28] updating dest_status as part of update_row_state
[13:27:28] ['umount', '/tmp/tmp3E1nW0']
[13:27:28] ['rmdir', '/tmp/tmp3E1nW0']
[13:27:40] ['umount', '/dev/sdc']
umount: /dev/sdc: not mounted
[13:27:40] ['parted', '-s', '/dev/sdc', 'mklabel', 'msdos']
[13:27:40] ['parted', '-s', '/dev/sdc', 'mkpartfs', 'primary', 'fat32', '0', '--', '-0']
[13:27:42] deleting /dev/sdc from the ui
[13:27:42] possibly adding: /org/freedesktop/Hal/devices/volume_uuid_5027_6364
[13:27:42] new device:
{'udi': '/org/freedesktop/Hal/devices/volume_uuid_5027_6364', 'capacity': dbus.UInt64(4018142720L), 'uuid': '5027-6364', 'device': '/dev/sdc1', 'mountpoint': '', 'fstype': 'vfat', 'free': 0, 'label': ''}
[13:27:42] adding: /dev/sdc1
[13:27:42] updating dest_status as part of update_row_state
[13:27:43] updating dest_status as part of update_row_state
[13:27:43] prop modified
[13:27:43] device_udi: /org/freedesktop/Hal/devices/volume_uuid_5027_6364
[13:27:43] num_changes: 2
[13:27:43] change: volume.mount_point
[13:27:43] change: volume.is_mounted
[13:27:53] Installing...
[13:27:53] Source CD: /media/disk/Downloads/ubuntu-9.04-desktop-i386.iso
[13:27:53] Destination disk: /dev/sdc1
[13:27:53] Persistence size: 3277684736 B
[13:27:53] Marking partition 1 as active.
[13:27:53] installing the bootloader to /dev/sdc.
[13:27:53] ['dd', 'if=/usr/lib/syslinux/mbr.bin', u'of=/dev/sdc', 'bs=446', 'count=1', 'conv=sync']
0+1 records in
1+0 records out
446 bytes (446 B) copied, 0.0118829 s, 37.5 kB/s
[13:27:53] installing the bootloader to /dev/sdc1.
[13:27:53] ['syslinux', '/dev/sdc1']
[13:27:54] ['parted', '-s', dbus.String(u'/dev/sdc'), 'set', u'1', 'boot', 'on']
[13:27:54] ['mount', '-o', 'loop,ro', '/media/disk/Downloads/ubuntu-9.04-desktop-i386.iso', '/tmp/tmpQTJpny']
[13:27:54] ['rm', '-rf', '/media/disk-1/autorun.inf']
[13:27:54] ['rm', '-rf', '/media/disk-1/casper']
[13:27:54] ['rm', '-rf', '/media/disk-1/dists']
[13:27:54] ['rm', '-rf', '/media/disk-1/install']
[13:27:54] ['rm', '-rf', '/media/disk-1/isolinux']
[13:27:54] ['rm', '-rf', '/media/disk-1/md5sum.txt']
[13:27:54] ['rm', '-rf', '/media/disk-1/pics']
[13:27:54] ['rm', '-rf', '/media/disk-1/pool']
[13:27:54] ['rm', '-rf', '/media/disk-1/preseed']
[13:27:54] ['rm', '-rf', '/media/disk-1/README.diskdefines']
[13:27:54] ['rm', '-rf', '/media/disk-1/ubuntu']
[13:27:54] ['rm', '-rf', '/media/disk-1/wubi.exe']
[13:27:54] ['rm', '-rf', '/media/disk-1/.disk']
[13:27:54] ['rm', '/media/disk-1/casper-rw']
rm: cannot remove `/media/disk-1/casper-rw': No such file or directory
[13:27:54] ['/usr/share/usb-creator/install.py', '-s', '/tmp/tmpQTJpny/.', '-t', '/media/disk-1', '-p', '3277684736']
Tried to symlink . -> /media/disk-1/ubuntu
Tried to symlink jaunty -> /media/disk-1/dists/stable
Tried to symlink jaunty -> /media/disk-1/dists/unstable
[Errno 5] Input/output error

[13:31:25] Unmounting source volume.
[13:31:25] ['umount', '/tmp/tmpQTJpny']
[13:31:25] ['rmdir', '/tmp/tmpQTJpny']
[13:31:25] Install command exited with code: 256
[13:31:25] Forcing shutdown of the install process.
[13:31:25] Unmounting source volume.
[13:31:25] ['umount', '/tmp/tmpQTJpny']
umount: /tmp/tmpQTJpny: not found
[13:31:25] ['rmdir', '/tmp/tmpQTJpny']
rmdir: failed to remove `/tmp/tmpQTJpny': No such file or directory
[13:31:25] Install failed.</i>

Other info:

<i>ubuntu@ubuntu:~$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04
ubuntu@ubuntu:~$ apt-cache policy usb-creator
usb-creator:
  Installed: 0.1.16
  Candidate: 0.1.16
  Version table:
 *** 0.1.16 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status
</i>

amid (dmalenko) wrote :

I experience the same problem when trying to create a 2Gb writable USB disk for 9.04.

I'm having the same issues as well. And when I did manage to make a USB disk, the persistent storage doesn't work whatsoever, so I keep losing all of the settings every time I shut down.

I also am losing any new packages I add to the USB disk. It's highly annoying because I'm trying to create customized live USB disks for an office, and being unable to create new disks with 9.04 is problematic. My current workaround is to run 8.10 in a VM and create the disks there.

Srinivasaverman (msverman) wrote :

I installed USB Startup Disk Creator in Ubuntu 9.04 but it gives an error while execution

Could not launch 'USB Startup Disk Creator'

Failed to execute child process "usb-creator" (No such file or directory)

E.Guerra (elderguerra) wrote :
Download full text (3.7 KiB)

The same with usb disk sandisk cruzer 4gb

-- Starting up at 12:52:55 --
[12:52:55] /var/lib/python-support/python2.6/dbus/connection.py:242: DeprecationWarning: object.__init__() takes no parameters
  super(Connection, self).__init__(*args, **kwargs)
[12:52:55] got a disc: Ubuntu 9.04 i386
[12:52:55] got a disc: U3 System
[12:52:55] adding: /dev/sde
[12:52:55] updating dest_status as part of update_row_state
[12:52:55] adding: /dev/sdd
[12:53:01] ['umount', '/dev/sde1']
umount: /dev/sde1: not found
[12:53:01] ['umount', '/dev/sde']
umount: /dev/sde: not mounted
[12:53:01] ['parted', '-s', '/dev/sde', 'mklabel', 'msdos']
[12:53:02] ['parted', '-s', '/dev/sde', 'mkpartfs', 'primary', 'fat32', '0', '--', '-0']
[12:53:04] deleting /dev/sde from the ui
[12:53:04] possibly adding: /org/freedesktop/Hal/devices/volume_uuid_EDA5_8A10
[12:53:04] new device:
{'udi': '/org/freedesktop/Hal/devices/volume_uuid_EDA5_8A10', 'capacity': dbus.UInt64(4022129664L), 'uuid': 'EDA5-8A10', 'device': '/dev/sde1', 'mountpoint': '', 'fstype': 'vfat', 'free': 0, 'label': ''}
[12:53:04] adding: /dev/sde1
[12:53:04] updating dest_status as part of update_row_state
[12:53:06] ['mount', '-t', 'vfat', '/dev/sde1', '/tmp/tmpJBXjVM']
[12:53:06] updating dest_status as part of update_row_state
[12:53:06] prop modified
[12:53:06] device_udi: /org/freedesktop/Hal/devices/volume_uuid_EDA5_8A10
[12:53:06] num_changes: 2
[12:53:06] change: volume.mount_point
[12:53:06] change: volume.is_mounted
[12:53:34] Installing...
[12:53:34] Source CD: /org/freedesktop/Hal/devices/volume_label_Ubuntu_9_04_i386
[12:53:34] Destination disk: /dev/sde1
[12:53:34] Persistence size: 134217728 B
[12:53:34] Marking partition 1 as active.
[12:53:34] installing the bootloader to /dev/sde.
[12:53:34] ['dd', 'if=/usr/lib/syslinux/mbr.bin', u'of=/dev/sde', 'bs=446', 'count=1', 'conv=sync']
0+1 records in
1+0 records out
446 bytes (446 B) copied, 0.0177447 s, 25.1 kB/s
[12:53:34] installing the bootloader to /dev/sde1.
[12:53:34] ['syslinux', '/dev/sde1']
[12:53:36] ['parted', '-s', dbus.String(u'/dev/sde'), 'set', u'1', 'boot', 'on']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/autorun.inf']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/casper']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/dists']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/install']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/isolinux']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/md5sum.txt']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/pics']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/pool']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/preseed']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/README.diskdefines']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/ubuntu']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/wubi.exe']
[12:53:36] ['rm', '-rf', u'/tmp/tmpJBXjVM/.disk']
[12:53:36] ['rm', '/tmp/tmpJBXjVM/casper-rw']
rm: cannot remove `/tmp/tmpJBXjVM/casper-rw': No such file or directory
[12:53:36] ['/usr/share/usb-creator/install.py', '-s', u'/media/cdrom0/.', '-t', '/tmp/tmpJBXjVM', '-p', '134217728']
Tried to symlink . -> /tmp/tmpJBXjVM/ubuntu
[Errno 5] Input/output error

[12:56:36] Unmounting target volume.
[12:56:36] ['umount', '/tmp/tmpJBXjVM']
[12:56:36] ['rmdir', ...

Read more...

E.Guerra (elderguerra) wrote :

Let me add, I used this a couple of days with other usb disk 1 gb perfectly.
I don't have that usb disk any more.
With my new 4gb disk is failing

Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
I'm unable to reproduce this problem. I'm able to start and use the USB startup disk creator.
Please answer these questions:
1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.
3. Does this problem persist in Karmic? Kindly test this in karmic and report back
This will help us to find and resolve the problem.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Changed in hundredpapercuts:
status: New → Incomplete
Changed in usb-creator (Ubuntu):
status: New → Incomplete
WubiNeophyte (wubibugs) wrote :

I personally ran into this in Karmic, but based upon comments in this bug, seems to be a regression from Intrepid.

== Regression details ==
Discovered in version: 0.2.12
Last known good version: 0.1.10

tags: added: regression-release
Vish (vish) wrote :

- Closing the papercut task , since this is a bug and not a papercut
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: Incomplete → Invalid
Paul Peacock (peacockpaul9) wrote :

Using up-to-date (x86_64) Karmic, I have the same problem. Firstly I cannot format using usb startup disk creator (not a big problem, using palimpsest to format to FAT). Using usb startup install fails with an uncaught exception error. All the files are on the USB stick apart from symlinks from 'stable' and 'unstable'. Cannot manually create symlinks using gnome or bash, and this appears to be the issue.

Andrew Schulman (andrex) wrote :

I can't figure out how to create the debug output that others have posted, but I also suffer from this problem.

1. The bug is reproducible. It happens every time I run usb-creator.
2. To reproduce:
* Start usb-creator.
* Choose a disk image and USB disk partition.
* Choose any option for storing documents and settings.
* Click on "Make Startup Disk".
Some progress dialogs appear, then a popup that says:

Installation failed
An uncaught exception was raised:
[Error 5] Input/output error

3. The problem occurs in up-to-date karmic.

Thanks,
Andrew.

Vish (vish) on 2010-03-07
affects: hundredpapercuts → usb-creator
Changed in usb-creator:
status: Invalid → New
Vish (vish) wrote :

Thanks for replying with the steps. [I'm not able to reproduce this same problem]

Setting bug to new.

Changed in usb-creator (Ubuntu):
importance: Undecided → Medium
status: Incomplete → New

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner.
There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test the current Ubuntu version (10.04). If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect 366087, and any other logs that are relevant for this particular issue.

Changed in usb-creator (Ubuntu):
status: New → Incomplete
Changed in usb-creator:
status: New → Incomplete
pmbsa (web-thebroughtons) wrote :

I am having the exact same problem, it occurs every time with any USB pen drive larger then 1GB.

I have tried to partition the larger drives to 1gb partitions but that has seemingly no effect at all. Same result.

Richard Lobb (richard-lobb) wrote :

I'm having this problem too, attempting to install Ubuntu 10.04 Netbook Edition on an HP Mini 210. The error always occurs at exactly the same point during the install process (with "copying files" at 35%). It occurs with two different pen drives (2GB and 4GB) and with different partitioning of the hard drive to use different areas of it. The iso download from which I built the pen drive installation appears valid by itself -- I've used it to install UNE on Virtual Box. At this stage Startup Disk Creator seems like the culprit.

Richard Lobb (richard-lobb) wrote :

Oops, correction to my previous posting. I remembered that the iso download I'd used successfully before in VirtualBox wasn't actually the same download I was using with USB Startup Disk Creator. So I just did an md5 check -- sure enough, the version I'd been having all the issues with was corrupt. Downloading another version (and verifying its checksum this time!) solved all my problems.

Dimitri John Ledkov (xnox) wrote :

You could have used zsync to redownload only corrupt bits and turn your corrupted iso into working one =)

This bug report is being closed due to your last comment regarding this being fixed with new iso. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in usb-creator (Ubuntu):
status: Incomplete → Invalid
Changed in usb-creator:
status: Incomplete → Invalid
Glottis (holytony) wrote :

I just had this error on Ubuntu 10.10:
An uncaught exception was raised:
[Error 5] Input/output error

A data CD I had inserted earlier in the DVD-ROM was still mounted, even though it had been already physically ejected. When I "unmounted" it in Nautilus, USB Creator worked error free.

I'm using Ubuntu 10.10, but thought this info would be useful.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers