.desktop item not translatable

Bug #331061 reported by Timo Jyrinki on 2009-02-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-creator (Guadalinex)
Medium
Unassigned
usb-creator (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: usb-creator

The desktop item is still not translatable. Please remember all I18N aspects when creating any new application for Ubuntu. I'm attaching a bzr branch with a fix to the problem.

This is indeed a glaring omission. We had it in Intrepid with network-manager, please let's not repeat the same mistake again.

Timo Jyrinki (timo-jyrinki) wrote :

Fix was committed to trunk by Evan. Not released yet.

Changed in usb-creator:
status: New → Fix Committed

When will this be released? This is still an issue.

Juanje Ojeda (juanje) on 2009-03-10
Changed in usb-creator:
importance: Undecided → Medium
status: New → Confirmed
Juanje Ojeda (juanje) wrote :

The patch fix the part of the problem but there is still an issue. The 'X-Ubuntu-Gettext-Domain' in the .desktop is wrong.
It should be 'usbcreator' and is 'usb-creator'.

The change is so simple, but I attach the patch anyway.

Changed in usb-creator:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.1.13

---------------
usb-creator (0.1.13) jaunty; urgency=low

  [ Evan Dandrea ]
  * Fix the .desktop item i18n support (LP: #331061). Thanks Timo
    Jyrinki!
  * "Note that using GTK_WIN_POS_CENTER_ALWAYS is almost always a bad idea."
    Place the window in the center, don't keep it centered. Thanks Eric
    Butler.
  * Set the title property of the labels after creating WrapLabels, not
    before. Thanks Eric Butler.
  * Point Vcs-Bzr in the control file to the proper location.
  * Call dd with the correct arguments (LP: #331327). Thanks Martin Pitt!
  * Move the addition of usb-creator.desktop.in to POTFILES.in to the build
    script.
  * Support SD cards and other removable devices. Thanks Eric Butler!

  [ Martin Pitt ]
  * setup.py: Remove broken installation of .desktop file; p-distutils-extra
    already does that. Fixes FTBFS.
  * setup.py: Use p-distutils-extra's clean rule to properly remove build/.

 -- Martin Pitt <email address hidden> Sun, 15 Mar 2009 22:48:23 +0100

Changed in usb-creator:
status: Fix Committed → Fix Released
Juanje Ojeda (juanje) wrote :

I open again the bug because the solution committed is incomplete. Please, read my last comment and the patch.

The gettext domain in the .desktop is wrong, it must be changed.

Changed in usb-creator (Ubuntu):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.1.15

---------------
usb-creator (0.1.15) jaunty; urgency=low

  * Set the proper gettext domain. Thanks Timo Jyrinki (LP: #331061).

 -- Evan Dandrea <email address hidden> Wed, 18 Mar 2009 21:23:22 +0000

Changed in usb-creator:
status: Confirmed → Fix Released
Juanje Ojeda (juanje) on 2009-03-19
Changed in usb-creator (Guadalinex):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers