Missing strings for translation

Bug #310804 reported by Alexey Balmashnov on 2008-12-23
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
usb-creator (Guadalinex)
High
Unassigned
usb-creator (Ubuntu)
Undecided
khadijah mitchell

Bug Description

Binary package hint: usb-creator

Not all strings are available for translation.

As one can see [1] there are only 20 strings, which cover overall used strings only partially.

[1] https://translations.launchpad.net/usb-creator/trunk/+pots/usbcreator/ru/+translate

István Nyitrai (sianis) wrote :

Hi!

I've created a fast patch for usb-creator. I think you can translate nearly all GUI text in the window with this.

I can't try the whole program, but I will.

Evan (ev) on 2009-01-07
Changed in usb-creator:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.1.12

---------------
usb-creator (0.1.12) jaunty; urgency=low

  [ Evan Dandrea ]
  * Correct grammatical typo in the GTK frontend (LP: #297569).
  * Depend on mcopy as syslinux only recommends it (LP: #296093).
  * Mark more strings for translation. Thanks István Nyitrai (LP: #310804).
  * Change the Debian maintainer to the Ubuntu Installer Team.
  * Work around a long standing GTK label bug by using a Python version of
  * libview's WrapLabel.
  * Fix nonsense 1 byte writes of the casper-rw ext3 loopback fs
    (LP: #313364).
  * Basic file copy error handling.
  * Sync the disk at the end of installation.
  * Better handle filesystem-on-disk in the bootloader installing code.
    Thanks Loïc Minier (LP: #325375)

  [ Jonathan Ernst ]
  * Menu entry should be named "USB startup disk creator" (LP: #286924)
  * Add French translation to desktop file

 -- Evan Dandrea <email address hidden> Wed, 18 Feb 2009 10:45:56 +0000

Changed in usb-creator:
status: Fix Committed → Fix Released
Roberto C. Morano (rcmorano) wrote :

Hi,

I still can not see more than 20 strings for translation in Rosetta although there are much more (near double) in the .pot template from trunk [1].

Please check it out. Thanks

[1] http://bazaar.launchpad.net/%7Eubuntu-installer/usb-creator/trunk/annotate/head%3A/po/usbcreator.pot

Kamil Páral (kamil.paral) wrote :

I reopen this bug because it is not fixed. There are 45 translations in Jaunty [1] but only 20 translations in the default template [2].

[1] https://translations.launchpad.net/ubuntu/jaunty/+source/usb-creator
[2] https://translations.launchpad.net/usb-creator

Changed in usb-creator:
status: Fix Released → New
Juanje Ojeda (juanje) wrote :

This bug is important for Guadalinex but also for all non-English speakers.

The usbcreator.pot seems updated in the code but the translations are not imported since awhile.
http://bazaar.launchpad.net/~usb-creator-hackers/usb-creator/trunk/annotate/head%3A/po//usbcreator.pot

Changed in usb-creator:
importance: Undecided → High
status: New → Confirmed
status: New → Confirmed
Juanje Ojeda (juanje) wrote :
Changed in usb-creator (Guadalinex):
status: Confirmed → Fix Committed
Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Committed
Adi Roiban (adiroiban) wrote :

There are still untranslatable strings in the glade file:

http://bazaar.launchpad.net/%7Eusb-creator-hackers/usb-creator/trunk/annotate/head%3A/gui//usbcreator.glade

Line 384: <property name="title">Installing</property>

In the "Installing" there is also an untranslatable "Copying files..." text, but I could not find it in the source code.

tags: added: i18n
Juanje Ojeda (juanje) wrote :

Confirmed the strings that has commented Adi Roiban. But also others in scripts/install.py:
bash$ grep -n sys.stdout.write ../scripts/install.py
35: sys.stdout.write('Copying files\n')
132: sys.stdout.write('Creating persistence file\n')
135: sys.stdout.write('Making persistence filesystem\n')

Changed in usb-creator (Guadalinex):
status: Fix Committed → In Progress
Juanje Ojeda (juanje) on 2009-04-01
Changed in usb-creator (Ubuntu):
status: Fix Committed → Confirmed
Juanje Ojeda (juanje) wrote :

I've just push to the i18n branch some changes to add gettext and _() function to scripts/install.py, so the strings which are been showing at the GUI during the copying progress dialog can be translated.

I did some test regenerating the pot and the po files and testig the new code with the translations. Now all the strings seems to be translatables.

Well, the only thing is that there is 2 time where is used "Ubuntu" to refer to the new usb written. It should be removed because it could be another distro (Kubuntu, Xubuntu, Ubuntu Studio, Guadalinex...).

Changed in usb-creator (Guadalinex):
status: In Progress → Fix Committed
Evan (ev) wrote :

Juanje,
With respect to hard-coded "Ubuntu" strings, I think usb-creator should source the release name from the CD image for the installation complete dialog, and the introduction label should be rewritten to not use a operating system title at all. I am going to use bug #321937 to track this particular part of the i18n problem.

The rest of this bug remains valid as the other problems you mention still stand.

Loïc Minier (lool) wrote :

I merged your branch but reverted the "Ubuntu" -> "distribution" changes

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Committed
Evan (ev) on 2009-09-24
Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
Adi Roiban (adiroiban) on 2009-10-05
Changed in ubuntu-translations:
status: New → Fix Released
Changed in usb-creator (Ubuntu):
assignee: nobody → khadijah mitchell (krm431043)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers