Ubuntu

Not available for translation, despite being in main

Reported by Tomasz Dominikowski on 2008-10-18
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
system-cleaner (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Timo Jyrinki
usb-creator (Ubuntu)
Undecided
Evan Dandrea
Nominated for Intrepid by Timo Jyrinki

Bug Description

Binary package hint: usb-creator

This program needs to be available for translation, it's in main and it's preinstalled. This is really late in the cycle for translators.

This is one of the i18n issues at https://wiki.ubuntu.com/TranslatingUbuntu/IntrepidTranslationIssues

Changed in usb-creator:
status: New → Confirmed
Ricardo Pérez López (ricardo) wrote :

As a patch/workaround, can the developer gives us a .pot file in order to translate it directly even without Launchpad?

Jochen Skulj (joskulj) wrote :

Our minimum goal should be to get at least all pre-installed application translated. So please open the translations in Launchpad our provide us access to update the po-files within your source repository (whereever this is located. I don't have a clue about this at the moment).

description: updated
goto (gotolaunchpad) wrote :

Hey, this is important! I want to translate but have no clue how to do that!

to be removed (liw) on 2008-10-26
Changed in system-cleaner:
status: New → Confirmed
to be removed (liw) wrote :

Ricardo, I'd be more than happy to provide the .pot file to translators. Actually, it's already here:

http://bazaar.launchpad.net/~systemcleaner-hackers/systemcleaner/trunk/files
subdirectory po, file cruftremover.pot.

Note that the software will be renamed to "Cruft Remover", so the file is now called cruftremover.pot.

I apologize for the software not being on Rosetta for translation to be easy, and also for generally being late with the whole translation support in the program. I'll see if I can get it onto Rosetta soonest, assuming that's still possible for intrepid.

to be removed (liw) wrote :

It seems to be too late now. :(

Jonathan Ernst (jonathan.ernst) wrote :

Hi Lars, here is a first version of the French translation. Please request a freeze exception to upload a new version of your tool with as many translations as possible.

Ricardo Pérez López (ricardo) wrote :

Hi Lars! Thanks for the info. I attach a preliminary version of the Spanish translation. It would be great if Intrepid uses it.

goto (gotolaunchpad) wrote :

No icons, no translations. It is a shame that such software is by default installed in a release of ubuntu. :(
Both in wrong sections of the application menu and both not necessary for a default installation.

Now it is too late, but: Where were the maintainers?

Sorry for being rude, but such things really destroy the good feeling of ubuntu. And such things should be avoided. So: How could this happen? We really need to avoid this in future releases. Thanks.

to be removed (liw) wrote :

bugmenot, it's _not_ installed by default.

usb-creator IS installed by default and is one of this release's highlight. It was included much too late in the dev. cycle and that's why we have one of the main new feature untranslated, with a bad menu name and a bad icon (stolen from ubiquity).

goto (gotolaunchpad) wrote :

I updated from Hardy to Intrepid and before that I had not system-cleaner nor usb-creator. After the upgrade I had both, both without icons and both untranslated and in the wrong sections of the application menu. IMO this software was/is not ready for a ubuntu release yet.

There was a need for a more up2date version of the graphics driver (radeonhd), and updating had been a secure thing (only bugfixes and adding of PCI ids) , but no one did that. And here come 2 unfinished applications much too late in the development cycle and even stay there, despite the nominated bugs (For me even release critical, because this two applications destroy the good image of ubuntu (especially of you're not using an english system.)

@bugmenot

system-cleaner was later removed from the dependencies of ubuntu-desktop. It means that if you upgraded before the final release you'll have system-cleaner installed (you are now free to remove it), but if you waited the final release system-cleaner won't be installed.

goto (gotolaunchpad) wrote :

This is strange: I have upgraded after the release. And I have removed the package already...

Jonathan I had a quick look at usb-creator source package and it doesn't even seem to have i18n capabilities. I consider this as a severe bug or at least a really bad development practice. Sorry for this comment, but IMHO every developper should be aware of gettext usage and i18n capabilities, english is the first language for only 6-7% of humanity and about 70% of humanity don't understand english at all.

to be removed (liw) wrote :

This bug seems to be against both system-creator and usb-creator packages. system-creator is not installed by default, but does have gettext support. Both system-creator and usb-creator were added fairly late to the default installed, and system-creator was pulled afterwards.

Because both packages are associated in this bug report, could everyone please say the name of the package instead of "it", so that everything is clear. Thanks.

Evan Dandrea (ev) on 2008-11-08
Changed in usb-creator:
assignee: nobody → evand
status: Confirmed → Fix Committed
to be removed (liw) on 2008-11-08
Changed in system-cleaner:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.1.11

---------------
usb-creator (0.1.11) jaunty; urgency=low

  [ Evan Dandrea ]
  * Strip null bytes from the CD label when parsing it from an ISO file
    (LP: #287318).
  * Internally represent the persistent file size in bytes for greater
    accuracy.
  * Move self.pipe declaration to the correct location (LP: #291645).
  * Add a bootloader installation progress message.
  * Install the bootloader to the MBR as well (LP: #273477).
  * Specify the filesystem type when mounting iso9660 images.
  * Warn the user when usb-creator cannot mount an image (LP: #287753).
  * i18n support (LP: #285413, #292556).
  * Added Swedish tranlsation (LP: #285811). Thanks Daniel Nylander.
  * Add -t option to write a trace file.
  * Don't include all .py files in the tree for translation.
  * Don't update the pot file on every build.
  * Write more information to the log (subprocesses, stderr, etc).

  [ Martin Owens ]
  * Fix small issue where enlarging the main window would have a different
    expanding effect on the top listview from the bottom listview.
  * Add gnomevfs support to use gnome device labels and icons. This should
    make things more user friendly.

  [ Mario Limonciello ]
  * Add support for providing command line ISO images.
  * Add support for defaulting the persistence setting in the UI via
    command line.
  * Default the GUI to start up centered on the screen.

 -- Evan Dandrea <email address hidden> Thu, 20 Nov 2008 09:28:08 +0000

Changed in usb-creator:
status: Fix Committed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Not fixed in stable release yet.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments