use the name USB flash drive instead of USB stick

Bug #275138 reported by Alexander van Loon on 2008-09-27
4
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: usb-creator

According to Wikipedia – http://en.wikipedia.org/wiki/USB_flash_drive#Naming – the name "USB flash drive" is the de facto standard term for these devices, and not the terms "USB disk" or "USB stick" which are currently used in usb-creator. I'm not sure though if "USB flash drive" would be the best name, because I assume usb-creator can also be used for external hard disk drives with a USB connection. In that case I think the name "USB storage device" would be better, but some external hard disk drives also use eSATA connections. Difficult to decide on a good name, but the current naming is certainly not good.

Related branches

How about the more generic "USB disk" or "USB drive"?

Alexander van Loon (avanloon) wrote :

I think my vote would go to "USB drive" as the best generic term. On Wikipedia it is mentioned – http://en.wikipedia.org/wiki/Drive – that a drive is a device that reads data and often writes data onto a storage medium (like a floppy or CD). "USB disk" isn't a good choice I think, because USB flash drives use flash memory, and not a rotating disk like a hard disk drive.

However, possibly something even more generic is needed because using "USB" in the name excludes external hard disks with an eSATA connection.

Evan (ev) on 2008-09-29
Changed in usb-creator:
importance: Undecided → Low
status: New → Confirmed
probono (probono) wrote :

Why not "Install Live System"?

It could even be integrated into the 1st screen of the regular Ubuntu Installer, it would ask: "Do you want to install a regular full system or a Live system" (and explain the differences).

Luca Ferretti (elle.uca) wrote :

GVFS (and maybe HAL) is using "thumb drive" or "USB drive". Disc is for stuff like CD or DVD.

See code in gvfs/monitor/hal/ghaldrive.c and, if i remember well, search on nautilus mailing list for a David Zeuther mail with him research about names to use.

Besides the wikipedia statement "By August 2008, "USB flash drive" or simply "UFD" had emerged as a de facto standard term for these devices" don't seems to me really trustworthy, note the [citation need]...

Evan (ev) wrote :

I've committed a fix for this to trunk. Since usb-creator no longer just operates on USB disks, but also SD cards and other removable media, I've changed the program title to "Startup Disk Creator" and changed all references to USB sticks to removable devices.

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.13

---------------
usb-creator (0.2.13) lucid; urgency=low

  [ Evan Dandrea ]
  * Set the install window as translatable. Thanks Milo Casagrande
    (LP: #414742).
  * Fix a typo in the Windows frontend (LP: #454926).
  * Use a close button instead of a quit button in the GTK+ frontend
    (LP: #285916).
  * Change the program title (not the program name) to "Startup Disk
    Creator" as usb-creator writes to more than just USB disks these days
    (LP: #275138).
  * In the GTK+ frontend, scan the download directory on startup and add
    all the CD and disk images (LP: #441104).
  * Expand the path provided by the -i option to its absolute
    (LP: #458497).
  * Unmount the target device rather than calling sync (LP: #457510).

  [ Martin Pitt ]
  * bin/usb-creator-helper: Supply start-time in the PolicyKit subject struct,
    so that this also works with current polkit-1 in lucid.
 -- Martin Pitt <email address hidden> Tue, 08 Dec 2009 10:51:37 +0100

Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers