usb-creator in Xenial fails to write customized ubuntu iso files

Bug #1605803 reported by Angelos Tzotsos
This bug affects 1 person
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)

Bug Description


I am one of the developers of OSGeoLive, an 8 year old project, which is a Geospatial distribution based on Lubuntu (previously on Xubuntu).

The last years we have been using the official customization guide to build our spin off iso files:

We are now in the process of releasing our version 10.0 (based on Xenial) and during our release candidate stage, we noticed that our 4GB iso files fail to be turned into a live usb using the usb-creator version (0.3.2) included in Ubuntu 16.04.

After building a live usb key with usb-creator 0.3.2 and try to boot from the usb, we are getting an "operating system missing" error.
We noticed that usb-creator was upgraded for Xenial, so we tried instead to use previous versions of usb-creator to create a live usb, and both Wily and Trusty versions worked. With those older versions, there was an issue with syslinux not being the same version as the one used in the iso, which we fixed as mentioned here:

We are wondering if this is a bug or it is related with some kind of bootloader change that happened in Xenial, that we are not aware of.

Steps to reproduce:
1. Download our rc1 iso file from:

2. Burn the iso into an 8GB usb key in Ubuntu Xenial

3. Boot from the new usb key.

Any help would be much appreciated.
Best regards,

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.