papercut level infrastructure fixes for usb-creator-gtk

Bug #1537836 reported by sudodus on 2016-01-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
usb-creator (Ubuntu)
Medium
Unassigned
Declined for Xenial by Marc Deslauriers

Bug Description

A new version, 0.3.2, of the Ubuntu Startup Disk Creator, is uploaded today and it works :-)

But the infrastructure around it is not updated:

1. man usb-creator-gtk

2. usb-creator-gtk --version

3. the help text (there is no persistence now) and screenshot in the Ubuntu Software Center and Synaptic

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: usb-creator-gtk 0.3.2
ProcVersionSignature: Ubuntu 4.3.0-7.18-generic 4.3.3
Uname: Linux 4.3.0-7-generic x86_64
ApportVersion: 2.19.3-0ubuntu3
Architecture: amd64
CasperVersion: 1.366
CurrentDesktop: XFCE
Date: Mon Jan 25 17:06:57 2016
LiveMediaBuild: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160125)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

sudodus (nio-wiklund) wrote :
sudodus (nio-wiklund) on 2016-01-25
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1537836

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Changed in usb-creator (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Medium
sudodus (nio-wiklund) wrote :

I suggest to upgrade the version information of usb-creator-gtk to 0.3.2 according to the attached file (output from diff)

sudodus (nio-wiklund) wrote :

I think it is time now to fix this 'papercut level' task for the Ubuntu Startup Disk Creator alias usb-creator. The version 0.3.2 has been working without any complaints (that I know of) is 16.04 LTS for around 5 months now (counting also the testing period of Xenial before it was released).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.3.3

---------------
usb-creator (0.3.3) yakkety; urgency=medium

  * Change version strings to 0.3.3. (LP: #1537836)
  * Fix PyGI import warnings.

 -- Marc Deslauriers <email address hidden> Tue, 26 Jul 2016 09:07:09 -0400

Changed in usb-creator (Ubuntu):
status: Triaged → Fix Released
sudodus (nio-wiklund) wrote :

Thanks Marc :-)

sudodus (nio-wiklund) wrote :

I can confirm that this fix has reached to the Yakkety iso files :-)

But I am still waiting for usb-creator-gtk version 0.3.3 to trickle down to the LTS releases Xenial and Trusty :-P

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers