Startup Disk Creator cannot fetch iso files from a directory with non-standard characters

Bug #1527900 reported by sudodus
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Fix Released
High
Unassigned
usb-creator (Ubuntu)
Fix Released
High
Marc Deslauriers

Bug Description

Using Swedish, the 'Downloads' folder is named 'Hämtningar', and the SDC cannot fetch files from that folder, probably because of the non-standard character ä (a-umlaut). I suppose there are similar problems with other non-standard characters, that might appear when other languages are used.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: usb-creator-gtk 0.3.1
ProcVersionSignature: Ubuntu 4.3.0-2.11-generic 4.3.0
Uname: Linux 4.3.0-2-generic i686
ApportVersion: 2.19.3-0ubuntu2
Architecture: i386
CurrentDesktop: LXDE
Date: Sat Dec 19 17:07:27 2015
InstallationDate: Installed on 2015-12-17 (2 days ago)
InstallationMedia: Lubuntu 16.04 LTS "Xenial Xerus" - Alpha i386 (20151216)
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
sudodus (nio-wiklund) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1527900

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Mörgæs (moergaes)
summary: - SDC cannot fetch iso files from a directory with non-standard characters
+ Startup Disk Creator cannot fetch iso files from a directory with non-
+ standard characters
Changed in usb-creator (Ubuntu):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in usb-creator (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.3.2

---------------
usb-creator (0.3.2) xenial; urgency=medium

  * bin/usb-creator-helper: properly handle utf-8 characters
    (LP: #1527900)

 -- Marc Deslauriers <email address hidden> Fri, 22 Jan 2016 14:35:42 -0500

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
sudodus (nio-wiklund) wrote :

Great news :-)

I'm waiting for version 0.3.2 to appear in the xenial daily iso file. It will be nice to have a version without any bug :-)

I think this version of the Ubuntu Startup Disk Creator will work very well. So far there is no other known bug, and if we find one, I think we will also be possible to squash it before 16.04 LTS will be released.

Revision history for this message
sudodus (nio-wiklund) wrote :

Thanks Marc,

The version 0.3.2 has reached the daily iso file and it works :-)

I tested with an iso file in the directory 'Hämt Ningar' which tests both the non-standard character ä and a space in the name.

Mörgæs (moergaes)
Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers