Early Syslinux Boot Error in pendrive made with the Ubuntu Startup Disk Creator

Bug #1499746 reported by sudodus on 2015-09-25
424
This bug affects 94 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
UNetbootin
Undecided
Unassigned
usb-creator (Ubuntu)
Critical
Unassigned
Wily
Critical
Unassigned

Bug Description

I cannot make a USB boot drive with the Ubuntu Startup Disk Creator in Lubuntu Wily beta 2.

The SDC no longer complains about udisks. It finishes and seems successful, but the created pendrive does not work: There is an 'early error' when booting, a black screen with white letters at the top:

"SYSLINUX 6.03 EDD 20150813 Copyright (c) 1994-2014 H. Peter Anvin et al

Boot Error"

I tested with 'the easiest case', in a live session of Wily: I tried to create a pendrive with Wily of the same architecture (i386 --> i386).

Another user reported a case with amd64 (in 15.04), so the bug seems to affect both architectures.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: usb-creator-gtk 0.2.67
ProcVersionSignature: Ubuntu 4.2.0-11.13-generic 4.2.1
Uname: Linux 4.2.0-11-generic i686
ApportVersion: 2.18.1-0ubuntu1
Architecture: i386
CasperVersion: 1.365
CurrentDesktop: LXDE
Date: Fri Sep 25 13:58:00 2015
LiveMediaBuild: Lubuntu 15.10 "Wily Werewolf" - Alpha i386 (20150924)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator
UDisksDump: Error: [Errno 2] No such file or directory: 'udisks'
UpgradeStatus: No upgrade log present (probably fresh install)

sudodus (nio-wiklund) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Chris Hermansen (c-hermansen) wrote :

I am the "another user" Nio mentions above. To confirm, in my case the bug appeared two days ago when attempting a 64 bit 15.10 startup disk under 64 bit 15.04. I attempted this process on three different USB devices: a Transcend 16Gb, a SanDisk Cruzer 4Gb and a Lexar USB Card Reader with a Transcend 4Gb Micro SDHC card in it.

There were no error messages during the usb-creator-gtk session, just an unbootable USB stick as a result.

I should mention that I had to erase the sticks with the Ubuntu "disks" utility as the "erase disk" function in usb-creator-gtk would not clear the drive for me, giving me the message:

org.freedesktop.DBus.Python.GLib.Error: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 275, in Format
    block.call_format_sync('vfat', GLib.Variant('a{sv}', {'label': GLib.Variant('s', '')}), None)
GLib.Error: udisks-error-quark: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error synchronizing after initial wipe: Timed out waiting for object (0)

The "disks" utility has no problem formatting my usb sticks; usb-creator-gtk shows no errors (as I noted above) installing the system on the drive so formatted.

Also I was able to create a working boot disk on the Transcend 16Gb using unetbootin.

Chris Hermansen (c-hermansen) wrote :

One more comment.

I *CAN* make a working ie bootable 15.04 USB stick with usb-creator on the same platform. It seems that the problem, for me at least, is in creating a working 15.10 USB stick.

sudodus (nio-wiklund) wrote :

I can confirm that it works to create USB boot drives from the wily iso files with the same hardware, when using other tools. I have iso-tested Lubuntu Wily beta 2 and used mkusb - both cloned live-only systems, and made 'grub 2 booted persistent live systems'. So the boot structure of the iso files is OK.

sudodus (nio-wiklund) wrote :

I am trying now to find something that works - call it workaround or whatever.

A system was installed from lubuntu-wily-alternate-amd64.iso (Alternate Lubuntu Wily beta 2 which I iso-tested). From that system I used the SDC to install from a file that I tested some time ago

ubuntu-wily-alternate-amd64.iso (standard Ubuntu)

into a pendrive, and the pendrive works. It is not affected by this bug. That iso file is dated August 5.

After that I downloaded the beta 2 version of ubuntu-wily-alternate-amd64.iso and used the SDC to install it into a pendrive. It is affected by this bug. So this bug seems to have appeared after August 5.

Changed in usb-creator (Ubuntu):
importance: Undecided → Critical
tags: added: vivid

If bug #1446646 exhibits the same behaviour as this one, please mark this report as duplicate.

Then in bug #1446646:

1. Into the tag list, add "wily".
2. Subscribe me to that report.

Thank you.

Changed in usb-creator (Ubuntu):
status: Confirmed → Triaged
sudodus (nio-wiklund) wrote :

@ Alberto Salvia Novella (es20490446e)

No, I think these bugs are independent of each other (this one and bug #1446646).

Okay, so that's all for my part. I'm unsubscribing now.

If you are using Ubuntu 15.10 Beta 2 (Wily), then the workaround is to manually download syslinux_6.03+dfsg-5ubuntu1 debian package from Vivid repository, extract syslinux binary and use it instead.

syslinux doesn't have other dependencies and other files used when creating a bootable usb (viz.mbr.bin) are identical between Vivid and Wily.

The error is primarily due to ldlinux.sys (which gets generated from syslinux). ldlinux.sys generated from Vivid syslinux doesn't have the issue.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1499746

tags: added: iso-testing
sudodus (nio-wiklund) wrote :

I can verify, that booting via grub 2 works like it should in UEFI mode.

The amd64 version of Ubuntu Wily daily iso file 'ubuntu-wily-desktop-amd64.iso' is still affected by this bug, the syslinux boot error. This is in BIOS mode.

I checked today in UEFI mode, and a pendrive made with the SDC in Wily and from Wily can boot (and it uses grub 2).

Changed in ubuntu-release-notes:
status: New → Fix Released
Vertago1 (vertago1) wrote :

I don't believe the note on https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes is completely correct at the moment. I just tried to make an amd64 15.10 image from 15.10 and it sort of works in that the uEFI works, but the legacy boot gives the syslinux error.

sudodus (nio-wiklund) wrote :

I can confirm that this bug is still alive. It affects booting with syslinux in BIOS alias legacy mode. It has never affected booting with grub in UEFI mode.

Simon Lynch (simon-lynch) wrote :

amd64 15.10 image from 15.10 on USB

- on Thinkpad T550 (using several variation of BIOS settings)
- several USBs with different formats

"SYSLINUX 6.03 EDD 20150813 Copyright (c) 1994-2014 H. Peter Anvin et al Boot Error"

Confirmed for me as well.

Simon Lynch (simon-lynch) wrote :

Addendum to #16 - However did make it work if you turn UEFI back on - thanks Vertago1.

Vertago1 (vertago1) wrote :

#17, I didn't turn UEFI on or off. My motherboard had two different usb boot options when I displayed the boot menu, one for legacy boot and one for UEFI. The legacy one gave the error described in the bug, while the UEFI one worked.

JoLa (josef-latt) wrote :

I also have the sysliniux error booting my USB stick first created with ubuntu 15.10 iso using usb-creator and second with unetbootin.

A stick created with dd works.

Radko Dinev (radko-dinev) wrote :

I have the same error when not using UEFI.

Grzegorz Śliwiński (fizyk) wrote :

same for me

I've created live usb with ubuntu 15.10 on Ubuntu 15.04, just after fresh upgrade today. I got this error on system without uefi, but on uefi it boots up just fine.

Robert Tari (robert-tari) wrote :

Same here.

Created a 15.10 USB on 15.04 and I am stuck with the above mentioned error. I have no UEFI, so no way around this.

sudodus (nio-wiklund) wrote :

Oh yes, there are ways around this bug. This bug affects the Startup Disk Creator, but there are other tools, that are *not* affected, for example mkusb in Ubuntu and Win32 Disk Imager in Windows.

https://help.ubuntu.com/community/mkusb

https://wiki.ubuntu.com/Win32DiskImager/iso2usb

Newton (newton-s-kim) wrote :

I made a pendrive using mkusb and it works. Thanks sudodus.

rtimai (rtimai) wrote :

The Wily Release Notes (https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes#Boot.2C_installation_and_post-install) indicate that a 15.10 Live USB may be successfully created using usb-creator "on a matching release of Ubuntu" (i.e., Ubuntu 15.10.) I believe this is incorrect, as I have successfully *upgraded* from 15.04 to 15.10, but am unable to create a bootable USB stick with ubuntu-15.10-desktop-amd64.iso using either usb-creator-gtk 0.2.67ubuntu1 or UNetbootin 6081(wily). In all attempts, "SYSLINUX 6.03... Boot error" message results as initially described.

I also tried using UNetbootin to install the latest "daily-live-x64" iso with the same boot error.

Jamie Strandboge (jdstrand) wrote :

I also tried to create a legacy boot key on a wily system for a wily boot key and was unable to. I even downgraded syslinux* to those in vivid and it still did not work. Ultimately, I had to create a vivid boot key then upgrade the system with do-release-upgrade to wily.

Rickard (rickard-uk) wrote :

Same problem here I have added a photo of what it looks like.
Tried to create a 15.10 USB start up disc using 15.04.

I had this problem in Vivid, but did not think to check for bug reports.

Now I have upgraded to Wily on two laptops and subsequently created startup pen drives a total of 10+ times, using 4 different physical pen drives. None of these have worked on either of the two laptops. Both laptops are hp ProBooks. The error message is invariably the same:

SYSLINUX 6.03 EDD 20150813 Copyright (C) 1994-2014 H. Peter Anvin et al
Boot error

pablomme (pablomme) wrote :

Quick note: flashing 15.04 from 15.10 does work (useful if you just need a more-or-less recent live environment)

Mauro Rossi (mauro-rossi) wrote :

Hi,

please assign the bug to be resolved.

On Ubuntu 15.10 unetbootin is affected because of syslinux_603 package,
while forcing installation of package from previous Ubuntu release unetbootin works ok.

sudo dpkg --force-all -i syslinux_6.03+dfsg-5ubuntu1_amd64.deb

Please correct the syslinux package of wily ( 6.03+dfsg+8ubuntu2 ) which is causing problems to all syslinux dependent usb disk cerator softwares.

Thanks from all Ubuntu Wily community of people.

Mauro

Rômulo (tlromulo-o) wrote :

Yes, this needs to be fixed, please. The problems seems to affect only the most recent version of Ubuntu (Ubuntu 15.10).

Thanks to sudodus for providing the workaround.

Stefan Leitner (s-o-l) wrote :

It also effects amd64 systems from where you try to create an usb boot stick and also both, i386 and amd64 ISOs

tags: removed: i386
Stefan Leitner (s-o-l) wrote :

@ Mauro Rossi

I tried your suggestion with forced installing of syslinux_6.03+dfsg-5ubuntu1_amd64.deb - but the boot error remained also after a restrart.

Stefan Leitner (s-o-l) wrote :

@ Mauro Rossi

Sorry, I forgot to mention that I tried it with usb-creator-gtk, not with unetbootin.

you are correct, with unetbootin your solution is working. but not with usb-creator-gtk.

Same here on Ubuntu 15.10 64bit. Tried both standard USB 2.0 pendrive and a USB 3.0 pendrive. Always arrives at the Boot Error after using Startup Disk Creator.

Also seeing this bug - 15.10 (64 bit) created on a 15.10 (64 bit) system results in a "Boot error" when booting.

Jason Youzwak (veganjay) wrote :

Also noticing this issue. I installed Ubuntu 15.10 to a USB stick using Startup Disk Creator, and upon booting I receive the "SysLinux Boot Error".

the key made with the startup disk creator does not work, even on old hardware. nevertheless, simply copying the whole iso image on a key works.

thus, workaround (as root or sudo):

dd if=ubuntu-15.10-desktop-amd64.iso of=/dev/sdX bs=16M ; sync

replace "X" with your usb key letter, see eg dmesg or blkid, end then eject the drive. for "X" do not include any partition numbers.

Bert Calatz (bertcalatz) wrote :

Also noticing this issue. I installed Ubuntu 16.04 to a USB stick using Startup Disk Creator and/or Unetbootin, and upon booting I reveice the "Syslinux Boot Error". I tried several workarounds (from here and bug report 1507002) but none of them worked for me.

Phil Boutros (philb61) wrote :

Can confirm the bug here as well, creating from 15.10, burning 15.10 image (to install 15.10 on another machine) with usb-creator. Now doing the dd option directly instead.

Ari Torhamo (ari-torhamo) wrote :

Mkusb worked for me too – thank sudodus! I wish I had found your comment a few hours earlier...

Bert Calatz (bertcalatz) wrote :

Oké, in addition on a earlier post (2015-12-11)

Working in 15:10 and downloading the xenial iso (16.04). Unetbootin and Startup Disk Creator failed to make a bootable USB

However, here a workaround that worked for me.

Right click on the xenial iso file, open with disk image writer, choose youre usb drive and click Start Restoring. Follow the instructions.

Kaiwan (kaiwan-billimoria) wrote :

I faced this bug as well, though in a slightly different fashion:
I was using extlinux directly to install syslinux a USB pendrive and boot a custom Linux distro off it. All well until this bug hit, i,e, Wily's version of syslinux!

Thanks to Praveen B - your comment workaround helped me install the working package from Vivid Vervet, and all worked again.

Pierre van Male (vmalep) wrote :

Hi,

Unable to create any Live USB from a Ubuntu 15.10 install.

The solution given by Mauro Rossi (comment #31) works for me (creating the live usb with UNetbootin).

The syslinux package is available here:
http://packages.ubuntu.com/vivid/amd64/syslinux/download

BR
Pierre

Theodotos Andreou (theodotos) wrote :

This bug is still here. mkusb worked fine.

vedavata (vedavrata) wrote :

   I had the same problem (error) of "Startup Disk Creator" (Xubuntu 15.10).
   And the tool 'gnome-disks' (from the package 'gnome-disk-utility') helped me:
apt-cache search gnome-disk
gnome-disk-utility - manage and configure disk drives and media
which gnome-disks
/usr/bin/gnome-disks
 Use the "Restore Disk Image..." from a disk Menu.

Stefan (steeflemmens) wrote :

Thank you, vedavata, your solution worked for me!

worldwidemv (web-markus) wrote :

I had the same problem on a Lenovo T440s. UEFI / Secure Boot is disabled.

I got the "boot error" error.

However, there was a special BIOS option called "USB UEFI BIOS Support". This was enabled. After disabling it, the USB stick booted fine.

The description for disabled reads: "Disables boot with USB diskette, USB memory key and USB optical drive.", so not that intuitive to disable the option., especially since UEFI is already off.

Erik Leitner (erik-leitner) wrote :

for me #49 did not work (on Lenovo T430)
see bug #1507002 for installing fixed syslinux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers