usb-creator fails to run syslinux due to architecture mismatch

Bug #1446646 reported by Erick Brunzell on 2015-04-21
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Trusty
High
Unassigned
Vivid
High
Unassigned

Bug Description

I had previously just considered this same_as bug #1338528, but it's now marked as a duplicate of bug #1330165 which is Fix Released, so I'm reporting this as a new bug since I'm trying to use Vivid to create a Vivid live USB. The Vivid version of usb-creator constantly fails to successfully create a Vivid live USB at the point of installing the bootloader.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: usb-creator-gtk 0.2.67
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic i686
ApportVersion: 2.17.2-0ubuntu1
Architecture: i386
CurrentDesktop: GNOME-Flashback:Unity
Date: Tue Apr 21 08:04:53 2015
InstallationDate: Installed on 2015-04-01 (20 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Beta i386 (20150331)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator
UDisksDump: Error: [Errno 2] No such file or directory: 'udisks'
UpgradeStatus: No upgrade log present (probably fresh install)

Erick Brunzell (lbsolost) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1446646

tags: added: iso-testing
Brian Murray (brian-murray) wrote :

From the UsbCreatorLog.txt:

usb-creator 2015-04-21 07:43:35,964 (DEBUG) install.py:232: install_bootloader
usb-creator 2015-04-21 07:43:47,676 (CRITICAL) install.py:99: Failed to install the bootloader.
usb-creator 2015-04-21 07:43:47,678 (ERROR) frontend.py:737: Installation failed.
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/usbcreator/install.py", line 257, in install_bootloader
    timeout=MAX_DBUS_TIMEOUT)
  File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python3/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.OSError: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 226, in InstallBootloader
    popen([syslinux_exe, '-f', device])
  File "/usr/lib/python3/dist-packages/usbcreator/misc.py", line 169, in popen
    startupinfo=startupinfo)
  File "/usr/lib/python3.4/subprocess.py", line 859, in __init__
    restore_signals, start_new_session)
  File "/usr/lib/python3.4/subprocess.py", line 1457, in _execute_child
    raise child_exception_type(errno_num, err_msg)
OSError: [Errno 8] Exec format error

Brian Murray (brian-murray) wrote :

I was unable to recreate this using usb-creator-gtk version 0.2.67. It may be worth noting that udisks --dump works for me and it failed when apport was generating this crash report.

UDisksDump: Error: [Errno 2] No such file or directory: 'udisks'

Brian Murray (brian-murray) wrote :

Actually, it seems that the apport hook calls udisks without checking to see if it is available.

Brian Murray (brian-murray) wrote :

I've fixed the apport hook for usb-creator-gtk in trunk.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
sudodus (nio-wiklund) wrote :

It is possible that this bug is causing usb-creator-gtk to fail today, when a fix for bug #1325801 is released to the trusty-proposed repository and fails to work.

Changed in usb-creator (Ubuntu):
importance: Undecided → High
Vivien GUEANT (vivienfr) wrote :

The Vivid version of usb-creator constantly fails to successfully create a Vivid live USB at the point of installing the bootloader.
The USB Key (2 GB) is formatted in FAT32

DistroRelease: Ubuntu 15.04 AMD64
Package: usb-creator-gtk 0.2.67ubuntu0.1
ProcVersionSignature: Ubuntu 3.19.0-16-generic
Architecture: AMD64
CurrentDesktop: GNOME-Flashback:Unity

Elmer Fudd (efuudd) wrote :

Same error for me.
Note that this only happens with the 15.04 64 bit image (which I need), but works fine with the 32bit image.
Format 32bit 16g thumb drive as FAT 32.
Fails at install of bootloader.

Right, this explodes because the architecture you're running on doesn't allow starting executables of the architecture you're trying to burn on the USB disk.

Thanks for filing this bug, this is a genuine issue that we had not anticipated in the other bug you linked -- marking Triaged/High.

For now, you may wish to use dd to create these images; for example:
$ dd if=ubuntu-15.04-desktop-amd64.iso of=/dev/sdz bs=512

Will write the image to the USB device directly -- remember to make sure you pick the right device instead of /dev/sdz which should be your USB disk; since dd will happily write the contents of the image where you tell it to without confirmation. If you pick the wrong disk, you can say bye-bye to your data now.

Changed in usb-creator (Ubuntu):
status: Confirmed → Triaged
summary: - Vivid usb-creator fails to install bootloader
+ usb-creator fails to run syslinux due to architecture mismatch
Changed in usb-creator (Ubuntu Precise):
status: New → Triaged
Changed in usb-creator (Ubuntu Trusty):
status: New → Triaged
Changed in usb-creator (Ubuntu Vivid):
status: New → Triaged
Changed in usb-creator (Ubuntu Precise):
importance: Undecided → Medium
Changed in usb-creator (Ubuntu Trusty):
importance: Undecided → High
Changed in usb-creator (Ubuntu Vivid):
importance: Undecided → High
Changed in usb-creator (Ubuntu Precise):
importance: Medium → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers