Hangs while erasing disk

Bug #1289269 reported by David Henningsson on 2014-03-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned

Bug Description

See screenshot - I was about to erase a disk so I could make a new live USB disk, and I've been waiting a few minutes now (it ususally finished in a few seconds). The "erasing" button is grayed out and the animation is running constantly.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: usb-creator-gtk 0.2.54
ProcVersionSignature: Ubuntu 3.13.0-14.34-generic 3.13.5
Uname: Linux 3.13.0-14-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Mar 7 11:47:09 2014
InstallationDate: Installed on 2013-11-04 (123 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131103)
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

David Henningsson (diwic) wrote :
David Henningsson (diwic) wrote :
David Henningsson (diwic) wrote :

After restarting usb-creator, the disk shows having correct amount of free space. However trying to create a startup disk immediately fails with "Installationen misslyckades" (means "installation failed").

Yu Ning (yuningdodo) wrote :

I have created a patch for this issue, would you like to give it a try?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
David Henningsson (diwic) wrote :

Thanks for the patch!

With this version, the problem has changed.

No longer do we wait indefinitely for the "erasing" button do become clear, but when it is finished, the amount of free space is reported as "0.0 B", and you still can't continue to the next step (i e create the USB disk), because the "create startup disk" button is grayed out.

Changed in usb-creator (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.56

---------------
usb-creator (0.2.56) trusty; urgency=medium

  [ Ivan Larionov ]
  * Loop-mount iso in read-only mode, can't modify it anyway. (LP: #1289314)

  [ Daniel Lawrence ]
  * usb-creator doesn't refresh size error (LP: #521311)

  [ Jeremy Bicha ]
  * Always select the most recent image found (LP: #1087117)

  [ Yu Ning ]
  * GTK: Handle the backend.format_ended_cb callback otherwise the erasing
    operation will never ended. (LP: #1289269) (LP: #1273925)

  [ Dimitri John Ledkov ]
  * At the end of successful UDisks2 format, trigger device change to
    remount and recalculate the now formatted free space.
 -- Dimitri John Ledkov <email address hidden> Tue, 01 Apr 2014 15:04:39 +0100

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Released
Yu Ning (yuningdodo) wrote :

Verified this issue is fixed with usb-creator 0.2.56, thanks.

Jeff (jfhavet) wrote :

I'm still having the issue with usb-creator-gtk 0.2.56.1

Here is a workaround :

1 Open unity dash
2 Search for "Disks" and open the software
3 Select your usb stick in the peripherals list
4 Click the little gears then select "Restaure disk image"
5 "Restaure" Ubuntu iso image onto your stick

And... voilà! Here is your bootable usb stick.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers