usb-creator-kde crashed with SIGSEGV in QWidgetPrivate::deleteTLSysExtra() on exit

Bug #1289026 reported by Josh Klecka on 2014-03-06
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
Utopic
Medium
Unassigned

Bug Description

[Impact]
usb-creator-kde crashes on exit

[Steps to reproduce]
* Open usb-creator-kde
* Close usb-creator-kde
* Upgrade to fixed version in -proposed
* Open usb-creator-kde
* Close usb-creator-kde

[Regression Potential]
None, similar fixes have been deployed for other Python-Qt projects

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: usb-creator-kde 0.2.54
ProcVersionSignature: Ubuntu 3.13.0-15.35-generic 3.13.5
Uname: Linux 3.13.0-15-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: KDE
Date: Thu Mar 6 16:19:21 2014
ExecutablePath: /usr/bin/usb-creator-kde
InstallationDate: Installed on 2014-03-05 (1 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140304)
InterpreterPath: /usr/bin/python3.4
ProcCmdline: /usr/bin/python3 /usr/bin/usb-creator-kde
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: usb-creator
StacktraceTop:
 QWidgetPrivate::deleteTLSysExtra() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QWidgetPrivate::deleteExtra() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QWidgetPrivate::~QWidgetPrivate() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
 QObject::~QObject() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
Title: usb-creator-kde crashed with SIGSEGV in QWidgetPrivate::deleteTLSysExtra()
UDisksDump: Error: [Errno 2] No such file or directory: 'udisks'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Josh Klecka (makamakamaka5) wrote :

StacktraceTop:
 QWidgetPrivate::deleteTLSysExtra (this=0x21206d0) at kernel/qwidget_x11.cpp:2890
 QWidgetPrivate::deleteExtra (this=this@entry=0x21206d0) at kernel/qwidget.cpp:1832
 QWidgetPrivate::~QWidgetPrivate (this=0x21206d0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
 ~QDialogPrivate (this=0x21206d0, __in_chrg=<optimized out>) at ../../include/QtGui/private/../../../src/gui/dialogs/qdialog_p.h:66
 QDialogPrivate::~QDialogPrivate (this=0x21206d0, __in_chrg=<optimized out>) at ../../include/QtGui/private/../../../src/gui/dialogs/qdialog_p.h:66

Changed in usb-creator (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Rohan Garg (rohangarg) on 2014-05-26
information type: Private → Public
description: updated
Changed in usb-creator (Ubuntu Utopic):
status: Confirmed → Fix Released
Rohan Garg (rohangarg) on 2014-05-26
Changed in usb-creator (Ubuntu Trusty):
status: New → In Progress

Hello Josh, or anyone else affected,

Accepted usb-creator into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/usb-creator/0.2.56.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in usb-creator (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Rohan Garg (rohangarg) wrote :

usb-creator-kde upgrades fine and does not crash on quit after the upgrade.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.56.1

---------------
usb-creator (0.2.56.1) trusty-proposed; urgency=medium

  [ Rohan Garg ]
  * Workaround Python Qt4 being sucky (LP: #1315866)
    - Known bug in Python Qt4 trying to delete objects twice, workaround by
      telling SIP to not call dtors on each object, and instead throwing away
      everything at the end
  * Stable release update (LP: #1289026).
 -- Evan Dandrea <email address hidden> Mon, 26 May 2014 15:28:12 +0100

Changed in usb-creator (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for usb-creator has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers