usb-creator-gtk fails to finish erasing a usb drive

Bug #1273925 reported by Doug McMahon on 2014-01-29
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned

Bug Description

Test case:
open usb-creator-gtk on a usb drive that has been used before & needs erasing
click erase
What happens:
The erase process never completes though after a bit the "Make Startup Disk" box becomes active
If the "Make Startup Disk" box is clicked on the s-d-c closes with an installation failed message
Otherwise 'erasing disc' just goes on & on.

If s-d-c is closed & then re-opened the disc drive will have been erased & installation proceeds normally

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: usb-creator-gtk 0.2.53
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Uname: Linux 3.13.0-5-generic x86_64
ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Jan 28 21:40:29 2014
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :
Yu Ning (yuningdodo) wrote :

This bug seems like a duplicate of bug #1289269.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed

It renders essential features or functionality of the package (or a dependent one) broken.

Changed in usb-creator (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.56

---------------
usb-creator (0.2.56) trusty; urgency=medium

  [ Ivan Larionov ]
  * Loop-mount iso in read-only mode, can't modify it anyway. (LP: #1289314)

  [ Daniel Lawrence ]
  * usb-creator doesn't refresh size error (LP: #521311)

  [ Jeremy Bicha ]
  * Always select the most recent image found (LP: #1087117)

  [ Yu Ning ]
  * GTK: Handle the backend.format_ended_cb callback otherwise the erasing
    operation will never ended. (LP: #1289269) (LP: #1273925)

  [ Dimitri John Ledkov ]
  * At the end of successful UDisks2 format, trigger device change to
    remount and recalculate the now formatted free space.
 -- Dimitri John Ledkov <email address hidden> Tue, 01 Apr 2014 15:04:39 +0100

Changed in usb-creator (Ubuntu):
status: Confirmed → Fix Released
Yu Ning (yuningdodo) wrote :

Verified this issue is fixed with usb-creator 0.2.56, thanks.

Matheus (mcmaquine) wrote :

I'm still having problem even with version 0.2.56.1. Please help.

Jeff (jfhavet) wrote :

I'm still having the issue too with usb-creator-gtk 0.2.56.1

Here is a workaround :

1 Open unity dash
2 Search for "Disks" and open the software
3 Select your usb stick in the peripherals list
4 Click the little gears then select "Restaure disk image"
5 "Restaure" Ubuntu iso image onto your stick

And... voilà! Here is your bootable usb stick.

gene_wood (gene.wood) wrote :

Bug 243039 was linked to this bug. I can confirm what @jfhavet is saying that with usb-creator-gtk 0.2.56.1 which is the most recent version under Ubuntu 14.04, this issue persists. When clicking the "Erase" button the following error pops up :

org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 218, in Format
    parent_dev = _get_parent_object(udisks, device)
  File "/usr/share/usb-creator/usb-creator-helper", line 49, in _get_parent_object
    parent = partition.get_cached_property('Table').get_string()
AttributeError: 'NoneType' object has no attribute 'get_cached_property'

I can also confirm that @jfhavet's workaround works well. Under English localized Ubuntu 14.04 the process is :

1 Open unity dash
2 Search for "Disks" or "udisksd" and launch "Disks"
3 Select your usb stick in the peripherals list
4 Click the little gears then select "Restore disk image..."
5 "Restore" Ubuntu iso image onto your stick

gene_wood (gene.wood) wrote :

This is either because Bug 243039 shouldn't have been linked to this bug because it's a seperate issue, or the fix reported in Comment #6 didn't actually fix this bug. I'm not sure if this bug should be re-opened as not fixed or if Bug 243039 should be unlinked from this bug as a seperate issue that has not been fixed.

gene_wood (gene.wood) wrote :

Sorry, those references in Comment #11 and Comment #10 above to Bug 243039 should be to Question 243039 : https://answers.launchpad.net/ubuntu/+question/243039 not Bug 243039

Christian González (droetker) wrote :

@gene_wood you can hide your own comments (right corner) - better do this to reduce confusion...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions