usb-creator-gtk --help leads to a segmentation fault

Bug #1265810 reported by Apteryx on 2014-01-03
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned

Bug Description

When displaying help by using "usb-creator-gtk --help" on the terminal, the help screen is shown and a segmentation fault error occurs, most of the time.

This only happen when using the latest trunk available from launchpad (revno 422, 0.2.52) with ~100% occurence rate, and on the Ubuntu 13.10 platform.

The problem is not reproducible using version 0.2.50 on Ubuntu 13.10.

Apteryx (maxco) on 2014-01-03
description: updated
summary: - usb-creator-gtk --help leads to a segmentation fault (core dumped)
+ usb-creator-gtk --help leads to a segmentation fault
Brian Murray (brian-murray) wrote :

This does not happen on Trusty, the release for which version 0.252 is designed.

Changed in usb-creator (Ubuntu):
status: New → Invalid
Brian Murray (brian-murray) wrote :

Sorry, this actually does happen on trusty. I didn't notice it because it happens after all the help has printed.

Changed in usb-creator (Ubuntu):
status: Invalid → New
status: New → Triaged
Changed in usb-creator (Ubuntu):
importance: Undecided → High
tags: added: trusty
era (era) wrote :

I don't see a segfault, but I see a pesky error message about "g_hash_table_destroy" apparently wanting to find a window to destroy when there are no windows (like when you run with --help or --version).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers