USB drive is created successfully, but fails to boot

Bug #1190256 reported by Xiaodong Xu on 2013-06-12
258
This bug affects 59 people
Affects Status Importance Assigned to Milestone
Linux Mint
New
Undecided
Unassigned
tuxboot
Fix Released
Undecided
Fritzielein
Debian
Fix Released
Unknown
unetbootin (Ubuntu)
Undecided
Unassigned
usb-creator (Ubuntu)
Undecided
Unassigned

Bug Description

Booting from USB drive shows the following error:

Failed to load libutil.c32
Failed to load COM32 file menu.c32

Solution: Copy libutil.c32 and libcom32.c32 to USB drive root directory after boot normally.

System: Funtoo
UNetbootin version: 584
Syslinux version: 5.01

Scott Tripp (kscott-tripp) wrote :

I get the same error message as described in the bug, but the suggested workaround does not help.

I also just tried this, on a Mageia4 system, (trying to load the Ubuntu trusty server 64 iso).
For me, the workaround does work - I just had to copy over /usr/lib/syslinux/libutil.c32

I think the issue is caused by a recent change in the way syslinux works
http://www.syslinux.org/wiki/index.php/Library_modules

See also: https://bugs.mageia.org/show_bug.cgi?id=11910

David Natkins (dnatkins) wrote :

You need to copy menu.c32 as well to the root directory of the USB drive. That worked for me (UBUNTU 14.10)

Changed in debian:
status: Unknown → New
Götz Christ (g-christ) wrote :

I have the same problem with unetbootin 608 (Arch Linux package) and syslinux 6.03pre19 when trying to boot Lubuntu 14.04 from a USB memory.

The described workaround works for me, coping the three files, libutil.c32 libcom32.c32 menu.c32 from /usr/lib/syslinux/bios/ to the USB drive root directory.

Changed in debian:
status: New → Confirmed
fabrixx (kraestal) wrote :

In Debian testing actually i find that files in /usr/lib/syslinux/modules/bios

Vipin (vipings007) wrote :

Where do i find the specified files ?? I am trying to boot debian.

Joan Tur (joantur) wrote :

My behaviour differs slightly. I'm running Debian testing, and the error I get only shows:
"Failed to load COM32 file menu.c32"

After adding the "menu.c32" file to tue USB's root I get the same error as Xiaodong Xu:
"Failed to load libutil.c32
Failed to load COM32 file menu.c32"

After adding the remaining two files the USB starts to boot, but hangs in a short while after showing some system booting information... same behaviour with both DeepIn (ubuntu based) and Debian Wheezy live USB.

Also, in all cases "dd if=isofile of=/dev/sd?" works flawesly.

@fabrixx: you're running Debian testing... is the workarround working for you??

Changed in debian:
status: Confirmed → Fix Released
Mike Townsend (mike-townsend00) wrote :

26-10-2014 In Ubuntu Mate, 14.10, I had to add the 3 above mentioned files (Thanks to you all) but I had to get them from:
"/usr/lib/syslinux/modules/bios". I added these to the root of the USB and the USB os loaded fine.

Severin Wünsch (sk1d) wrote :

I can confirm this bug on lubuntu 14.10

Is this package under active development?

Štefan Baebler (stefanba) wrote :

for me ubuntu-14.10-desktop-amd64 boot with multibootusb on a USB stick fails with:
---
SYSLINUX 6.02 EDD 2013-10-13 Copyright (C) 1994-2013
Undef symbol FAIL: __syslinux_shuffler_size
Failed to load libcom32.c32
Failed to load COM32 file gfxboot.c32
boot:
---
both of these above mentioned files are present in:
"F:\multibootusb\ubuntu-14.10-desktop-amd64\isolinux\gfxboot.c32"
"F:\multibootusb\ubuntu-14.10-desktop-amd64\isolinux\libcom32.c32"
and are exactly the same size as within the SquashFS archive:
F:\multibootusb\ubuntu-14.10-desktop-amd64\casper\filesystem.squashfs\usr\lib\SYSLINUX\modules\bios\

libutil.c32 file also matches perfectly, however menu.c32 is missing. Will try booting it after copying menu.c32 from squashfs to isolinux and will report back.

I suspect this is fixed (well, changed at least) upstream;
http://www.syslinux.org/wiki/index.php/Syslinux_6_Changelog says:
Changes in 6.03:
...
core, BIOS: Move __syslinux_shuffler_size to assembly. Actually get the shuffler size sanely. Fix booting recent Syslinux versions on certain hardware and on certain virtualization software (e.g. QEMU 0.11.1, VirtualBox 4.1.x).
...

Changes in 6.02
BUG Warning: Using Syslinux 6.02 on BTRFS volumes corrupts the superblock. Use 6.03 or newer .

Interestingly booting the same source iso directly in the oracle virtualbox works fine.
Also earlier ubuntu-14.04.1-desktop-amd64 boots with no problems from the same USB stick and same multibootusb on the same computer.

Štefan Baebler (stefanba) wrote :

As expected, the copying of menu.c32 didn't help.

colas (colas-nahaboo-net) wrote :

same bug trying to create a bootable USB disk for Ubuntu 14.10 desktop 64 bits from an Ubuntu 14.10 desktop 64 bits system, with unetbootin 603-1

Copying the 3 files /usr/lib/syslinux/modules/bios/{libcom32,libutil,menu}.c32 to the root of the USB disk worked.

Brian (brini25) on 2014-11-09
Changed in unetbootin:
status: New → Incomplete
status: Incomplete → New
Oskar (oskarse) wrote :

Unetbootin worked fine for me up to 14.10. Bootable USB keys created with unetbootin in 14.10 display "Failed to load COM32 file menu.c32 boot: " when I try too boot these USB keys.

I made two of them ( most recent versions of Parted Magic and Knoppix) and both of them stop and display the error message "Failed to load COM32 file menu.c32" boot: "

When you see this message, hit the "Tab" key and you will see a list of booting options:

unetbootindefault
ubnentry0
ubnentry1
ubnentry2
ubnentry3
ubnentry4
ubnentry5
ubnentry6
ubnentry7
ubnentry8
ubnentry9
ubnentry10
ubnentry11
ubnentry12
ubnentry13
ubnentry14

I just type unetbootindefault and that starts the booting from the USB key .

It seems that the booting from default is not working, but I do not know why...
Hope this helps

  // , The above answer "Copying the 3 files /usr/lib/syslinux/modules/bios/{libcom32,libutil,menu}.c32 to the root of the USB disk worked." worked for me.

I was trying to install ubuntu 14.10 x64 to a PNY device.

After you install Ubuntu 14.10 to your USB drive, run the following commands:

cd /usr/lib/syslinux/modules/bios/
cp libcom32.c32 /media/path/to/usb/drive/
cp libutil.c32 /media/path/to/usb/drive/
cp menu.c32 /media/path/to/usb/drive/

If you have any more questions about this, PM me.

tags: added: unetbootin
tags: added: installation
tags: added: mageia
tags: added: bios
tarak parab (tarakparab) wrote :

It seems typing 'live' (without ' ') and pressing enter boots the pendrive! I tried and it worked for me. Sometimes the screen flashes two-three time before booting.

paul (paulse) wrote :

actually typing "live" works, booting Ubuntu 14.04.1 LTS
Thanks.

Solution #14 worked for me.
Copied the three mentioned files and was still getting the error. Hit Tab and type in unetbootindefault
The computer now boots through the image burned to the USB.
Can confirm bug on lubuntu 14.10

Ivan Frimme (9-ivan) wrote :

Can confirm https://bugs.launchpad.net/unetbootin/+bug/1190256/comments/14 works on Debian Jessie. tx Oskar!

I copied libcom32.c32, libutil.c32, menu.c32 and gfxboot.c32 from Ubuntu 14.10 /usr/lib/syslinux/modules/bios to the root of an USB stick with Ubuntu 14.10 without success.

Typing 'live' and pressing Enter worked then.

deysonthome (deysonthome) wrote :

.I copied libcom32.c32, libutil.c32, menu.c32 only to de root directory .... and solved the problem ...good solution ... thanks

whoknows (adv8888) wrote :

Mine is to boot ubuntu-14.10-desktop-amd64 with multibootusb on a USB stick.
looping with these 4 lines every a few seconds:
"
Undef symbol FAIL: __syslinux_shuffler_size
Failed to load libcom32.c32
Failed to load COM32 file gfxboot.c32
boot:
"
Copied all 4 files as netAction did but no luck.

Only typing 'live' and pressing Enter worked. (Yes, w/o copying those files.)

Bill Moran (bill1moran) wrote :

Same problem with ubuntu server 14.10. I used #14 and typed "unetbootindefault" at the boot prompt and it worked.

Thanks!

I got same problem on Minimal CD Ubuntu 14.04.
And i used with #22 and it worked.

Thanks!

Chad Miller (cmiller) wrote :

Happens with Ubuntu 14.04.2.

Changed in unetbootin (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Seb Bonnard (sebma) wrote :

Hi again,

My mistake, this issue seems to be solved by unetbootin 608 :

http://changelogs.ubuntu.com/changelogs/pool/universe/u/unetbootin/unetbootin_608-1/changelog

Sorry for my previous comment.

Changed in unetbootin:
status: New → Fix Released
Götz Christ (g-christ) wrote :

Come on, this is not fixed, since the bug exists in version 208 which is the latest version and was released in 2014. (See comment 4)

Mehdi EL KRARI (mehdielk) wrote :

typing "install" for ubuntu server works for me. Unless it ask me to mount the CD in one of installation steps.

affects: unetbootin → tuxboot
Changed in tuxboot:
assignee: nobody → Fritzielein (ah-haagmans)
Roberta Lrp (ennesimo) wrote :

Hi,

I get this while booting Tails (Debian) from live usb:

"Failed to load COM32 file menu.c32"

Please could you explain me how can I download and copypaste the missing files?

I found this package containing the files you mentioned but I don't understand how can I keep and put on the root the ones I need only: https://www.archlinux.org/packages/core/x86_64/syslinux/

Thanks.

AliceMarkBB (alicemackbb) wrote :

For my Xubuntu 16.04, the missing files is available in usr/lib/syslinux/modules/bios. Just copy them to the root (/) of your usb. This solution worked well for me when I try to test Trinity Rescue USB. Thanks a lot, guys. (I still get the same error for the solution of hitting Tab and type what appear on the screen).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.