64 bit live-USB successfully boots, but without persistence on UEFI pc

Bug #1159016 reported by Ubfan on 2013-03-22
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
grub
Unknown
Unknown
usb-creator (Ubuntu)
Status tracked in Vivid
Vivid
High
Unassigned

Bug Description

The 64but 12.10 2G live USB was set up on a 32bit 12.04.1 non-UEFI host with 1G persistence.
The USB boots and persistence works on the non-UEFI host.
The USB boots in Secure boot mode but without persistence on a UEFI host.
The /proc/cmdline on the running live media shows the running kernel to be vmlinuz.efi.signed, which of
course does not appear in any syslinux config files.
Looks like something got left out in the secure boot procedure to have persistence.

Live media created with the following iso:
800063488 Mar 18 11:14 ubuntu-12.10-desktop-amd64.iso
md5sum
7ad57cadae955bd04019389d4b9c1dcb ubuntu-12.10-desktop-amd64.iso

The UEFI host is a Toshiba Satellite S855-5378 and has Windows 8 preinstalled,
so no legacy BIOS is present.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: usb-creator-gtk 0.2.38
ProcVersionSignature: Ubuntu 3.2.0-39.62-generic-pae 3.2.39
Uname: Linux 3.2.0-39-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: i386
Date: Fri Mar 22 16:48:52 2013
ExecutablePath: /usr/bin/usb-creator-gtk
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

Ubfan (ubfan1) wrote :
Fred Palmer (oldfred) wrote :

The live installer boots with syslinux for BIOS and grub for UEFI.

So I think you have to edit grub menu for persistence as with UEFI syslinux is not used.
Not sure how to do that, as I do not use persistence.

Ubfan (ubfan1) wrote :

Thanks Fred. Yes the fix is simple enough, add the word "persistent" to the /boot/grub/grub.cfg vmlinuz kernel lines. This bug still affects 13.04 also.
  I find persistence useful for setting up my install media with additional wireless/ethernet packages which may be needed on some machines. A Toshiba Satellite under 12.10 had neither working wireless nor ethernet (until the first kernel upgrade), so I set up the wireless rt8723 module build and the boot-repair deb on another machine, to make the Toshiba installation easier -- Ha.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
tags: added: trusty
Sergio Benjamim (sergio-br2) wrote :

The problem remains in Trusty, but unetbootin has this problem too. I think that the package affected is wrong, usb-creator, or not?

tags: added: amd64
removed: i386 running-unity third-party-packages
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1159016

tags: added: iso-testing
Changed in usb-creator (Ubuntu):
importance: Undecided → Critical
affects: usb-creator (Ubuntu) → grub (Ubuntu)
Steve Langasek (vorlon) on 2014-01-28
affects: grub (Ubuntu) → grub2 (Ubuntu)
summary: - 12.10 64bit live-USB successfully boots, but without persistence on UEFI
- pc
+ 64 bit live-USB successfully boots, but without persistence on UEFI pc

Notified to the upstream bug tracker at <https://savannah.gnu.org/bugs/index.php?42077>.

Changed in grub2 (Ubuntu):
status: Confirmed → Triaged
Changed in grub2 (Ubuntu):
importance: Critical → High
Timo Palomaa (timppis) wrote :

There is another comment: https://savannah.gnu.org/bugs/index.php?42077#comment3

...saying this has nothing to do with upstream grub. Whose responsibility is this then!?

Phillip Susi (psusi) wrote :

USB creator needs to configure grub to pass the persistence flag, as it does with isolinux.

affects: grub2 (Ubuntu) → usb-creator (Ubuntu)
Timo Palomaa (timppis) wrote :

#5: I can confirm this happens with unetbootin too, so it is definitely not just usb-creator that fails.

Yu Ning (yuningdodo) wrote :

Here is a usb-creator patch used by myself, it will add the cmdline arguments to grub *.cfg, so they will take effect with UEFI BIOS. Would anyone like to give it a try?

Yu Ning (yuningdodo) wrote :

BTW, from my point of view it's not a grub bug since grub.cfg is not configured by usb-creator at all; and once we append the "persistent" option in grub.cfg it just works.

The attachment "mangle-grub.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
tags: added: vivid
Yu Ning (yuningdodo) wrote :

Hi, I have proposed a merge request with the patch uploaded in comment #12, could anyone help to review it? Thanks in advance.
https://code.launchpad.net/~yuningdodo/usb-creator/usb-creator.lp1159016-mangle-grub/+merge/250267

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.66

---------------
usb-creator (0.2.66) vivid; urgency=medium

  * usbcreator/install.py: adjust grub configurations, otherwise the
    persistent mode can't be enabled with UEFI BIOS. (LP: #1159016)
  * usbcreator/install.py: detect os version with regex and check for the
    result. (LP: #1208129)
  * GTK: select a source if it's already added. (LP: #978691)
  * GTK: scroll to the selected source.
 -- Yu Ning <email address hidden> Fri, 06 Mar 2015 12:39:57 -0500

Changed in usb-creator (Ubuntu Vivid):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.