url-dispatcher stops working, can't open links from scopes or apps

Bug #1483854 reported by Sergio Cazzolato on 2015-08-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Pat McGowan
url-dispatcher (Ubuntu)
Critical
Ted Gould

Bug Description

Trying to use the url dispatcher I got this error when trying to go to this url and other too:

** (process:31929): WARNING **: Unable to dispatch url 'scope://com.canonical.scopes.photos_photos':GDBus.Error:com.canonical.URLDispatcher.BadURL: URL 'scope://com.canonical.scopes.photos_photos' is not handleable by the URL Dispatcher

then in the log I found this:

** (process:2011): WARNING **: Unable to create tables: database is locked
** (process:2011): CRITICAL **: url_db_find_url: assertion 'db != NULL' failed

After all, ted suggested that restarting the url dispatcher would work and it did.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in url-dispatcher (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller) wrote :

I've just hit this with rc-proposed image 104 on arale. The net affect is you can't launch ANY urls, so just about all the apps and scopes that use url-dispatcher stop working. This is really bad. If the db is getting corrupted, we need to be able to recover without forcing a restart.

I've attached my database.

Bill Filler (bfiller) wrote :
Changed in url-dispatcher (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Ted Gould (ted)
Changed in canonical-devices-system-image:
milestone: none → ww40-2015
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → Critical
summary: - Getting assertion 'db != NULL' failed when using the url dispatcher
+ url-dispatcher stops working, can't open links from scopes or apps
Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package url-dispatcher - 0.1+16.04.20151110-0ubuntu1

---------------
url-dispatcher (0.1+16.04.20151110-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Ted Gould ]
  * Remove the cache if the service fails to start. Fail to start if we
    can't create the database. (LP: #1483854)

 -- Bill Filler <email address hidden> Tue, 10 Nov 2015 14:37:07 +0000

Changed in url-dispatcher (Ubuntu):
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments