Ubuntu

cycling through the radio devices for eeepc

Reported by Shang Wu on 2011-05-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Chris Van Hoof
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Chris Van Hoof
Raring
Undecided
Unassigned
gnome-settings-daemon
New
Medium
Debian
Fix Released
Unknown
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
Nominated for Precise by James M. Leddy
Nominated for Quantal by James M. Leddy
Nominated for Raring by James M. Leddy
linux (Ubuntu)
Medium
Keng-Yu Lin
Nominated for Precise by James M. Leddy
Nominated for Quantal by James M. Leddy
Nominated for Raring by James M. Leddy
urfkill (Ubuntu)
Medium
Keng-Yu Lin
Nominated for Precise by James M. Leddy
Nominated for Quantal by James M. Leddy
Nominated for Raring by James M. Leddy

Bug Description

On an Eee PC platform, when pressing Fn + F2 will disable Wifi and bluetooth together, pressing it again will enable both function. However, in the windows world, pressing the same key will
<Assuming both devices are ON after boot up>

(0. Both devices are ON)
1. Both devices are OFF
2. Wifi ON/ Bluetooth OFF
3. Wifi OFF/ Bluetooth ON

Then it cycle back to step 0 again.

Shang Wu (shangwu) on 2011-05-19
affects: linux → oem-priority
Changed in oem-priority:
importance: Undecided → Wishlist
status: New → Confirmed
Chris Van Hoof (vanhoof) on 2011-07-18
Changed in oem-priority:
assignee: nobody → Chris Van Hoof (vanhoof)

This bug is missing log files that will aid in dianosing the problem. From a terminal window please run:

apport-collect 785025

and then change the status of the bug back to 'New'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Chris Van Hoof (vanhoof) on 2011-07-19
Changed in linux (Ubuntu):
assignee: nobody → Chris Van Hoof (vanhoof)
Changed in oem-priority:
importance: Wishlist → Medium
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Chris Van Hoof (vanhoof) on 2011-07-26
Changed in linux (Ubuntu):
assignee: Chris Van Hoof (vanhoof) → Keng-Yü Lin (lexical)

@Shang

In the driver code there are several types of radio devices (WLan, Bluetooth, Wimax, WWan3G) to handle, do we have a specific cycling procedure for these devices?

Not all the radio devices are available on the same laptop I've seen right now, but they are in the code.

Shang Wu (shangwu) wrote :

@Keng-Yu,

If we implement them all in once, how are we going to handle if the Wimax and WWan3G device is not available? I believe for this bug's purpose, we were only concern about cycling between the WLan and Bluetooth.

Keng-Yu Lin (lexical) wrote :

I am investigating if this is more proper to be done in the userspace, like to have a daemon controlling the order of killswitch (http://www.freedesktop.org/wiki/Software/urfkill)

Changed in linux (Ubuntu):
status: Confirmed → In Progress
Keng-Yu Lin (lexical) on 2011-08-10
affects: linux → null
Changed in debian:
status: Unknown → New
Changed in null:
status: Unknown → New
Changed in debian:
status: New → Fix Committed
Changed in null:
status: New → Fix Committed
Keng-Yu Lin (lexical) on 2011-08-25
Changed in linux (Ubuntu):
status: In Progress → Triaged
Changed in debian:
status: Fix Committed → Fix Released
Changed in null:
status: Fix Committed → Fix Released
Keng-Yu Lin (lexical) wrote :

FFE to sync the ufkill package in bug 833745.

Keng-Yu Lin (lexical) wrote :

urfkill package is already sync'ed in Oneiric. So we have at least a start point to work on implementing this feature.

I keep the kernel task because it can be likely to change the keycode from KEY_WLAN to KEY_RFKILL. But this relies how it is going to be implemented in urfkill.

affects: null → urfkill (Ubuntu)
Changed in urfkill (Ubuntu):
importance: Unknown → Undecided
status: Fix Released → New
status: New → Triaged
assignee: nobody → Keng-Yü Lin (lexical)
importance: Undecided → Wishlist
Changed in linux (Ubuntu):
importance: Medium → Wishlist
Keng-Yu Lin (lexical) wrote :

the cycling toggle patch is sent upstream for review.

marked the task in Oneiric as wontfix and will focus on the current dev release (Precise).

Changed in urfkill (Ubuntu):
status: Triaged → In Progress
Keng-Yu Lin (lexical) on 2011-11-03
summary: - [eeepc_wmi] cycling through the radio devices
+ cycling through the radio devices for eeepc
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → New
Chris Van Hoof (vanhoof) on 2012-01-23
Changed in oem-priority:
status: Confirmed → Triaged
Changed in oem-priority:
status: Triaged → In Progress
James M. Leddy (jm-leddy) wrote :

Hi Keng-yu, Is urfkill making its way into precise?

Keng-Yu Lin (lexical) on 2012-05-15
Changed in linux (Ubuntu):
status: Triaged → Invalid
Keng-Yu Lin (lexical) wrote :

The package is debian too, urfkill gets sync'd in every release.

For the cyclic rfkill toggle, urfkill upstream does not think it's a good idea. Instead it is preferred to have g-s-d draw the dialog for the switching.

See https://bugzilla.gnome.org/show_bug.cgi?id=661643 and the screenshot: http://bugzilla-attachments.gnome.org/attachment.cgi?id=198921

But it is not merged in gnome.

Changed in urfkill (Ubuntu):
status: In Progress → Won't Fix
Chris Van Hoof (vanhoof) on 2012-06-25
Changed in linux (Ubuntu):
importance: Wishlist → Undecided
importance: Undecided → Medium
Changed in urfkill (Ubuntu):
importance: Wishlist → Medium
Changed in oem-priority:
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.