urfkilld crashed with SIGSEGV in input_event_cb()

Bug #1357576 reported by abma on 2014-08-15
118
This bug affects 16 people
Affects Status Importance Assigned to Milestone
urfkill (Ubuntu)
Medium
Chad Miller

Bug Description

happened after some update... no idea how/why it happens atm.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: urfkill 0.6.0~20140708.110711.a0581f3-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-8.13-generic 3.16.0
Uname: Linux 3.16.0-8-generic x86_64
ApportVersion: 2.14.5-0ubuntu4
Architecture: amd64
Date: Sat Aug 16 00:14:41 2014
ExecutablePath: /usr/lib/x86_64-linux-gnu/urfkill/urfkilld
ProcCmdline: /usr/lib/x86_64-linux-gnu/urfkill/urfkilld
ProcEnviron:
 PATH=(custom, no user)
 TERM=linux
SegvAnalysis:
 Segfault happened at: 0x7f1918959e13 <_IO_vfprintf_internal+7443>: repnz scas %es:(%rdi),%al
 PC (0x7f1918959e13) ok
 source "%es:(%rdi)" (0x00000020) not located in a known VMA region (needed readable region)!
 destination "%al" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: urfkill
StacktraceTop:
 ?? ()
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
SystemImageInfo: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden: 'system-image-cli'
Title: urfkilld crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: Upgraded to utopic on 2014-01-27 (200 days ago)
UserGroups:

abma (abma) wrote :

StacktraceTop:
 input_event_cb (source=0x7f191a097490, condition=<optimized out>, input=0x7f190c003450) at urf-input.c:86
 g_main_dispatch (context=0x7f191a070c00) at /build/buildd/glib2.0-2.41.2/./glib/gmain.c:3064
 g_main_context_dispatch (context=context@entry=0x7f191a070c00) at /build/buildd/glib2.0-2.41.2/./glib/gmain.c:3663
 g_main_context_iterate (context=0x7f191a070c00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.41.2/./glib/gmain.c:3734
 g_main_loop_run (loop=0x7f191a071070) at /build/buildd/glib2.0-2.41.2/./glib/gmain.c:3928

Changed in urfkill (Ubuntu):
importance: Undecided → Medium
summary: - urfkilld crashed with SIGSEGV in g_main_context_dispatch()
+ urfkilld crashed with SIGSEGV in input_event_cb()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in urfkill (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Chad Miller (cmiller) on 2014-08-22
information type: Private → Public
Chad Miller (cmiller) on 2014-08-22
Changed in urfkill (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package urfkill - 0.6.0~20140708.110711.a0581f3-0ubuntu3

---------------
urfkill (0.6.0~20140708.110711.a0581f3-0ubuntu3) utopic; urgency=medium

  [ Chad MILLER ]
  * debian/control: Depend on python3, because of scripts in debian/scripts/
  * debian/patches/urfkill-debug-input.patch: Too few arguments to format
    string causing SEGVs. (LP: #1357576)

  [ Mathieu Trudel-Lapierre ]
  * debian/control, debian/rules: drop hardening-wrapper; just use build flags
    from dh (but with all hardening enabled).
 -- Chad MILLER <email address hidden> Fri, 22 Aug 2014 10:19:52 -0400

Changed in urfkill (Ubuntu):
status: Confirmed → Fix Released

crash after system resume from hibernate

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers