/var/log/kern.log gets spammed with rfkill messages

Bug #1340710 reported by Mirco Müller on 2014-07-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
urfkill (Ubuntu)
Medium
Unassigned

Bug Description

As of today (updated to kernel 3.15.0-6-generic) my utopic based desktop-machine keeps disk i/o busy with writing constantly at about 1 Meg/sec and also spams /var/log/kern.log with:

...
Jul 11 14:09:43 HAL9000 kernel: [ 3790.678329] rfkill: input handler enabled
Jul 11 14:09:43 HAL9000 kernel: [ 3790.743970] rfkill: input handler disabled
Jul 11 14:09:44 HAL9000 kernel: [ 3791.476045] rfkill: input handler enabled
Jul 11 14:09:44 HAL9000 kernel: [ 3791.543424] rfkill: input handler disabled
Jul 11 14:09:44 HAL9000 kernel: [ 3792.314127] rfkill: input handler enabled
Jul 11 14:09:44 HAL9000 kernel: [ 3792.379737] rfkill: input handler disabled
Jul 11 14:09:45 HAL9000 kernel: [ 3793.171388] rfkill: input handler enabled
Jul 11 14:09:45 HAL9000 kernel: [ 3793.231092] rfkill: input handler disabled
Jul 11 14:09:46 HAL9000 kernel: [ 3794.027400] rfkill: input handler enabled
Jul 11 14:09:46 HAL9000 kernel: [ 3794.090796] rfkill: input handler disabled
Jul 11 14:09:47 HAL9000 kernel: [ 3794.855748] rfkill: input handler enabled
Jul 11 14:09:47 HAL9000 kernel: [ 3794.922930] rfkill: input handler disabled
Jul 11 14:09:48 HAL9000 kernel: [ 3795.647676] rfkill: input handler enabled
Jul 11 14:09:48 HAL9000 kernel: [ 3795.712540] rfkill: input handler disabled
Jul 11 14:09:49 HAL9000 kernel: [ 3796.502059] rfkill: input handler enabled
Jul 11 14:09:49 HAL9000 kernel: [ 3796.570120] rfkill: input handler disabled
Jul 11 14:09:49 HAL9000 kernel: [ 3797.310477] rfkill: input handler enabled
Jul 11 14:09:49 HAL9000 kernel: [ 3797.365789] rfkill: input handler disabled
Jul 11 14:09:50 HAL9000 kernel: [ 3798.214718] rfkill: input handler enabled
Jul 11 14:09:50 HAL9000 kernel: [ 3798.270505] rfkill: input handler disabled
...

Here's the ouput of iotop:

Total DISK READ : 0.00 B/s | Total DISK WRITE : 72.39 K/s
Actual DISK READ: 0.00 B/s | Actual DISK WRITE: 906.83 K/s
  TID PRIO USER DISK READ DISK WRITE SWAPIN IO> COMMAND
  330 be/3 root 0.00 B/s 0.00 B/s 0.00 % 98.36 % [jbd2/sda1-8]

Mirco Müller (macslow) wrote :

It started...

Jul 11 00:47:14 HAL9000 kernel: [ 1315.610925] rfkill: input handler disabled
Jul 11 00:47:15 HAL9000 kernel: [ 1317.065654] rfkill: input handler enabled
Jul 11 00:47:16 HAL9000 kernel: [ 1317.175074] rfkill: input handler disabled
Jul 11 00:47:17 HAL9000 kernel: [ 1318.716811] rfkill: input handler enabled

... and keeps going without interruption.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1340710/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

Could you please attach /var/log/syslog? This should include sufficient data to figure out what is the cause of the problem.

Changed in ubuntu:
status: New → Incomplete
importance: Undecided → Medium
affects: ubuntu → urfkill (Ubuntu)
Mirco Müller (macslow) wrote :
Mirco Müller (macslow) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package urfkill - 0.6.0~20140708.110711.a0581f3-0ubuntu2

---------------
urfkill (0.6.0~20140708.110711.a0581f3-0ubuntu2) utopic; urgency=medium

  * debian/patches/ignore_input_monitor_startup.patch: don't fail startup if
    the input device monitor fails to start. (LP: #1340710)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 11 Jul 2014 09:33:33 -0400

Changed in urfkill (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers