urfkill crashes on ARM devices

Bug #1218563 reported by Tony Espy on 2013-08-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
urfkill (Ubuntu)
Undecided
Unassigned

Bug Description

Work is being done to leverage urfkill for "Flight Mode" support on Ubuntu Touch ( and potentially Desktop in the future ). See the following blueprint for details:

https://blueprints.launchpad.net/ubuntu/+spec/ubuntu-touch-flight-mode

When running the current version of urfkill ( 0.4.0-4 ) on a Touch image, urfkill crashes due to the lack of a system udev "dmi" device on ARM platforms ( eg. Galaxy Nexus ). This results in a DmiInfo instance with a bunch of NULL pointers, which eventually results a subsequent segfault in the urf-config code while parsing a profile.

Tony Espy (awe) wrote :

Note, the linked branch is being used for development, and as such, has consolekit temporarily removed as a runtime dependency. This hack will go away once urfkill has been re-factored to support logind. This branch also contains two other changes:

1) urfkill-dbg package created

2) fix for nfc crash ( see bug #1218567; this bug also has steps to reproduce both bugs )

Tony Espy (awe) on 2013-09-09
Changed in urfkill (Ubuntu):
status: New → Confirmed

Oops, forgot to close this with the upload of 0.4.0-4ubuntu1.

Changed in urfkill (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers