/etc/resolv.conf: Error retrieving chunk extents: Operation not supported

Bug #969926 reported by dino99 on 2012-03-31
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ureadahead (Ubuntu)
Medium
Unassigned

Bug Description

Precise i386 b2 logged as gnome-classic

got this logged into /vat/log/upstart/ureadahead.log :

ureadahead: Unable to obtain rotationalness for device 0:15: No such file or directory
ureadahead:/etc/resolv.conf: Error retrieving chunk extents: Operation not supported

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ureadahead 0.100.0-12
ProcVersionSignature: Ubuntu 3.2.0-21.34pre201203300400-generic-pae 3.2.13
Uname: Linux 3.2.0-21-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu2
Architecture: i386
Date: Sat Mar 31 12:23:25 2012
SourcePackage: ureadahead
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

dino99 (9d9) wrote :
dino99 (9d9) on 2012-03-31
description: updated
Phillip Susi (psusi) wrote :

Is /etc part of your root fs? What fs type is that? Can you list /proc/mounts?

Changed in ureadahead (Ubuntu):
status: New → Incomplete
dino99 (9d9) wrote :

its ext4 partition and /proc/mounts is 0 byte

and this error is still existing on quantal i386 (log attached)

dino99 (9d9) wrote :

forgotten about /etc : its a genuine installation on a desktop (rights : drwxr-xr-x )

Changed in ureadahead (Ubuntu):
status: Incomplete → Confirmed
dino99 (9d9) on 2012-07-19
Changed in ureadahead (Ubuntu):
status: Confirmed → New
Phillip Susi (psusi) wrote :

can you cat /proc/mounts?

dino99 (9d9) wrote :

oem@dub:~$ cat /proc/mounts
rootfs / rootfs rw 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev devtmpfs rw,relatime,size=2056844k,nr_inodes=208325,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /run tmpfs rw,nosuid,relatime,size=826216k,mode=755 0 0
/dev/disk/by-uuid/00c5de83-479c-4ab0-9b54-9af0a727175e / ext4 rw,relatime,errors=remount-ro,data=ordered 0 0
none /sys/fs/fuse/connections fusectl rw,relatime 0 0
none /sys/kernel/debug debugfs rw,relatime 0 0
none /sys/kernel/security securityfs rw,relatime 0 0
none /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
none /run/shm tmpfs rw,nosuid,nodev,relatime 0 0
/dev/sdc3 /home ext3 rw,relatime,errors=continue,barrier=1,data=ordered 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
gvfs-fuse-daemon /home/oem/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=1000,group_id=1000 0 0

Phillip Susi (psusi) wrote :

The problem seems to be caused by the fact that /etc/resolv.conf is now a symlink to /run. 0.100.0-12 added /run to the ignore list, however, the ignore list checking appears to be done on the symlink name rather than on what it points to.

Changed in ureadahead (Ubuntu):
status: New → Triaged
dino99 (9d9) wrote :

Thanks for your #7 comment; is there a command i could test to tweak that wrong symlink ?

Phillip Susi (psusi) wrote :

The symlink isn't wrong, it is ureadahead that is wrongly following the symlink into /run, which it should stay out of.

Changed in ureadahead (Ubuntu):
importance: Undecided → Medium
dino99 (9d9) wrote :

Feedback from QQ i386

resolvconf.log:
/etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symbolic link to /run/resolvconf/resolv.conf

ureadahead.log:
ureadahead: Error while tracing: No such file or directory

Looks like ureadahead is not actively maintained (some old bugs still around)
https://launchpad.net/ubuntu/+source/ureadahead/+bugs

and wonder why such program is part of ubuntu-minimal ? while very good project like e4rat (for ext4 only) is not available from ubuntu archive.
http://sourceforge.net/projects/e4rat/files/0.2.3/

Hopes to see you make good decisions as the ureadahead + plymouth team seem badly acting while booting.

Bryan Fullerton (fehwalker) wrote :

The actual issue here is that ureadahead is storing symlinks in the pack file at all.

It has no way of knowing where those paths point when reading the pack file back off the disk on next boot, as in this case they may point to locations that are ignored by ureadahead normally.

And in any case it is capturing the targets of the symlinks in the trace, so these files are represented already, so there's no reason to store the symlink as well.

I'm working on a proposed code change to no longer include symlinks in the pack files.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ureadahead - 0.100.0-16

---------------
ureadahead (0.100.0-16) raring; urgency=low

  * src/trace.c: update to ignore symlinks when tracing + cleanup extra stat()
    (LP: #969926)
 -- Bryan Fullerton <email address hidden> Mon, 25 Mar 2013 10:09:18 +0100

Changed in ureadahead (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers