Ubuntu

boot fails [...] ureadahead [...] terminated with status 5

Reported by Olivier RIEUX-LOPEZ on 2010-03-20
112
This bug affects 23 people
Affects Status Importance Assigned to Milestone
ureadahead (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ureadahead

I upgraded to 9.10 (from 9.04). Since then cannot boot up anymore, I always receive this message (more or less):

init: ureadahead main process (2958) terminated with status 5
mountall: /proc: unable to mount: device or resource busy
mountall: /proc/self/mountinfo: no such file or directory
mountall: root file system is not mounted
init: mountall main process (2959) terminated with status 1
General error mounted file system

I then fall into the maintenance shell.
When I type "mount" I can see that proc is mounted on /proc.
And the right partition is mounted on / (but read-only).
(If I comment the proc line in /etc/fstab, nothing changes.)

I WOULD LIKE TO FIX THAT WITHOUT REINSTALLING FROM SCRATCH.

Thank you for your attention.

Hi there, thanks for the report.

status 5 usually means that you have /var mounted on a separate partition, is that true?

The mountall errors are a knock-on effect of an earlier bug that should already be fixed, did exiting from this shell fix the issue for you?

Changed in ureadahead (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium

Hi Scott,

Thank you for your assistance.

Dear Scott,

I am sorry to inform you that "/var" is a regular directory on the "/" partition.

I can't understand the question "did exiting from this shell fix the issue for you?".
I can't do anything but in the maintenance shell, that is to say I can't do much, since I have no idea of how to boot the system manually.

What test do you suggest to help your diagnosis ?
Do you want me to post some of my configuation files?

Thank you again.
Best regard.

Could you supply a copy of your /etc/fstab

Hi Scott,

Here is a zip archive (created with 7zip) with my fstab. I also included my grup configuration files just in case it might help (the menu.lst is the only system configuration file that I modified since my first installation).

I also wanted to tell you that the initial installation was 8.04 LTS (Hardy Heron), I then modified my menu.lst, and then successfully upgraded twice, and then the next upgrade failed as you know. I did modify absolutely nothing between the last successful upgrade and the failed upgrade.

Thank you for you help.
Best regard.

On Sat, 2010-04-24 at 12:55 +0000, Olivier RIEUX-LOPEZ wrote:

> Here is a zip archive (created with 7zip) with my fstab. I also included
> my grup configuration files just in case it might help (the menu.lst is
> the only system configuration file that I modified since my first
> installation).
>
Thanks.

Could you run:

  sudo ureadahead --force-trace --debug

For me? Attach any output; if after a minute or so, it hasn't
returned, press Ctrl+C to terminate it - again include any output.

Scott
--
Scott James Remnant
<email address hidden>

Tim Kornhammar (tim-kornhammar) wrote :

I tried it on Lucid.

""
$ sudo ureadahead --force-trace --debug
ureadahead: Error while tracing: Filen eller katalogen finns inte*
""
* The file or folder does not exist.

And since the help says that the root file system should be used I'm guessing something is wrong with reading/finding the root.

However, trying to set the path to / or /dev/sda or /dev/sda1 does not work either.

Hi,

I get the same answer as Tim:

"
$ sudo ureadahead --force-trace --debug
ureadahead: Error while tracing: No such file or directory
"

I then tried:
"
$ sudo ureadahead --debug
/var/lib/ureadahead/pack: no such file or directory
ureadahead: Error while tracing: No such file or directory
"

And then:
"
$ ls /var/lib/ureadahead
debugfs
"

What else can I try?

Thank you.
regards

bwat47 (bwat47) wrote :

I am suddenly getting this too. Lucid 64 bit. No /var separate partition, this happened out of the blue, I have all the same problems as the post above me.

bwat47 (bwat47) wrote :

Well actually I forgot to add, my boot does not fail though, it keeps going and I can login and everything.

damu (damu) wrote :

I too get the same message after upgrading from 8.04LTS to 10.04LTS 2 days before.
kindly suggest a solution.

vanuch (goncharov-i-v) wrote :

hello.
i have the same bug. /var is a directories on / , not another partition.
i try run:
           sudo ureadahead --force-trace --debug
was only one string:
         trace: Missing uselib tracing: Нет такого файла или каталога
"Нет такого файла или каталога" it is translate like "file or catalog is absent".
i waiting ~20 min and after this press ctrt+c, ater this were started printed log to console (~37494 strings). see in attach.
before it i make the same but press ctrl+c and log was only 100-200 strings.
after this i chk /var/lib/ureadahead/:

drwxr-xr-x 2 root root 48 2009-11-10 11:33 debugfs
-rw------- 1 root root 42376 2010-05-06 21:18 home.pack
-rw------- 1 root root 1004 2010-05-06 21:18 media.data.pack
-rw------- 1 root root 3116 2010-05-06 21:18 media.video.pack
-rw------- 1 root root 404980 2010-05-06 21:18 pack

i hope this info help You fix bug.

damu (damu) wrote :

The message I am getting on boot failure is the following, when I upgraded from 8.04 to 10.04

init:ureadahead main process(2750) termintaed with status 5
libudv: udev mount for_new_from_netlink: error getting socket : Invalid argument new_from_netlink (udev, "udev")
init: mountall main process main process(2753)killed by ABRT signal
General error mounting file systems.
A maintenance shell will be started.

I could run some softwares installed with an error that is related to "xwindows not working".

Jason (jason-goodtimes) wrote :

Hi,

I had the exact same problem, upgraded from 8.04LTS to 10.04LTS and then got the ureadahead errors.
I resolved the problem by editing /boot/grub/menu.lst and changing my kernel to the one supplied with Lucid

root (hd0,0)
kernel /vmlinuz-2.6.32-22-generic root=/dev/md2 ro quiet splash
initrd /initrd.img-2.6.32-22-generic

Obviously you will need to adjust the above to your environment.

Regards,
Jason

vanuch (goncharov-i-v) wrote :

hello.
I fix my problem.
For the first, i find to installed to packet like *readahead. there was: sreadahead (as i anderstood it for SSD disk) and ureadahead.
So i purge sreadahead.
After this i did:
aptitude reinstall ureadahead

After reboot files *.pack in dir /var/lib/ureadahead/ were created.
I did not know what same help prurge sreadahead or reinstall ureadahead because did this in one time, without reboot between action.

Hope it ishelp U.

Thorsten Hirsch (t-hirsch) wrote :

aptitude reinstall ureadahead

...solved the problem for me. No seperate /var partition, no manual additions in /etc/fstab. Initial installation was Ubuntu 9.10 and the error message (due to the missing pack file) appeared after upgrading to 10.04.

Weird. Reinstalling ureadahead certainly does fix it.

Mugsy323 (ambrosia-1) wrote :

I am receiving a similar error (number in parentheses is different), also reporting "ureadahead" "terminated" and "status 5", at which point, the boot process halts. This is Ubuntu 10.04.

When my Ubu partition is launched, a briefly catch glimpse of the words "file not found" just as the drive is booted.

Same when trying to use the Ubuntu "generic safe mode" from the Grub menu. Ubu just refuses to run.

I can't load Ubu at all. I can access the drive/files by booting from a LiveCD, but that's it. Prior to this, I was searching for some decent Backup software, but nothing I found was any good. It is *possible* one of these programs changed something that is now preventing Ubu from loading.

It is a pain that there isn't an automated "repair" tool like there is for Windows. :(

Can anyone help? I don't want to have to reformat.

damu (damu) wrote :

Hi Jason,
I tried to edit the /boot/grub/menu.lst file but I cudnt save anything because it was opened as read-only file even if the user is root.
How to fix the problem?

John Prostka (japros) wrote :

Hi,

I've been having the same or similar problems at startup since upgrading to kernel 2.6.32-23 Server #37 Ubuntu SMP, x86_64, where my system is reachable via ssh but at my locale console I never get the login prompt. No key combinations like Control-F2 etc ever gets me anywhere. Ctrl-Alt-Del however starts the shutdown routine and the cycle repeats.

I recently, 11 JUL 10, sent an email to Scott Remnant in which I outlined my workaround to add a line to "/etc/init/ureadahead.conf" at the very end of this file which calls "exec /sbin/inctl start rc-sysinit". After rebooting, I was able to get my local server console login screen and everything operated fine ever since.
I did check my /var/log/boot.log and did see some services that were logging their objections to boot.log but only the one time did I see this. Subsequent reboots only logged a normal output in "boot.log".

I expressed to Scott in my email that I believe that "upstart" was causing the console output about ureadahead and that therein the problem lies and not with ureadahead. I hope this helps anyone who has been trying to get a login screen on their server as it worked for me.

If anyone needs further clarification please post.

I know that this is a kludge and Scott wants to get to the bottom of this anomaly. Oh, by the way, I did try the kernel line patch in grub but it didn't work.

Cheers!

damu (damu) wrote :

I did not understand the way to solve th e problem. I hav eno option to login from any other system as dont have LAN at my work place. when I boot in UBUNTU, it is asking for the root password and Xwindows dont work. I can not also edit any files, including GRUB file. Please tell me in detail on how to solve the problem.

Hi

Damu said:
"I did not understand the way to solve th e problem. I hav eno option to login from any other system as dont have LAN at my work place.[...] I can not also edit any files, including GRUB file"

The only way I found to edit files in my failing ubuntu installation is to use ubuntu from a live cd and manually mount the partition where my files of interest are.

Best regards.

Hi all,

I am also having the "status 5" error, and I do have /var mounted on a separate partition. The system boots fine, and after booting the /var/lib/ureadahead folder is empty. I have just found a fix suggested by sentinella86 on the ubuntu forums (http://www.uluga.ubuntuforums.org/showthread.php?p=9555086):

 sudo sed -i 's+^start on starting mountall+start on mounted MOUNTPOINT=/var+' /etc/init/ureadahead.conf

I tried it, and the "status 5" error disappeared. I can now see the following files in the /var/lib/ureadahead folder: pack, tmp.pack, usr.pack, and var.pack. The only thing is that during booting I noticed some parallel and green lines on the top of the screen, and one or two sort of quick screen flashes. What do you think about this workaround? ¿Can it be used safely?

Many thanks for your help.
nosco

loganleigh (noble-ms) wrote :

I just did a fresh installation of Ubuntu 10.04 LTS on a Dell Inspiron 6400 and from the very first boot after installation I began receiving this error:

I am getting "ureadahead main process (319) terminated with status 5" or sometimes "ureadahead main process (329) terminated with status 5" during boot. Sometimes the boot fails but sometimes it completes successfully.

I /do/ have my /var directory in a separate partition. I've done some googleing and see that separating my /var away from my / partition seems to be the cause of my problem, but I don't see any reasonable good solutions.

Does the solution nosco propose in Comment #23 above seem reasonable? (namely, sudo sed -i 's+^start on starting mountall+start on mounted MOUNTPOINT=/var+' /etc/init/ureadahead.conf)

I was playing around with removing the pack files and disabling the ureadahead.conf file and I discovered that I have NO pack files in /var/lib/ureadahead/pack. Perhaps this is the source of the problem?

Just hoping to include more clues that might help give a reasonable resolution to folks getting this error.

aptitude reinstall ureadahead, did not solve the problem.

Fresh Kubuntu Netbook 10.4 install on Asus eeepc 1000h, no separate /var partition, no manual additions in /etc/fstab, but separate /home...

Used the fix proposed in comment #23, message is gone, but still can't see any files in the /var/lib/ureadahead folder.

danrgmc (danrgmc-yahoo) wrote :

To: Nosco-post #23
    Kudos to you-this worked for me.
I just installed the latest stable kernel: 2.6.35 using method described by 'Master Kernel Thread' No errors-everything seemed to work except VLC. After reinstalling VLC I received 'status 5' message; bootup continuing after brief pause. After running your script bootup is normal. Thank you

Vladimir Hidalgo (vlad88sv) wrote :

I think that +bug/432360 is duplicate of this bug, even through title says sreadahead, it diverges to ureadahead and exit status 5.

hedgehog (hedgehogshiatus) wrote :

This very simple fix worked for me:

[URL="http://ubuntuforums.org/showpost.php?p=9555086&postcount=9"][B]sentinella86[/B][/URL]

HTH?

This very simple fix worked for me as well:

[URL="http://ubuntuforums.org/showpost.php?p=9555086&postcount=9"][B]sentinella86[/B][/URL]

i am using /var on its own partition, as well as /home on its own partition etc... (all in RAID 1)
so the problem seemd to be in /var.

gohai (gottfried-haider) wrote :

I am not sure if this exactly the same bug as before, but I can't get ureadahead to trace here on an up-to-date xubuntu 11.04 beta.

Reinstalling ureadahead does not help.

When I run "sudo ureadahead --force-trace --debug", I get the following output:
ureadahead: Error while tracing: No such file or directory

Running "sudo strace ureadahead --force-trace --debug" yields:
openat(3, "events/fs/do_sys_open/enable", O_RDWR) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale-langpack/en_US/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale-langpack/en/LC_MESSAGES/libc.mo", O_RDONLY) = -1 ENOENT (No such file or directory)
close(3) = 0
write(2, "ureadahead: Error while tracing:"..., 59ureadahead: Error while tracing: No such file or directory
) = 59
exit_group(5) = ?

gohai (gottfried-haider) wrote :

Sorry, my fault: I didn't know ureadahead does not work on vanilla kernels. Please disregard the previous comment.

I just upgraded from 9.10 to 10.04 with a separate /var partition and afterwards I too was getting a "ureadahead main process (xxx) terminated with status 5" message along with having no pack files in /var/lib/ureadahead. The system boots normally otherwise however. It seems that if /var is separate then the fix called for is changing "start on starting mountall" to "start on mounted MOUNTPOINT=/var" in /etc/init/ureadahead.conf (as in comment #23; if /var is not separate then the fix apparently called for is to reinstall ureadahead). This did indeed eliminate the message in my case and pack files are now being created. But if I read the comments here and under bug 432360 correctly then the message was just a warning that ureadahead could not read the pack files from /var because /var wasn't mounted yet and so boot performance could not be improved. Telling ureadahead to start only once /var is mounted eliminates the message but defeats the purpose of ureadahead (faster booting).

Launchpad Janitor (janitor) wrote :

[Expired for ureadahead (Ubuntu) because there has been no activity for 60 days.]

Changed in ureadahead (Ubuntu):
status: Incomplete → Expired
Nicola (nicola) wrote :

same problem in oneiric with /var in a separate partition

Network Janitor (t-janitor) wrote :

Just a "ping" on this issue: same error on a fresh install of 10.04 LTS. /var is a separate partition on my system - haven't made any countermeasures aside from reinstalling ureadahead which, notably, had no affect. As the system still boots, I likely will not change its start point and bear with until the next Ubuntu release where, I hope, this issue is resolved...

Dave Lehman (dslehman) on 2012-03-23
Changed in ureadahead (Ubuntu):
status: Expired → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers