package ureadahead 0.100.0-16 failed to install/upgrade: triggers looping, abandoned

Bug #1394893 reported by David Henningsson on 2014-11-21
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
dpkg (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
ureadahead (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Iain Lane
Utopic
Undecided
Iain Lane

Bug Description

Happend on today's "sudo apt-get dist-upgrade"

ProblemType: Package
DistroRelease: Ubuntu 15.04
Package: ureadahead 0.100.0-16
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
Date: Fri Nov 21 09:17:23 2014
DuplicateSignature: package:ureadahead:0.100.0-16:triggers looping, abandoned
ErrorMessage: triggers looping, abandoned
InstallationDate: Installed on 2014-11-03 (17 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141103)
SourcePackage: ureadahead
Title: package ureadahead 0.100.0-16 failed to install/upgrade: triggers looping, abandoned
UpgradeStatus: No upgrade log present (probably fresh install)

David Henningsson (diwic) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ureadahead (Ubuntu):
status: New → Confirmed
jerrylamos (jerrylamos) wrote :

This pc is at
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.04
DISTRIB_CODENAME=vivid
DISTRIB_DESCRIPTION="Ubuntu Vivid Vervet (development branch)"
Linux Aspire1 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
model name : Intel(R) Atom(TM) CPU N455 @ 1.66GHz
model name : Intel(R) Atom(TM) CPU N455 @ 1.66GHz
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller

did apt-get update, apt-get dist-upgrade and got this bug. 20141121.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ureadahead - 0.100.0-17

---------------
ureadahead (0.100.0-17) vivid; urgency=medium

  * Switch trigger directives to interest-noawait, to avoid trigger cycles
    which can cause dpkg to bail out. (LP: #1394893)
 -- Iain Lane <email address hidden> Fri, 21 Nov 2014 12:13:21 +0000

Changed in ureadahead (Ubuntu):
status: Confirmed → Fix Released
Lazaro Alejo (habanany) wrote :

crashed while upgrading system

Iain Lane (laney) wrote :

This can happen in dist-upgrades, depending on the configure/trigger order that's used. I think we should SRU this fix to 14.04/14.10. But double check that dpkg in those versions supports the interest-noawait variants first.

Assign back to me if nobody takes this before 2014-12-05.

Changed in ureadahead (Ubuntu Trusty):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in ureadahead (Ubuntu Utopic):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Iain Lane (laney) on 2014-12-08
Changed in ureadahead (Ubuntu Trusty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Iain Lane (laney)
Changed in ureadahead (Ubuntu Utopic):
assignee: Canonical Desktop Team (canonical-desktop-team) → Iain Lane (laney)
Iain Lane (laney) wrote :

Looks like it's probably better to add a Breaks from dpkg, like in 1.7.22 in Debian:

    * Add Breaks on old man-db, fontconfig and readahead-fedora packages using
      awaiting triggers, as they produce trigger cycles. Closes: #768599

instead of SRUing.

Changed in ureadahead (Ubuntu Trusty):
status: New → Invalid
Changed in ureadahead (Ubuntu Utopic):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dpkg (Ubuntu Trusty):
status: New → Confirmed
Changed in dpkg (Ubuntu Utopic):
status: New → Confirmed
Changed in dpkg (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2014-12-08
Changed in dpkg (Ubuntu Trusty):
status: Confirmed → Invalid
Changed in dpkg (Ubuntu Utopic):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dpkg - 1.17.21ubuntu2

---------------
dpkg (1.17.21ubuntu2) vivid; urgency=medium

  * Cherry-pick from Debian (LP: #1394893)
    + Add Breaks on old man-db, fontconfig and readahead-fedora packages using
      awaiting triggers, as they produce trigger cycles. Closes: #768599
  * Modify the above to specify the version of fontconfig that included this
    change in Ubuntu, and to add ureadahead.
 -- Iain Lane <email address hidden> Mon, 08 Dec 2014 12:09:15 +0000

Changed in dpkg (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers