crashes on Ubuntu Touch due to /var/lib/ureadahead/ being read-only

Bug #1233281 reported by James Hunt on 2013-09-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lxc-android-config (Ubuntu)
High
Oliver Grawert
ureadahead (Ubuntu)
High
Unassigned

Bug Description

# tail /var/log/upstart/ureadahead.log
ureadahead:.: Ignored relative path
ureadahead:.: Ignored relative path
ureadahead:.: Ignored relative path
ureadahead:NetworkManager: Ignored relative path
ureadahead:NetworkManager: Ignored relative path
ureadahead:NetworkManager: Ignored relative path
ureadahead:tracing_on: Ignored relative path
ureadahead:events/fs/open_exec/enable: Ignored relative path
ureadahead:events/fs/do_sys_open/enable: Ignored relative path
ureadahead:pack.c:388: Unhandled error from write_pack: Read-only file system

Although write_pack() is failing due to EROFS, trace() (which calls write_pack()) does not check for any raised errors, hence the crash.

Changed in ureadahead (Ubuntu):
importance: Undecided → High
Oliver Grawert (ogra) on 2013-10-04
Changed in lxc-android-config (Ubuntu):
importance: Undecided → High
assignee: nobody → Oliver Grawert (ogra)
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxc-android-config - 0.107

---------------
lxc-android-config (0.107) saucy; urgency=low

  * make /var/lib/ureadahead writable (LP: #1233281)
 -- Oliver Grawert <email address hidden> Fri, 04 Oct 2013 11:58:51 +0200

Changed in lxc-android-config (Ubuntu):
status: Confirmed → Fix Released
Oliver Grawert (ogra) wrote :

hmm, that leaves us with a bit of a catch22, ureadahead expects /var/lib/ureadahead/debugfs to be available ... by making /var/lib/ureadahead writable, the formerly mounted /var/lib/ureadahead/debugfs gets hidden by the rw mount ...

i can work around this by adding a pre-start script to the ureadahead upstart job that mounts /var/lib/ureadahead/debugfs before firing up ureadahead, but i wonder if there is a way to have system-image do the right thing instead

Stéphane Graber (stgraber) wrote :

I'd suggest we just get ureadhead to use debugfs from the right location: /sys/kernel/debug

Stéphane Graber (stgraber) wrote :

Note that the situation ogra describes above is actually handled usually by making a writable-path entry that's (persistent + transition), the only reason it doesn't appear to work here is because /var/lib/ureadahead/debugfs isn't mounted by mountall so the mount point resolution doesn't happen...

Barry Warsaw (barry) on 2013-11-13
no longer affects: system-image (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ureadahead (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers