/var/log/upstart/ureadahead.log contains garbage

Bug #1085766 reported by Dave Gilbert on 2012-12-03
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
ureadahead (Ubuntu)
High
Andy Whitcroft

Bug Description

After an upgrade to Raring (as of today) from Quantal I'm seeing tons of these in /var/log/upstart/ureadahead.log:

Counted 8 CPUs

ureadahead: ��&����a��w: Ignored relative path
ureadahead: : Ignored relative path
ureadahead: �=%���n�T9: Ignored relative path
ureadahead: �=%����v9T9: Ignored relative path
ureadahead: �=%���U�Ek�: Ignored relative path
ureadahead: �=%���`�a: Ignored relative path

(the boot was wonderfully fast - not sure if that's because ureadahead was working well or if it's because it didn't do anything).

Dave

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ureadahead 0.100.0-12build1
ProcVersionSignature: Ubuntu 3.7.0-4.12-generic 3.7.0-rc7
Uname: Linux 3.7.0-4-generic x86_64
ApportVersion: 2.6.3-0ubuntu2
Architecture: amd64
Date: Mon Dec 3 02:06:14 2012
InstallationDate: Installed on 2012-07-17 (138 days ago)
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120717)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: ureadahead
UpgradeStatus: Upgraded to raring on 2012-12-02 (0 days ago)

Dave Gilbert (ubuntu-treblig) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ureadahead (Ubuntu):
status: New → Confirmed

Same here, although the boot seems a lot slower than quantal was.

James Hunt (jamesodhunt) wrote :

ureadahead itself hasn't changed in any significant way for a long time now, so this is looking like a possible kernel issue.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1085766

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.8 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc2-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

After testing the mainline kernel, we can perform a kernel bisect to try and identify the commit that introduced this regression.

tags: added: needs-bisect
James Hunt (jamesodhunt) wrote :

Problem is seen on i386 and amd64, but NOT on armhf (panda ARMv7).

James Hunt (jamesodhunt) wrote :

I tried this using ...

linux-headers-3.8.0-999_3.8.0-999.201301110405_all.deb
linux-headers-3.8.0-999-generic_3.8.0-999.201301110405_i386.deb
linux-image-3.8.0-999-generic_3.8.0-999.201301110405_i386.deb
linux-image-extra-3.8.0-999-generic_3.8.0-999.201301110405_i386.deb

... however, removing the pack file and rebooting resulted in the following in /var/log/upstart/ureadahead.log:

Counted 1 CPUs

ureadahead: Error while tracing: No such file or directory

This seems to be because the mainline kernel does not enable /sys/kernel/debug/tracing/events/fs/*.

James Hunt (jamesodhunt) wrote :

Looking more closely at my /var/log/upstart/ureadahead.log, this looks like memory corruption:

ureadahead:^P^P_í,<8b><97>¿add): Ignored relative path
ureadahead:^P^P_í,<8b><97>¿irqd: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿er/0: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿er/0: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿er/u: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿er/u: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿tion: Ignored relative path
ureadahead: ^P^P_í,<8b><97>¿h) S: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿sche: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿hdog: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿hdog: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿tirq: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿atio: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿ker: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿ker: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿hdog: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿tirq: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿atio: Ignored relative path
ureadahead:^P^P_í,<8b><97>¿ker: Ignored relative path

If you squint you can make out what appear to be partial kernel thread names:

hdog => watchdog/...
tirq => ksoftirqd/...
atio => migration/...

etc.

Andy Whitcroft (apw) wrote :

There are two issues. ureadahead is using a deprecated and now removed interface to ftrace to enable tracing. The kernel interface for open has changed the type of the filename, producing junk for filenames.

Changed in ureadahead (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → High
Changed in linux (Ubuntu):
importance: Medium → High
status: Incomplete → In Progress
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) on 2013-01-11
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ureadahead - 0.100.0-13

---------------
ureadahead (0.100.0-13) raring; urgency=low

  * src/trace.c: tracing_enabled is deprecated and gone, switch to tracing_on
    (LP: #1085766).
 -- Andy Whitcroft <email address hidden> Fri, 11 Jan 2013 12:05:17 +0000

Changed in ureadahead (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.8.0-0.3

---------------
linux (3.8.0-0.3) raring; urgency=low

  [ Andy Whitcroft ]

  * Revert "SAUCE: (no-up) trace: add trace events for open(), exec() and
    uselib()"

  [ Scott James Remnant ]

  * SAUCE: (no-up) trace: add trace events for open(), exec() and uselib()
    (for v3.7+)
    - LP: #1085766, #462111
 -- Andy Whitcroft <email address hidden> Fri, 11 Jan 2013 16:57:27 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
gianluca.pettinello (g-pet) wrote :

Please could you submit a patch to kernel 3.7.2 so that people like me, that like to compile vanilla kernel, can enable ureadahead tracing?
Thanks
Gianluca

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

same problem in 15.04 again

Ryan Solomon (phizes) wrote :

And the same problem in Kubuntu 15.10, I think the fix may be the same.

Jason Gerard DeRose (jderose) wrote :

This problem seems to exist currently on both 15.10 and Xenial

xb5i7o (xb5i7o) wrote :

I can confirm i am having the same issue on Xenial, my syslog gets flooded with millions of ureadahead messages, i restarted and i havent seen it happen as yet again. This usually happens when you start up the PC.

What is ureadahead??

I have this too with Xenial. Looking at yesterday's syslog:

$ sudo grep -c "Ignored relative path" /var/log/syslog.1
19728

and here are the first few lines:

$ sudo grep -m30 ureadahead /var/log/syslog.1
Oct 6 08:00:20 dl1 systemd[1]: Stopped Stop ureadahead data collection 45s after completed startup.
Oct 6 08:01:02 dl1 systemd[1]: Started Stop ureadahead data collection 45s after completed startup.
Oct 6 08:01:47 dl1 systemd[1]: Starting Stop ureadahead data collection...
Oct 6 08:01:47 dl1 systemd[1]: Started Stop ureadahead data collection.
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:events/fs/open_exec/enable: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:buffer_size_kb: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:tracing_on: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:binfmt_misc: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:size: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:start: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:size: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:start: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:size: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:start: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:size: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:start: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:size: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:start: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:dm/uuid: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: message repeated 11 times: [ ureadahead:dm/uuid: Ignored relative path]
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:.: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:1/stat: Ignored relative path
Oct 6 08:01:47 dl1 ureadahead[222]: ureadahead:1/cmdline: Ignored relative path

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers