UPX doesnt support LZMA compression

Bug #625158 reported by Pali on 2010-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upx-ucl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: upx-ucl

I'm trying use upx to compress win32/pe file with params:

upx -9 --brute --ultra-brute file.exe

But upx crashed and show me error:

upx: packer_c.cpp:43: static bool Packer::isValidCompressionMethod(int): Assertion `0 && "Internal error - LZMA not compiled in"' failed.

So problem is that ubuntu binary upx is not compiled with LZMA. It is possible to enable LZMA support for upx?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upx-ucl - 3.08-2ubuntu1

---------------
upx-ucl (3.08-2ubuntu1) precise; urgency=low

  * Merge from Debian testing. (LP: #928768) Remaining changes:
    - [arm] needs porting to thumb2; use -marm as the code
      does a lot of low level hacking not yet ready for thumb2

upx-ucl (3.08-2) unstable; urgency=low

  * Upload to unstable.
  * LZMA compression is now supported (LP: #625158).

upx-ucl (3.08-1) experimental; urgency=low

  * New upstream version 3.08.
  * Switch to tiny rules format and debhelper v9.
  * Rename & refresh patches with gbp-pq import/export.
  * Add VCS fields.

upx-ucl (3.07-4) experimental; urgency=low

  * Compile with the latest version of lzma-dev (closes: #452817):
    + add 02_lzma.patch for minor changes required to accomplish the above;
    + introduce build dependency on lzma-dev (>= 9.22).
  * 03_typos.patch, debian/doc-base: Fix typos found by lintian.
  * Remove leading article from package's description (lintian).
  * Bump Standards-Version to 3.9.2 (no changes required).
 -- Paolo Sammicheli <email address hidden> Thu, 19 Jan 2012 07:47:12 +0000

Changed in upx-ucl (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers