Ubuntu

initctl crashed with SIGABRT in nih_error_clear()

Reported by Chuck McKinnis on 2012-04-18
96
This bug affects 12 people
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Medium
James Hunt
Precise
Medium
James Hunt
Quantal
Undecided
Unassigned

Bug Description

12.04b2

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: upstart 1.5-0ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic i686
ApportVersion: 2.0.1-0ubuntu4
Architecture: i386
Date: Tue Apr 17 16:26:22 2012
ExecutablePath: /sbin/initctl
InstallationMedia: Ubuntu 10.04.4 LTS "Lucid Lynx" - Release i386 (20120214.2)
ProcCmdline: initctl show-config -e gdm
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: upstart
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libnih.so.1
 nih_error_pop_context () from /lib/i386-linux-gnu/libnih.so.1
 ?? ()
Title: initctl crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2012-04-18 (0 days ago)
UserGroups:

Related branches

Chuck McKinnis (chuck-mckinnis) wrote :

StacktraceTop:
 nih_error_clear () at error.c:300
 nih_error_clear () at error.c:288
 nih_error_pop_context () at error.c:417
 job_class_com_ubuntu_Upstart0_6_Job_start_on_get_notify (pending_call=0x22144dc8, pending_data=0x22145078) at com.ubuntu.Upstart.Job.c:3712
 ?? ()

Changed in upstart (Ubuntu):
importance: Undecided → Medium
summary: - initctl crashed with SIGABRT in raise()
+ initctl crashed with SIGABRT in nih_error_clear()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu):
status: New → Confirmed
James Hunt (jamesodhunt) wrote :

Hi Chuck - thanks for reporting this. Please could you comment on what happens when you run 'initctl show-config gdm' (no '-e'). Also, please attach your /etc/init/gdm.conf.

I am just in the process of replacing Ubuntu with Fedora (If I wanted
Windows, I would install it).

The error occurred just after the first boot of the newly installed
system. I logged in as root and ran initctl show-config gdm. Result =
"command not found".

/etc/init/gdm.conf does not exist (might be part of the problem).

On 4/18/2012 8:58 AM, James Hunt wrote:
> Hi Chuck - thanks for reporting this. Please could you comment on what
> happens when you run 'initctl show-config gdm' (no '-e'). Also, please
> attach your /etc/init/gdm.conf.
>

--
Chuck McKinnis
Consultant, Serenity Systems International
New Mexico Location Manager, Sirius Computer Solutions (retired)
Covenant Solutions
IBM Senior Systems Specialist (retired)
505-286-3191
Time's fun when you're having flies.......Kermit the Frog

James Hunt (jamesodhunt) wrote :

Please could those affected by this bug comment on what happens when they run the following commands:

sudo /sbin/initctl show-config -e gdm
sudo /sbin/initctl show-config gdm
sudo /sbin/initctl show-config
sudo /sbin/initctl show-config -e

Also, it would be helpful to know if the problem is only seen on upgrade or fresh install. Since 'initctl show-config' handles the scenario where the job does not exist, I wonder if this signifies an upgrade probem with nih/eglibc. The following might provide a clue:

    sudo apt-get --no-act check && echo ok || echo bad

James Hunt (jamesodhunt) wrote :

At this stage, we believe the problem here is related to lucid upgrades where the new (precise) initctl is talking to the old (lucid) version of init as the upgrade proceeds. See bug 985755.

James Hunt (jamesodhunt) on 2012-04-20
Changed in upstart (Ubuntu):
assignee: nobody → James Hunt (jamesodhunt)
James Hunt (jamesodhunt) on 2012-04-20
Changed in upstart (Ubuntu):
status: Confirmed → In Progress
Steve Langasek (vorlon) on 2012-04-25
visibility: private → public

Hello Chuck, or anyone else affected,

Accepted upstart into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in upstart (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upstart (Ubuntu Quantal):
status: New → Confirmed
Rich McAllister (rfm) wrote :

I had what appears to be a variant of this problem on a machine upgraded from Lucid; selecting logoff/restart from the unity bar resulted in no restart, and after manual restart an initctl crash was reported. Installing the proposed change seems to have fixed it, thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.5-0ubuntu7

---------------
upstart (1.5-0ubuntu7) precise-proposed; urgency=low

  * Correct a build failure from the previous upload.

upstart (1.5-0ubuntu6) precise-proposed; urgency=low

  * debian/upstart.logrotate: don't create empty files after rotation;
    upstart will automatically create new log files for jobs as needed.
  * init/main.c: restore the fix for bug #540256; we know the console setup
    is taken care of by plymouth in Ubuntu, so upstart changing the console
    settings just makes trouble (such as turning echo back on when it
    shouldn't be). LP: #876626.

  [ James Hunt ]
  * debian/upstart-job: Only attempt to handle disabled jobs if the running
    version of Upstart supports such a query (LP: #985755, #984474).
  * debian/manpages/upstart-events.7: Fixed typo and corrected reference to
    'kill signal' stanza.
 -- Steve Langasek <email address hidden> Thu, 26 Apr 2012 07:48:17 -0700

Changed in upstart (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in upstart (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers