Feature Freeze Exception request for Upstart in Precise

Bug #962124 reported by James Hunt on 2012-03-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Wishlist
Unassigned

Bug Description

I have just made an upstream Upstart release (1.5) and wish to get this added to Precise.

= Rationale =

== Bug Fixes ==

Upstart 1.5 includes fixes for two important bugs seen in Ubuntu:

* bug 936667
* bug 940290

== New Features ==

=== Usage stanza ===

Upstart 1.5 also includes a new "usage" feature, developed by Redhat.

I believe adding this new feature is low-risk but does introduce a new initctl command ("initctl usage <job>") and a new job stanza ("usage <string>").

CONTINGENCY: There are currently no users of this feature as it is new, however if this feature proved problematic, The usage stanzas could simply be commented out of the relevant /etc/init/*.conf files.

== Code Changes ==

Facilities relating to the early job logging code -- which is already in the Ubuntu version of Upstart -- has been renamed. The early job logging facility ensures that jobs which *end* before the disk becomes writeable are cached until Upstart is notified of writeable disks by calling a new initctl command. When the feature was first introduced into Ubuntu, that command was called "flush-early-job-log", but now that the code is in Upstream Upstart, it has been renamed to the more descriptive
"notify-disk-writeable".

Related branches

James Hunt (jamesodhunt) wrote :

It's worth pointing out that there is interest in seeing bug 936667 fixed from server folk. Also, users are starting to build kernels without initramfs support (particularly on ARM?) so it would be very beneficial to see this included in Precise.

Steve Langasek (vorlon) on 2012-03-22
Changed in upstart (Ubuntu):
importance: Undecided → Wishlist
Steve Langasek (vorlon) wrote :

I've reviewed this code and agree that the new features here are low-impact, and that the bugfixes are important to have for precise. Provided this stands up in pre-upload testing (currently ongoing), I'm +1 on this FFe, but I'd appreciate having someone else approve it since I'm not sure I'm sufficiently arms-length to be objective.

Martin Pitt (pitti) wrote :

This looks appropriate and safe enough at this point, +1 from me too.

Changed in upstart (Ubuntu):
status: New → Triaged
Steve Langasek (vorlon) wrote :

Thanks, Martin. James, I've merged your branch onto lp:ubuntu/upstart and tacked on a few changelog fixes (documenting bug numbers). Once you're satisfied with the regression testing, we can get this uploaded.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.5-0ubuntu1

---------------
upstart (1.5-0ubuntu1) precise; urgency=low

  * FFe. LP: #962124.
  * New upstream 1.5 release.
    - fix boot failure when /dev/pts is not mounted before upstart starts.
      LP: #936667.
    - fix a file descriptor leak on job restarts. LP: #940290.
  * debian/conf/failsafe.conf: Added missing "emits" which breaks
    'initctl check-config'.
  * debian/manpages/upstart-events.7: Added 'failsafe-boot' and
    'recovery' events.
 -- James Hunt <email address hidden> Thu, 22 Mar 2012 13:50:31 +0000

Changed in upstart (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers