Can't access to TTY- init /etc/event.id/tty1:16: Unknown stanza

Bug #95210 reported by Flapane on 2007-03-23
70
Affects Status Importance Assigned to Milestone
upstart (Ubuntu)
Undecided
Unassigned

Bug Description

I get this, even if the boot goes well, but I can't access to tty (eg alt ctrl f1), and I need tty...
the system is fully upgraded.

init /etc/event.d/tty1:16: Unknown stanza
init /etc/event.d/tty2:16: Unknown stanza

up to tty6

Feisty amd64 fully upgraded

Jan Nekvasil (jan-nekvasil) wrote :

I can confirm this on i386 beta live CD. This bug is actually the only thing that holds me back from installation on hardisk.

Flapane (flapane) on 2007-03-24
description: updated

Confirmed on Feisty i386 desktop beta.
Due to bug #62002, i need access to tty.

pinzia (pinzia) wrote :

Possible solution
In Live dpkg --configure -a

Flapane (flapane) wrote :

thanks but already tried

The files /etc/event.d/ttyX (from package system-services) are different than my current edgy installation.

Fesity Beta i386 desktop CD version:

respawn
exec /sbin/getty 38400 tty1

My currently installed Edgy version:

respawn /sbin/getty 38400 tty1

Flapane (flapane) wrote :

https://launchpad.net/ubuntu/+source/casper/+bug/92928 says that the problem has been fixed, but I have still the problem here...

Flapane (flapane) wrote :

my tty files were corrupted.
Solved by changing them with
respawn
exec /sbin/getty 38400 tty1 [up to ... 6]

Tyrus (simon-inf) wrote :

same probleme here with beta fully updated.
Solved with exec /sbin/getty 38400 tty1 also.

Flapane (flapane) wrote :

could you post your corrupted file?
I unfortunately deleted it, and it would be useful for developers to understand the issue

Jeff Fortin Tam (kiddo) wrote :

hi. I have just experienced this bug. The end of my corrupt files look like this:
/sbin/getty 38400 tty2exec /sbin/getty 38400 tty2

It should be:
exec /sbin/getty 38400 tty2

notice how it is actually the same line but it got duplicated two times one after another. Wtf?
Also, my login prompt now appears in the middle of my boot process with an [OK] besides it, so it doesn't let me login since there are other processes starting after that. When everything is done, I can do ctrl-C twice to get another login prompt. Anyone knows why? How can I make it appear last?

Jeff Fortin Tam (kiddo) wrote :

no actually, I need to do ctrl-D to get my login prompt on tty1

komputika (info-komputika) wrote :

using "apt-get install system-services" actually fixed this issue for me.
I don't know if that package was already installed before upgrading, but it wasn't after the upgrade.

I can confirm this bug on the released Feisty, when upgrading with apt-get --dist-upgrade. I have not tried the CD version.
system-services was installed: so apt-get install system-services did not make a difference.
apt-get --reinstall install system-services did not update the files either.
apt-get remove followed by install would remove ubuntu-base as well, and I didn't want to try that..
After updating exactly like Flapane did, it works but as Jeff said in the middle of the boot process. However I don't need control-d to get to the login prompt, I just press enter after booting.

I think it is related to #96777 which is related to #89314

Frederic Wenzel (freeed) wrote :

@Flapane: This is how a corrupt file looks like:

# tty1 - getty
#
# This service maintains a getty on tty1 from the point the system is
# started until it is shut down again.

start on runlevel 2
start on runlevel 3
start on runlevel 4
start on runlevel 5

stop on runlevel 0
stop on runlevel 1
stop on runlevel 6

respawn
/sbin/getty 38400 tty1exec /sbin/getty 38400 tty1

Flapane (flapane) wrote :

Yes, Frederic, my file looked exactly like your corrupted one ;)

Frederic Wenzel (freeed) wrote :

Yeah. Glad I have SSH access to the box, too. Fixing the last line made the issue go away for me too.

Flapane (flapane) wrote :

Yep, I used a livecd chroot

Colin Watson (cjwatson) wrote :

Bug 89314 is a different bug, even though it was later hijacked to describe this problem. Deduplicating.

Colin Watson (cjwatson) wrote :

upstart (0.3.8-2) gutsy; urgency=low

  * Fix broken migration of old-style 'respawn process' stanzas which
    produced corrupted 'exec' stanzas. Try to fix up files previously
    corrupted by this. LP: #95210

 -- Colin Watson <email address hidden> Mon, 17 Sep 2007 02:41:08 +0100

Changed in upstart:
status: Confirmed → Fix Released
Taupter (taupter) wrote :

I still have problems here with it (Kubuntu Gutsy on ia32, updated from Feisty, up-to-date as of 9th October 2007).
When I switch to tty*, there's a black screen with a white blinking cursor with no login messages at all. When I use Magic SysRq keys no message is printed on screen. I'm still able to switch to X after that.
The funny part is I'm able to log in in tty1-6, despite having no visual clues about it, and being able to run programs (I logged as root and ran "startx -- :1" and a new X desktop.).

There's a sample of a /etc/event.d/tty* file:
# tty1 - getty
#
# This service maintains a getty on tty1 from the point the system is
# started until it is shut down again.

start on runlevel 2
start on runlevel 3
start on runlevel 4
start on runlevel 5

stop on runlevel 0
stop on runlevel 1
stop on runlevel 6

respawn
exec /sbin/getty 38400 tty1

I notice something that may be important related to this (I had the same problem).

when I did an "apt-get update; apt-get upgrade" and doing it multiples times to upgrade, I always got the message that package "linux-generic linux-headers-generic linux-image-generic" where kept back. but doing "apt-get dist-upgrade system-services" updated them.

doing "apt-get dist-upgrade system-services" didnt helped.
I have no "/etc/event.d/" directory
but the file "/etc/init/tty1.conf" contain this:
"# tty1 - getty
#
# This service maintains a getty on tty1 from the point the system is
# started until it is shut down again.

start on stopped rc RUNLEVEL=[2345]
stop on runlevel [!2345]

respawn
exec /sbin/getty -8 38400 tty1

"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers